RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-28-2020, 08:21 AM   #1
Junior Member
 
Join Date: Jul 2019
Posts: 2
2012 35K Electrical Issue

Hey, friends.

We keep our motorhome in covered storage and use it often. We are getting ready for a 19 day road trip. Last week, we took it in and had the oil changed and fluids/hoses checked for our trip. All was fine. About four days ago we went to check on it like we do every week or so. The engine started just fine. But the dash battery light was on and stayed on after starting. The belts are all in place. When we turned the engine off the battery light stayed on, but much more dimly than when the engine was on. We flipped both battery switches off that are above the door...and the dash battery light was still dimly lit. We repeated the startup and shut down procedure several times and it was the same...even with the battery switches above the door turned off, the dash battery light was dimly lit.

Frustrated, we left it and came home...calling the mobile repairman, who we have not heard back from yet.

In the meantime, we went back to the motorhome yesterday and the engine started fine....and the battery light on the dash went off like it should when we started it. We let it run a bit...hoping it was a fluke. Shut it down, including turning the two battery switches over the door off, and restarted....and the battery light stayed on again. Shut the engine down...and the battery light was dim, but definitely on. Turned the battery switches over the door off....and the dash battery light was still dimly lit.

And the kicker...

The engine started even with the two battery switches over the door in the off position.

Im no mechanic....but here are my clues in addition to the above...

1) When we had a dead engine battery before, we depressed the emergency button on the dash to start the engine using the brand new house batteries and it would not start, click or anything, so is that emergency switch on the dash doing anything? Could that be related?

2). The steps will not retract or extend until the two switches above the door are in the on position and the engine key is in the on position. This is true even when we discovered that the engine would start even with those switches off...no step movement unless the switches were on and the engine is on.

3) all three batteries are brand new...within the last four months or so.

4) Everything seems to be working as it should inside the coach when the engine and generator is on....with the exception of the main bathroom vanity light that is blowing the 20amp fuse ...I switched that fixture to LED lightbulbs and they all come on...then it blows the fuse. We have had the LED bulbs in the fixture for almost a year without problems, though. I dont see how that might be related to our big problem, though. I have ordered a new fixture that should be here this week...and i am going to try regular light bulbs in it in case there is some issue with one of the the LED bulbs.

If anyone can give us some ideas on what to look for or what might be causing this problem, I would appreciate your input!

Thanks,
Vince
Galveston, TX
VincePAC is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-01-2020, 07:23 AM   #2
Junior Member
 
Dalone55's Avatar
 
Join Date: Jul 2020
Posts: 16
Greetings Vince:
Your problem did not fall on deaf ears. It just seems rather complicated. First off, what year/model are we speaking of? You mention three batteries, mine has six. You can automate a signature by clicking on USER CP in one of the secondary tabs above, still working on mine.

Just a wild guess: Inspect for rodent damage, especially under your rig. I saw a squirrel 20' away from mine yesterday. I will start trapping (live trap) tomorrow. Make sure to release anything you catch at least five miles away.

Regards,
Robert
__________________
'02 Fleetwood Bounder 39r: Cummins TurboDiesel ISB 300 HP / Allison 3000
Trailering 1989 classic VW Bug
NW New Mexico
Dalone55 is offline   Reply With Quote
Old 08-04-2020, 04:13 AM   #3
Senior Member
 
Join Date: Jul 2019
Posts: 130
The switches above the door do not prevent you from starting the engine, but they may prevent charging properly. They will also prevent the step from working if they are off.

I suggest you remove the negative cable from both your engine battery and house batteries. Sometimes the relay gets weird and removing the negatives for a minute or two will let them reset. This might explain why the booster switch did not work properly.
SavnTheWales is offline   Reply With Quote
Reply

Tags
electric, electrical



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fleetwood Southwind 35K :: 2019 Fleetwood Southwind 35K jyjcbs iRV2 Owners Registry 0 01-10-2019 01:56 PM
16 Bounder 35K :: 2016 Fleetwood 35K computerguy iRV2 Owners Registry 0 01-19-2018 05:40 PM
Holiday Rambler Vacationer 35K vs. Fleetwood Bounder 35K klebs Class A Motorhome Discussions 7 04-01-2017 10:12 AM


All times are GMT -6. The time now is 04:02 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.