Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-06-2021, 12:29 PM   #1
Senior Member
 
Join Date: Jan 2013
Location: Huntsville Al
Posts: 137
Aux battery switch not working

On a 2018 Southwind 36P my chassis battery got low and I needed to use the Aux switch to start the RV. When pressed, the light does not come on, there is no relay click sound, and no power to the battery. I have checked the fuses in the power control module, in the cab and all coach fuses. I was able to start the RV by running jumper cables from the coach batteries to the chassis battery, but the aux switch would be much easier if I can get it working.

Any ideas ?
Jimg is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-06-2021, 12:56 PM   #2
Senior Member
 
rvbiker45's Avatar


 
Newmar Owners Club
Spartan Chassis
Join Date: Apr 2015
Location: Dallas, TX area
Posts: 510
If you have the B.I.R.D. system, probably located in the electrical panel with the transfer switch, check the fuses on that fuse block. I think there are 5 fuses on the B.I.R.D. module.

If they are all OK, pull the Start Booster switch out of the panel and verify that all the wires are inserted in the back of the switch. I think there are four tabs on the negative side of the switch and one on the positive side.
__________________
Don and Marilynn
'04 Newmar Dutch Star 4010
Spartan Chassis/Cummins ISL 400
rvbiker45 is offline   Reply With Quote
Old 04-07-2021, 08:37 PM   #3
Junior Member
 
Join Date: Apr 2020
Posts: 8
Sounds like the Solenoid needs replacing..
Lifesahwy is offline   Reply With Quote
Old 04-08-2021, 06:35 AM   #4
Senior Member
 
Join Date: Jan 2013
Location: Huntsville Al
Posts: 137
Thanks. I will remove the switch and see if I have any power. I have been unable to locate the solenoid so far to check it.
Jimg is offline   Reply With Quote
Old 04-08-2021, 07:23 AM   #5
Senior Member
 
computerguy's Avatar
 
Join Date: Jul 2010
Location: FT on the Road
Posts: 2,806
The solenoids are inside the BCC. The BCC will be near your batts and inverter usually in a basement compartment for Fleetwood products. The BCC is a gloss black and label approx 8"x8"x 5"
__________________
I don't make it much on here anymore so will not see your reply to my comment. Drop me a direct message and when I come back on I will see it.
Cheers!
computerguy is offline   Reply With Quote
Reply

Tags
battery, switch



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Aux 1 / Aux 2 Switch - 2020 Coachmen Mirada 35BH greybirds2 Forest River Owners Forum 3 07-16-2020 11:59 AM
Aux start switch not working Tunez Class A Motorhome Discussions 8 10-09-2016 07:29 AM
My Aux Start Battery Switch Is Not Working Yellowboat Winnebago Industries Owner's Forum 14 04-06-2014 08:01 AM
battery disconnect switch not working...no battery power kennyb79 RV Systems & Appliances 2 08-27-2012 06:46 AM
Aux Start not working hawaiicop Winnebago Industries Owner's Forum 3 01-01-2008 07:53 AM


All times are GMT -6. The time now is 06:28 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.