Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-28-2022, 11:04 AM   #1
Junior Member
 
Join Date: Sep 2021
Location: Sherwood,Michigan
Posts: 3
Blog Entries: 1
Battery replacement issue

My 2015 Fleetwood Storm F-53 chassis V-10 362hp coach batteries died so I replaced them and now the generator, leveling system work but everything else is dead. Anyone have any ideas?
ilash is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-28-2022, 11:11 AM   #2
Senior Member
 
Join Date: Aug 2019
Location: Eastern outskirts of Dallas, TX
Posts: 1,890
Check for more wires dangling that were supposed to be connected.

Make sure the Use/Store switch is in the Use position.
__________________
‘91 Ultrastar Champion‘02 Georgie Boy Landau 8.1l Workhorse
‘03 Jeep Wrangler TJ 2018 Jeep Wrangler JK toad
MrMark52 is offline   Reply With Quote
Old 06-28-2022, 11:46 AM   #3
Senior Member
 
Tha_Rooster's Avatar
 
Join Date: Aug 2008
Location: Georgia
Posts: 7,763
Quote:
Originally Posted by ilash View Post
My 2015 Fleetwood Storm F-53 chassis V-10 362hp coach batteries died so I replaced them and now the generator, leveling system work but everything else is dead. Anyone have any ideas?


1) Hooked up wrong
2) shorted out fuse hooking up
3) what voltage is the chassis batteries?
__________________
2007 Fleetwood Revolution LE 40V
Tha_Rooster is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
House Battery Replacement Installation Issue msmallfield Class A Motorhome Discussions 9 04-24-2022 10:30 PM
18 Vegatouch issue, or battery issue jeffnjen Entegra Owner's Forum 16 10-23-2017 08:32 PM
Chassis battery issue/Battery boost Ranger Rick Winnebago Industries Owner's Forum 8 02-21-2012 10:21 AM
Battery replacement possible issue rcatter Newmar Owner's Forum 5 04-12-2011 09:15 AM
Southwind 36D Issue after issue after issue.... fixn2gocamp Fleetwood Owner's Forum 4 10-21-2009 07:05 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 10:23 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.