Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-06-2016, 05:37 PM   #1
Member
 
Gdgb23's Avatar
 
Join Date: Dec 2014
Posts: 30
Breaker or fuse for Vacuflush?

2015 excursion 35b

Vacuflush is inop. Appears no power getting to it. No status light, no red or green.

Factory said fuse was in power control bay, it's not. Then they said breaker under sink. Nothing there either. No breaker or fuse that I can see near the vacuum pump either.

Does anyone know where the fuse or breaker is?


2015 Fleetwood Excursion 35b
Towing 2013 Jeep Rubicon
Gdgb23 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-06-2016, 07:47 PM   #2
Senior Member
 
Join Date: Feb 2014
Location: Pensacola FL
Posts: 1,451
Look for a breaker in the compartment where the inverter is located, on a 35K it's the bay to the left of the entry door. Little metal cube with two prongs on it about an inch long. There is a little button on the metal housing,
__________________
Brenda & AL
2017 Thor Venetian, T42 "Groot"
2020 Chevy Sonic, 2019 KTM 790 Duke
z3406 is offline   Reply With Quote
Old 01-07-2016, 05:45 AM   #3
Senior Member
 
DebbieMH's Avatar


 
Entegra Owners Club
Join Date: Oct 2012
Location: LA - Lower Alabama
Posts: 3,685
Check the fuses and the breaker, but that may not be the problem. There is a silver box on the back passenger side bottom compartment. Look in there and make sure one of the wires hasn't come loose. When we had a 2014 Excursion 35b - we had a cronic problem with the power not getting to the toilet. Good luck - maybe do a search here on it - maybe someone did find an easy solution.
__________________
Lynn & (Dan in spirit ) Fur kids Carl & Alvin
Full time - home base is a lot @ Bella Terra
2015 Entegra Anthem 44B with HWH Active Air
2021 Grand Cherokee Summit
DebbieMH is offline   Reply With Quote
Old 01-08-2016, 10:49 AM   #4
Junior Member
 
cornelljd's Avatar
 
Join Date: Aug 2015
Location: Byron Center, Michigan
Posts: 18
Send a message via AIM to cornelljd Send a message via MSN to cornelljd Send a message via Yahoo to cornelljd
Ours was located under the step by the house batteries. Very hard to find. Took me several days of looking to find it. Of course it was in the very bottom of the box and had to disconnect several harness to get access to it. The reset button is very small and the circuit bracker is not that large also. We have a 2015 FeetWood Terra 35K. The rep. from FleetWood was very helpful and patient with us since we just started a two week trip and no toilets!!!!!
cornelljd is offline   Reply With Quote
Reply

Tags
fuse



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Searching for OBD II Fuse - 2006 F53 195pilot Ford Motorhome Chassis Forum 10 08-13-2015 10:42 PM
20 amp Stay-in-play fuse keeps blowing Donut lover Toads and Motorhome Related Towing 11 03-19-2015 06:00 AM
Norcold 1200 W/ Amish CU Intermittent Fuse Blow ProjectPro RV Systems & Appliances 1 03-02-2015 04:41 PM
Fuse for roof lights ?? caheath Workhorse and Chevrolet Chassis Motorhome Forum 3 02-21-2015 08:30 PM
12VDC 30A circuit breaker tripping TexasSkunk Tiffin Owner's Forum 2 08-18-2014 12:57 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 05:34 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.