Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-20-2015, 10:01 AM   #1
Junior Member
 
Join Date: Apr 2015
Posts: 2
Control Panel

Readings no longer showing on KIB control panel for tank levels or main battery voltage. The aux voltage still works and gives a reading in the same window but the main button does not produce a reading. Tank level buttons and main button are all on the top of a board. Saw this exact problem posted several years ago and resolved by replacing a fuse, but thread is no longer active. I've searched and searched for this fuse and can't find it. Any suggestions? My fuses are all checking out good in the BCC and in the distribution center under the lav sink.
thanks,
Chris
2004 Pace Arrow 37C
cmwood70 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-20-2015, 10:27 AM   #2
Community Administrator
 
JohnRR's Avatar


 
Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Sep 2010
Location: Marquette, Michigan "Da UP" & Lehigh Acres Fl
Posts: 21,405

I wish I could give you an answer but I've never given it any thought.
__________________
John & Cathy R.
06 Pace Arrow 38L Workhorse W24
08 14 Lincoln MKX AWD, 06 Lincoln Mark LT 4X4
See My Pace Arrow Upgrades
JohnRR is offline   Reply With Quote
Old 04-20-2015, 09:39 PM   #3
Junior Member
 
Join Date: Apr 2015
Posts: 2
Well, I figured it out. Retested the fuses in the BCC 115 Rev G with the voltmeter on each side and found the bad fuse. It is the third one down on the right labeled LP DET. Everything in the control panel works now! My lesson learned...don't just pull the fuse and look at it. Test the continuity with a volt meter to each side and you should get the same voltage or an ohm meter to test continuity once it is pulled out. Hope someone else can use this.
Chris
cmwood70 is offline   Reply With Quote
Old 04-20-2015, 10:39 PM   #4
Community Administrator
 
JohnRR's Avatar


 
Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Sep 2010
Location: Marquette, Michigan "Da UP" & Lehigh Acres Fl
Posts: 21,405
Thank you for the update they are important, you never know who might get use from it down the road.
__________________
John & Cathy R.
06 Pace Arrow 38L Workhorse W24
08 14 Lincoln MKX AWD, 06 Lincoln Mark LT 4X4
See My Pace Arrow Upgrades
JohnRR is offline   Reply With Quote
Reply

Tags
panel



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Where o where is my control panel RepoPimp Class A Motorhome Discussions 13 06-30-2014 09:59 PM
Powergear Jacks no panel lights JWLSC Fleetwood Owner's Forum 3 06-19-2014 08:10 PM
HWH Control Panel Problem pittso Alpine Coach Owner's Forum 18 05-19-2014 04:10 PM
O6 Providence dash hvac control panel seasonedsole Fleetwood Owner's Forum 7 04-05-2014 04:56 PM
Bounder: Fuse panel location? rgreen45 Fleetwood Owner's Forum 5 10-28-2013 05:37 AM


All times are GMT -6. The time now is 11:26 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.