Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-19-2021, 05:13 PM   #1
Senior Member
 
Join Date: Mar 2015
Location: Brandon, FL and Franklinville, NY
Posts: 112
Dash air stopped working

The dash air on our 2015 Excursion 33D will not come on. The green light on the dash button will not come on either. Is the a fuse for this?
hdfxrs is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-19-2021, 06:06 PM   #2
Senior Member
 
Join Date: Jan 2012
Posts: 111
Quote:
Originally Posted by hdfxrs View Post
The dash air on our 2015 Excursion 33D will not come on. The green light on the dash button will not come on either. Is the a fuse for this?


Same thing happened to me a few months back(2012 Itasca Ellipse). It was a 25amp fuse/breaker. I reset it and everything worked. If in fact thatís the issue, I strongly suggest you isolate the cause. In my case I think the AC compressor ceased and caused to fuse to pop. Long story short. 100 miles after resetting the breaker my serpentine belt broke and left me on the side of the rode over Memorial Day.
bam565 is offline   Reply With Quote
Old 07-19-2021, 06:55 PM   #3
Registered User
 
Join Date: Jul 2016
Posts: 1,042
https://www.proairllc.com/design-eng...empcon-guides/
Massparanoia is offline   Reply With Quote
Old 07-22-2021, 09:02 AM   #4
Senior Member
 
Join Date: Mar 2015
Location: Brandon, FL and Franklinville, NY
Posts: 112
Thanks for the schematics. Fleetwood service tech says there is an inline automotive type fuse for the snowflake switch that must be blown. Says it should be under the dash, maybe in front of the passenger. I canít find any fuses as far as I can see. Canít trace the wires as they are taped together with many other wires and canít see how to see anything in front of the passenger seat.
hdfxrs is offline   Reply With Quote
Old 07-23-2021, 04:43 AM   #5
Senior Member
 
Hittntheroad's Avatar
 
Join Date: Mar 2016
Location: Morehead City NC
Posts: 351
On my previous Fleetwood Flair I traced my 25 amp fuse to the area above the emergency brake. It was wire tied to 2 other fuses just hanging under the dash. It took me days to find it. Very frustrating. No labels or nothing. I ended up removing the dash panel and tracing the red wire from the fan motor control switch to the fuse. You will probably find it starts off red from the switch and turns white at the fuse.
Attached Thumbnails
Click image for larger version

Name:	2CAF351A-36FB-47F7-A3F8-8B8A2BFE89F8.jpg
Views:	16
Size:	301.4 KB
ID:	336912   Click image for larger version

Name:	4C3EE284-7B69-457D-B6B8-5F68AFD2F5AA.jpg
Views:	14
Size:	221.0 KB
ID:	336913  

__________________
2016 Jayco Precept 31 UL
Hittntheroad is offline   Reply With Quote
Old 07-24-2021, 05:51 PM   #6
Senior Member
 
Join Date: Mar 2015
Location: Brandon, FL and Franklinville, NY
Posts: 112
Thanks. Iíll look again. How did you remove the dash panel?
hdfxrs is offline   Reply With Quote
Old 07-25-2021, 08:46 AM   #7
Senior Member
 
Hittntheroad's Avatar
 
Join Date: Mar 2016
Location: Morehead City NC
Posts: 351
Quote:
Originally Posted by hdfxrs View Post
Thanks. Iíll look again. How did you remove the dash panel?
Mine was fairly easy. The top of the dash came up exposing all the under dash wiring.
__________________
2016 Jayco Precept 31 UL
Hittntheroad is offline   Reply With Quote
Old 07-28-2021, 05:48 AM   #8
Junior Member
 
Join Date: Aug 2016
Posts: 18
My 2014 33D also lost dash air but it was more than the fuse. If I recall correctly it was an issue with the compressor. Good luck
Rogercaiazza is offline   Reply With Quote
Old 07-29-2021, 06:57 AM   #9
Senior Member
 
Join Date: Mar 2015
Location: Brandon, FL and Franklinville, NY
Posts: 112
Quote:
Originally Posted by Rogercaiazza View Post
My 2014 33D also lost dash air but it was more than the fuse. If I recall correctly it was an issue with the compressor. Good luck
Had a compressor issue two years ago and a leak in the front last year. Have taken as much of the dash apart as I can figure out, but canít find the fuse.
hdfxrs is offline   Reply With Quote
Old 07-29-2021, 11:39 AM   #10
Junior Member
 
Join Date: Jul 2021
Posts: 7
Mine works when I first turn it on tuns on nothing to write home about but it does blow cool air, but after 20 mins our so it peters out? New one on me?
Scottfree1 is offline   Reply With Quote
Old 07-29-2021, 11:53 AM   #11
Senior Member
 
Join Date: Jul 2017
Posts: 166
Quote:
Originally Posted by Scottfree1 View Post
Mine works when I first turn it on tuns on nothing to write home about but it does blow cool air, but after 20 mins our so it peters out? New one on me?
That's probably just low freon. Go to AutoZone, they will loan you a set of AC manifold gauges. Pick up a couple of cans of R134a at the same time, because the gauge set is the best way to add gas. Make one of the cans the type with leak detector dye in it.

If the gauges indicate low gas, add the new R134a, starting with the dyed one. If the problem returns within a few months, you can get a UV flashlight and eyeglasses from Harbor Freight for under $10, and look under the hood in the dark for glowing green indicator dye under UV light.
Rickinnocal is offline   Reply With Quote
Old 07-29-2021, 12:17 PM   #12
Senior Member
 
Xmcdog's Avatar
 
Join Date: Dec 2019
Location: Nova Scotia
Posts: 1,623
Quote:
Originally Posted by Scottfree1 View Post
Mine works when I first turn it on tuns on nothing to write home about but it does blow cool air, but after 20 mins our so it peters out? New one on me?
Sounds like it is icing up. Usually an airflow issue but low refrigerant can give much the same result. The kicker with yours is that it works for 20 mins then fades. Classic low airflow. Blocked air filter? Air leakage? Loose compressor belt will also give a similar issue. Hope this helps.
__________________
Jeff and Annette Smith
04 Glendale Titanium 24E29 Fifth
2011 GMC Diesel 2500 HD
Xmcdog is offline   Reply With Quote
Old 07-30-2021, 03:35 PM   #13
Junior Member
 
Join Date: Aug 2017
Posts: 17
Does your fan motor work? If not, it's the relay located in the first compartment on the driver's side. There are 2 relays there. It's the lighter color gray one' I looked everywhere under the dash for the relay, but the ones I found there weren't the problem.
stu white is offline   Reply With Quote
Old 07-31-2021, 07:06 AM   #14
Senior Member
 
Join Date: Mar 2015
Location: Brandon, FL and Franklinville, NY
Posts: 112
Quote:
Originally Posted by stu white View Post
Does your fan motor work? If not, it's the relay located in the first compartment on the driver's side. There are 2 relays there. It's the lighter color gray one' I looked everywhere under the dash for the relay, but the ones I found there weren't the problem.
My fan works. Snowflake button does not light up or turn AC on.
hdfxrs is offline   Reply With Quote
Reply

Tags
air, dash, dash air



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Baystar 3305 2007 Dash Air Stopped Working. FannyBayStar Newmar Owner's Forum 1 08-06-2018 01:53 PM
1995 Triple E in dash air conditioning has stopped working, need wiring diagram. B Trevathan Class A Motorhome Discussions 8 09-09-2014 04:02 PM
Dash Air Fan, Power window and Power Seat Stopped working thirdwall Workhorse and Chevrolet Chassis Motorhome Forum 5 07-12-2014 01:05 PM
Dash air and heat stopped working thebings Class A Motorhome Discussions 8 10-10-2013 02:28 PM
Dash air stopped working? Donna & Chuck Alpine Coach Owner's Forum 8 06-26-2006 05:24 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 07:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.