Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-20-2022, 06:47 PM   #1
Senior Member
 
Leary54's Avatar
 
Freightliner Owners Club
Join Date: Dec 2011
Posts: 240
Dash stopped working

I have a 2008 Fleetwood Bounder diesel pusher. I changed out LBCU and did not resolve the issue. I looking at the wires that go to the gauges. Frieghtliner won’t help me said I have to go though a Frieghtliner dealer and dealer says there are no wiring harnesses in the system. Any help out there would be appreciated. Thanks
Leary54 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-20-2022, 08:23 PM   #2
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 27,896
Do you have this document on testing the LBCU ?
Attached Files
File Type: pdf LBCU info and diagnostics.pdf (220.3 KB, 6 views)
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 09-21-2022, 09:03 AM   #3
Senior Member
 
Leary54's Avatar
 
Freightliner Owners Club
Join Date: Dec 2011
Posts: 240
Thanks, I do not have this manual.
Leary54 is offline   Reply With Quote
Old 09-21-2022, 10:38 AM   #4
Senior Member
 
RichKimball's Avatar


 
Fleetwood Owners Club
Freightliner Owners Club
Join Date: Feb 2012
Location: Central Arkansas
Posts: 1,198
Quote:
Originally Posted by Leary54 View Post
I have a 2008 Fleetwood Bounder diesel pusher. I changed out LBCU and did not resolve the issue. I looking at the wires that go to the gauges. Freightliner won’t help me said I have to go though a Freightliner dealer and dealer says there are no wiring harnesses in the system. Any help out there would be appreciated. Thanks
Very sad to hear that Gaffney won't offer advice.

There is the separate wiring harness to each gauge as you know. FL has recommended that the newer black colored harnesses be used. Most that have changed say that worked for them. If yours are white, then change might be warranted. You can try hooking up one gauge at a time and testing.

I'll look around for the pn of the harnesses and post if I can.
__________________
2008 Fleetwood Bounder Diesel 38S, Flat tow-2015 Cherokee Trailhawk
Richard (KG5JAQ) & Margaret Kimball w/Shih-Tzu 'Charley'
RichKimball is offline   Reply With Quote
Old 09-21-2022, 10:41 AM   #5
Senior Member
 
RichKimball's Avatar


 
Fleetwood Owners Club
Freightliner Owners Club
Join Date: Feb 2012
Location: Central Arkansas
Posts: 1,198
Attached is a thread that contains the harness pn's. Post #8. Best of luck.https://www.irv2.com/forums/f26/gauges-483576.html
__________________
2008 Fleetwood Bounder Diesel 38S, Flat tow-2015 Cherokee Trailhawk
Richard (KG5JAQ) & Margaret Kimball w/Shih-Tzu 'Charley'
RichKimball is offline   Reply With Quote
Old 09-24-2022, 03:51 PM   #6
Senior Member
 
Leary54's Avatar
 
Freightliner Owners Club
Join Date: Dec 2011
Posts: 240
Quote:
Originally Posted by RichKimball View Post
Very sad to hear that Gaffney won't offer advice.



There is the separate wiring harness to each gauge as you know. FL has recommended that the newer black colored harnesses be used. Most that have changed say that worked for them. If yours are white, then change might be warranted. You can try hooking up one gauge at a time and testing.



I'll look around for the pn of the harnesses and post if I can.


Thank you
Leary54 is offline   Reply With Quote
Reply

Tags
dash



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dash a/c stopped working faye Newmar Owner's Forum 15 07-31-2010 10:16 PM
Dash a/c stopped working faye MH-General Discussions & Problems 3 04-26-2010 11:55 AM
Dash Heater/AC Blower stopped working spat Workhorse and Chevrolet Chassis Motorhome Forum 1 10-21-2009 07:15 AM
Anyone stopped OR NOT stopped for pulling motorcycle trailer behind TT? tammyinwv Trailer Towing and Tow Vehicles Discussion 17 02-26-2007 09:54 PM
Dash air stopped working? Donna & Chuck Alpine Coach Owner's Forum 8 06-26-2006 06:24 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 03:11 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.