Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-28-2022, 09:58 PM   #1
Senior Member
 
Join Date: Oct 2012
Posts: 156
Question discovery 44h water pump losing prime

We just took our 2021 discovery 44h out of storage and found our water pump loses prime. Filled water tank with gravity fill, closed bypass and started pump. Faucets run good for a few seconds, even longer a few times, and then water stops. I flip the bypass and get it reprimed with city water pressure, only to have it lose prime again. No leak that i can see. Strainer is clean.
slate is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-29-2022, 06:30 AM   #2
Senior Member
 
Join Date: Aug 2019
Location: Eastern outskirts of Dallas, TX
Posts: 1,611
Probably not losing its prime but being starved of water.

Make sure the valving in your wet bay is positioned properly. Easy to have things closed when they should be open and vice versa.

You could have a stuck check valve on the suction side of the pump.

And finally - the pump diaphragms do get stiff or possibly a hole in them. Easy to get, easy to replace.

But you need to make sure there is a free flow of water to the pump suction side first.
__________________
Ď91 Ultrastar Champion
Ď02 Georgie Boy Landau 8.1l Workhorse - Ď03 Jeep Wrangler TJ 2018 Jeep Wrangler JK toad
MrMark52 is offline   Reply With Quote
Old 05-29-2022, 08:11 AM   #3
Member
Official iRV2 Sponsor
 
Join Date: Feb 2021
Posts: 415
When you turn on the water pump, does it prime up and shut off? That would tell us if you have everything set properly. If it keeps running, then you have a valve somewhere open. Do you have a watermiser in the shower? If so, check the position of that valve. The water filter out of the housing and see if you keep pressure that way.
__________________
.
NATIONAL INDOOR RV CENTERS - NIRVC
Sales | Service | Indoor Storage | Wash
Collision Repair & Paint Restoration


SM Nashville 972-697-6325
Bobby Dowdle is offline   Reply With Quote
Old 05-29-2022, 08:19 AM   #4
Senior Member
 
Join Date: Oct 2012
Posts: 156
It wouldn't prime at all when I first filled water. Opened the bypass valve and got water through all the fixtures. Then closed the bypass and tried the pump. Sure enough, it worked......for a about a minute then appeared to lose prime. It had normal pressure also. It just quit pumping water, and the pump kept running. Have cycled it like this probably 10 times always with the same result. I'm familiar with the valve settings. I've had numerous RVs and 3 motorhomes with this same setup.
slate is offline   Reply With Quote
Old 05-29-2022, 08:21 AM   #5
Senior Member
 
Join Date: Oct 2012
Posts: 156
Quote:
Originally Posted by Bobby Dowdle View Post
When you turn on the water pump, does it prime up and shut off? That would tell us if you have everything set properly. If it keeps running, then you have a valve somewhere open. Do you have a watermiser in the shower? If so, check the position of that valve. The water filter out of the housing and see if you keep pressure that way.
Yes it primes up pumps water for a bit, then no water, pump keeps running.
slate is offline   Reply With Quote
Old 05-29-2022, 08:25 AM   #6
Member
Official iRV2 Sponsor
 
Join Date: Feb 2021
Posts: 415
Do you have a winterize valve in the bay? Is it closed? When it primed up, does stay that way if you donít turn on any faucets? How full is the fresh tank?
__________________
.
NATIONAL INDOOR RV CENTERS - NIRVC
Sales | Service | Indoor Storage | Wash
Collision Repair & Paint Restoration


SM Nashville 972-697-6325
Bobby Dowdle is offline   Reply With Quote
Old 05-29-2022, 08:32 AM   #7
Senior Member
 
Join Date: Oct 2012
Posts: 156
Quote:
Originally Posted by Bobby Dowdle View Post
Do you have a winterize valve in the bay? Is it closed? When it primed up, does stay that way if you donít turn on any faucets? How full is the fresh tank?
Stays primed up as far as i can tell. It pressures up and cuts out. I open a couple faucets to flush out the antifreeze and after a few seconds it loses prime. Pump "freewheels" and doesn't stop, even when i shut off the faucets.
slate is offline   Reply With Quote
Old 05-29-2022, 08:36 AM   #8
Senior Member
 
Join Date: Oct 2012
Posts: 156
I'm going to check for a winterize valve, but i don't believe it has one. The dealership winterized it before we bought it.
slate is offline   Reply With Quote
Old 05-29-2022, 08:36 AM   #9
Member
Official iRV2 Sponsor
 
Join Date: Feb 2021
Posts: 415
Sounds like the pump has an issue. If you google the pump model, you can search for pressure adjustment. That will show you where the Allen head screw is in the bottom of the pump. You can follow the instructions to see if that will correct the issue. If not, you will probably need to replace the pump.
__________________
.
NATIONAL INDOOR RV CENTERS - NIRVC
Sales | Service | Indoor Storage | Wash
Collision Repair & Paint Restoration


SM Nashville 972-697-6325
Bobby Dowdle is offline   Reply With Quote
Old 05-29-2022, 11:26 AM   #10
Senior Member
 
ArtJoyce's Avatar
 
Monaco Owners Club
Freightliner Owners Club
Holiday Rambler Owners Club
Join Date: Sep 2019
Location: Thornville, Ohio
Posts: 2,299
I'm not sure you have an issue. I think what happens is it starts to pump, but the hot water tank is empty. With almost resistance to fill with water. At that time water stops running from the we faucet. You switch the bypass it stops filling the tank and water comes out of the faucets.

Give it 10 minutes to fill the tank and open a hot water faucet to bleed all the air. I think what your are seeing is normal.
__________________
Art & Joyce
Thornville, OH
35' DP Endeavor being pushed by a Kia Soul
ArtJoyce is offline   Reply With Quote
Old 05-29-2022, 11:27 AM   #11
Senior Member
 
ArtJoyce's Avatar
 
Monaco Owners Club
Freightliner Owners Club
Holiday Rambler Owners Club
Join Date: Sep 2019
Location: Thornville, Ohio
Posts: 2,299
Ps: make sure you have enough water in the FW tank. 20 plus gallons.
__________________
Art & Joyce
Thornville, OH
35' DP Endeavor being pushed by a Kia Soul
ArtJoyce is offline   Reply With Quote
Reply

Tags
cover, discovery, pump, water, water pump



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SureFlo pump losing prime Alpine36 Alpine Coach Owner's Forum 12 04-03-2021 07:46 PM
19 Discovery LXE 44H kvhookj Fleetwood Owner's Forum 11 04-08-2019 12:36 AM
Losing prime on fresh water pump Mark1959 Class A Motorhome Discussions 7 09-05-2018 02:18 PM
2018 Fleetwood Discovery LXE 44H - Video Distribution Radarthis Class A Motorhome Discussions 17 05-02-2018 10:45 PM
rv water pump losing prime kurtwm Class C Motorhome Discussions 2 05-26-2012 06:12 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 10:54 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.