Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-29-2021, 02:51 PM   #1
Junior Member
 
Join Date: Nov 2021
Posts: 3
Electrical outlets not working on driver side

I have a 2015 Fleetwood bounder 35K. I plugged in a space heater and the electrical outlets quit working on the driver side dinette and sofa. I found the GFI in the rear bathroom and it was fine. But I am unable to find any other GFIs inside or outside the motorhome. I thought maybe another GFI had popped but cant find anything. I checked all the breakers they were fine. The inverter works fine. Any ideas.
Viperwife is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-29-2021, 03:02 PM   #2
Senior Member
 
hayward3411's Avatar
 
Join Date: Feb 2015
Location: Huntingtown, MD
Posts: 741
On the side of your inverter they're 2 resettable push fuses, check them out.
__________________
Earl & Sharon, 2008 Fleetwood Expedition, ISB 6.7
1995 Jeep YJ/2013 Chevy Sonic
hayward3411 is offline   Reply With Quote
Old 12-04-2021, 01:24 PM   #3
Senior Member
 
Join Date: Jan 2013
Location: Huntsville Al
Posts: 154
Be sure you did not blow a breaker on the power supply coming into your coach. You might want to check to make sure you have 120 v at both sides of the supply plug.
Jimg is offline   Reply With Quote
Old 12-05-2021, 04:53 AM   #4
Senior Member
 
Toribk's Avatar
 
Join Date: Oct 2011
Posts: 532
Are you sure there is no GFI outlet near the kitchen?

Sent from my SM-G955U using iRV2 - RV Forum mobile app
Toribk is offline   Reply With Quote
Old 12-05-2021, 05:59 AM   #5
Senior Member
 
Join Date: Sep 2009
Location: Central Indiana
Posts: 1,139
Probably you can find two more gfi outlets on the under side of the coach floor in two different storage bins. One in the water bay that is used to proved heat if needed to protect water and sewer lines from freezing. The other would be about center bin on passenger side used to power anything outside in patio area.
mrboyer is offline   Reply With Quote
Old 12-05-2021, 08:23 AM   #6
Senior Member
 
computerguy's Avatar
 
Join Date: Jul 2010
Location: FT on the Road
Posts: 2,950
OP should look at this thread. Similar issue and much more info to look at. https://www.irv2.com/forums/f107/ele...in-562719.html
computerguy is offline   Reply With Quote
Old 12-05-2021, 09:50 AM   #7
Junior Member
 
Join Date: Nov 2021
Posts: 3
Bingo! Found small electrical box under the sofa. Followed the wires to under the slide and found the problem. The electrical wire is tight and got caught on the slide while moving, pulled a wire right out of the electrical box. Fleetwood could have designed better. All fixed now!
Viperwife is offline   Reply With Quote
Reply

Tags
driver, electric, electrical



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Basement electrical outlets not working BounderMike Winnebago Industries Owner's Forum 13 06-29-2020 09:46 AM
2007 Vectra-Electrical outlets (3) not working Pijoycehb Winnebago Industries Owner's Forum 5 05-01-2019 11:33 AM
Electrical outlets not working on shore power DDLonghorn Thor Industries Owner's Forum 12 02-21-2019 05:19 AM
Two Interior Electrical Outlets Not Working dlduck Class A Motorhome Discussions 7 11-15-2015 02:40 PM
120v Electrical Outlets not working in 03 MDDS rbguinn Alpine Coach Owner's Forum 8 09-11-2008 07:35 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 03:43 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.