Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-10-2018, 09:20 PM   #1
Senior Member
 
Join Date: May 2010
Posts: 105
Engine Battery

Following the cold spell we had in central fl, tried to start the RV (2014 Fleetwood Bounder 35K), and nothing ... Finally RSA arrived and gave us a jump and it started up right away, ran engine for awhile.
turned it off and tried to restart and nothing ?? I kinda had that feeling that I shouldn't have turned it off, but then I couldn't run the engine all night.

Also our stairs were retracted and now they won't extend out, that's a long way down, had to go put up some stuff which we are using now for stairs but go down carefully.

Since the battery started on the jump at first turn, is the battery good? or since it wouldn't restart is it bad and needs replacing? we ran our RV just a couple of months ago when we went camping and everything appeared fine then.

thanks for any input.

Bill
stormy2000 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-11-2018, 01:01 AM   #2
Senior Member
 
daveandcarol's Avatar
 
Fleetwood Owners Club
Join Date: May 2013
Posts: 1,412
May not have run long enough to get a good charge. Since you could jump start easily and run on battery, it's probably not shorted out or freeze damaged. See if you have any headlights. If lights come on at all, battery terminals may be dirty or moisture in connections could have frozen enough to mess with good connection. Should check battery with voltmeter to see if any charge is present. AutoZone and others will test battery for free if you take it there.
Steps run off engine battery, automatically retract when engine starts.
__________________
Dave RVM#66 and Carol
1998 Pace Arrow Vision
Seeing the USA - 200 miles at a time
daveandcarol is offline   Reply With Quote
Old 01-11-2018, 01:07 AM   #3
Senior Member
 
daveandcarol's Avatar
 
Fleetwood Owners Club
Join Date: May 2013
Posts: 1,412
One more thing, as Lt. Colombo used to say. If you hadn't used the coach for 'a couple of months', it's possible a small electrical drain might have discharged the battery (not as likely on the engine battery but a possibility anyway, its possible the manufacturer put something on the wrong battery). If your battery is 3 years old, it might be getting a little weak from age. Checked the water level in it lately, or is it sealed type?
__________________
Dave RVM#66 and Carol
1998 Pace Arrow Vision
Seeing the USA - 200 miles at a time
daveandcarol is offline   Reply With Quote
Old 01-11-2018, 01:19 AM   #4
Senior Member
 
Join Date: Sep 2012
Posts: 8,055
I'd go invest in a battery charger and charge the battery in place. Then check out a maintainer or just top it off every week or so. A voltmeter will tel the state of charge well enough to know when to charge it. One is needed anyway for basic electrical troubleshooting. YMMV
nothermark is offline   Reply With Quote
Old 01-11-2018, 02:42 AM   #5
Senior Member
 
Arch Hoagland's Avatar
 
Monaco Owners Club
Workhorse Chassis Owner
Join Date: Aug 2002
Location: Clovis, CA, USA
Posts: 10,974
https://www.amazon.com/WirthCo-20108.../dp/B002OWFLC4


I would install a cutoff switch, use an external charger to completely charge the battery and see what happens after it is fully charged which could take several hours.

Then when you have it working use the knife blade switch to disconnect the battery so it doesn't happen again.

Is your battery maintenance free or do you need to add water to it?
__________________
2004 Monaco La Palma 36DBD, W22, 8.1, 7.1 MPG
2000 LEXUS RX300 FWD 22MPG 4020 LBS
Of all the things I've lost in life I miss my mind the most.
Arch Hoagland is offline   Reply With Quote
Old 01-11-2018, 08:09 PM   #6
Senior Member
 
Join Date: May 2010
Posts: 105
I believe the battery is maintenance free, I have request to fleetwood for that info, still waiting, thought about taking battery to autozone, and I read somewhere that when you remove the battery, you must relearn the bounder to the battery installed? not comprehending that part of relearning the bounder, is there some memory attached to the battery?
Thought about putting a battery charger on the engine battery, or maybe just making a schedule to run the bounder least once every week when stationary for a bit.
stormy2000 is offline   Reply With Quote
Reply

Tags
battery, engine



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1994 southwind - engine battery wont kick over engine stevenstoli Fleetwood Owner's Forum 7 11-01-2012 03:31 AM
Engine Pre-Lubricator - Pre-Lube Engine Oiler Doggy Daddy MH-General Discussions & Problems 2 06-22-2008 02:55 AM
Turbo Boost / Stop engine check engine warning... jtharley Winnebago Industries Owner's Forum 1 09-15-2006 11:20 AM
Service Engine Soon / Reduced Engine Power Nonno Workhorse and Chevrolet Chassis Motorhome Forum 6 08-22-2006 10:10 AM
Too much engine heat and engine noise rver1776 Workhorse and Chevrolet Chassis Motorhome Forum 4 08-01-2005 07:21 AM


All times are GMT -6. The time now is 04:51 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.