RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-09-2018, 07:19 PM   #1
Senior Member
 
Join Date: Jan 2012
Location: Boaz, Alabama
Posts: 534
Fleetwood 2007 Providence 40 X problem

I have a 2007 Fleetwood Providence 40X diesel, the RV has not been used for 1 year. I have been starting the engine and generator ever week. An alert has been going off as soon as the key is turned on, I have a (!) light on the dash. I had an experienced repairman check all the fuses, the electrical system and source can be located. The repairman suggested that I contact Catapillar and have them run a check on my Diesel engine to see if the engine is causing the alert. I am scared to drive it to a catapillar repair center in case the alert is concerning something serious. I am seeing $$$$ for the catapillar tect has to come to the RV, any ideas of what could cause the alert?
Tom222 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-09-2018, 10:48 PM   #2
Senior Member
 
Join Date: Jan 2012
Location: Boaz, Alabama
Posts: 534
Quote:
Originally Posted by Tom222 View Post
I have a 2007 Fleetwood Providence 40X diesel, the RV has not been used for 1 year. I have been starting the engine and generator ever week. An alert has been going off as soon as the key is turned on, I have a (!) light on the dash. I had an experienced repairman check all the fuses, the electrical system and source can be located. The repairman suggested that I contact Catapillar and have them run a check on my Diesel engine to see if the engine is causing the alert. I am scared to drive it to a catapillar repair center in case the alert is concerning something serious. I am seeing $$$$ for the catapillar tect has to come to the RV, any ideas of what could cause the alert?
Sorry the REPAIRMAN COULD NOT FIND THE SOURCE OF THE ALERT.
Tom222 is offline   Reply With Quote
Old 07-09-2018, 10:58 PM   #3
Senior Member
 
Fleetwood Owners Club
Join Date: Jun 2011
Location: Mississippi
Posts: 334
I would call chassis company first and see what the icon means...GlenB
GlenB is offline   Reply With Quote
Old 07-10-2018, 07:58 AM   #4
Senior Member
 
Fleetwood Owners Club
Join Date: May 2012
Posts: 176
Quote:
Originally Posted by Tom222 View Post
I have a 2007 Fleetwood Providence 40X diesel, the RV has not been used for 1 year. I have been starting the engine and generator ever week. An alert has been going off as soon as the key is turned on, I have a (!) light on the dash. I had an experienced repairman check all the fuses, the electrical system and source can be located. The repairman suggested that I contact Catapillar and have them run a check on my Diesel engine to see if the engine is causing the alert. I am scared to drive it to a catapillar repair center in case the alert is concerning something serious. I am seeing $$$$ for the catapillar tect has to come to the RV, any ideas of what could cause the alert?
Does the buzzer sound when this icon is displaying? My similar rig will occasionally show this icon (with buzzer) for low voltage when the main chassis batteries have been hammered during cold start and/or when the air pressure on the brake system is low. These faults clear after 30 seconds or so. On one of my air pressure gages, I have a poor ground somewhere and the gage will occasionally bounce around for a minute or two before it finally stabilizes and during that time the buzzer will sound.
__________________
Jim Brinsfield
07 Fleetwood Excursion
jbrinsfi is offline   Reply With Quote
Old 07-10-2018, 11:06 AM   #5
Moderator Emeritus
 
SarahW's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Oct 2011
Location: In a lawnchair
Posts: 11,979
Quote:
Originally Posted by GlenB View Post
I would call chassis company first and see what the icon means...GlenB
Or maybe post in the Cat section of the forum and see if those guys know what it means. Caterpillar Engine Forum - iRV2 Forums
__________________
.2012 Fleetwood Bounder 33C
SarahW is offline   Reply With Quote
Old 07-10-2018, 03:11 PM   #6
Senior Member
 
Tha_Rooster's Avatar
 
Join Date: Aug 2008
Location: Georgia
Posts: 6,402
Quote:
Originally Posted by Tom222 View Post
I have a 2007 Fleetwood Providence 40X diesel, the RV has not been used for 1 year. I have been starting the engine and generator ever week. An alert has been going off as soon as the key is turned on, I have a (!) light on the dash. I had an experienced repairman check all the fuses, the electrical system and source can be located. The repairman suggested that I contact Catapillar and have them run a check on my Diesel engine to see if the engine is causing the alert. I am scared to drive it to a catapillar repair center in case the alert is concerning something serious. I am seeing $$$$ for the catapillar tect has to come to the RV, any ideas of what could cause the alert?


It needs to be plugged into a computer. You say that the engine has been started every week for a year, if it wasn’t driven to temp probably worst than just letting it sit.
__________________
2007 Fleetwood Revolution LE 40V
Tha_Rooster is offline   Reply With Quote
Old 05-26-2019, 11:38 PM   #7
Senior Member
 
Join Date: Jan 2012
Location: Boaz, Alabama
Posts: 534
Update: Freightliner Suggested replacing All the gauges to solve the electrical dash panel issues. Freightliner told the repair shop that if that didn’t solve the problem, that Freightliner would repay me for the gauges. The repair shop is eating the labor, because it has been a continuous repair issue. We will see.
Tom222 is offline   Reply With Quote
Reply

Tags
fleetwood



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 Providence svfara Fleetwood Owner's Forum 2 12-30-2016 06:53 PM
2007 Fleetwood Providence, pickup in 2 weeks.... Lloyd in S.C. Class A Motorhome Discussions 12 09-15-2013 10:49 AM
Info on 2007 Fleetwood Providence 39 V Mrfoto Fleetwood Owner's Forum 3 07-24-2013 02:16 PM
problems with 2003 fleetwood providence Taco MH-General Discussions & Problems 5 09-22-2005 04:24 PM


All times are GMT -6. The time now is 08:02 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.