Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-19-2014, 06:18 AM   #1
Junior Member
 
Join Date: May 2014
Posts: 1
Blog Entries: 1
Fleetwood Discovery 2000

I have a 2000 Fleetwood Discovery. I recently brought it out of long storage and the batteries were down. I had to start it up using the house batteries switch. This was no issue as it eventually charged enough for me to get it home to plug it into voltage. The issue I am now having is that the dash warning lights are continuously panning across in rows, lighting individually like a slot machine when it is plugged in. I thought that it might be due to the battery issue, but not certain. Any advice would be greatly appreciated. Again, thank you for allowing me to participate on this site. I am new and will contribute to others when reasonable.
msmith7201 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-19-2014, 09:54 AM   #2
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 23,310
Cranking the engine with low voltage may have locked the Dash or the VDC ( Vehicle Data Center a Freightliner name.) In a diagnostic mode. Is your coach on a Freightliner chassis ?
Disconnect all batteries, and shore power ,make sure all batteries are fully charged, then re-connect . With this kind of problem a full shut down is the first thing to try.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 05-19-2014, 09:55 AM   #3
Moderator Emeritus
 
SarahW's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Oct 2011
Location: In a lawnchair
Posts: 11,980
Howdy and welcome to iRV2. Sorry you are having a problem. It sounds to me like that could be battery related. Are the batteries charged back up again? Which chassis is your Discovery on?
__________________
.2012 Fleetwood Bounder 33C
SarahW is offline   Reply With Quote
Reply

Tags
fleetwood



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2013 Fleetwood Discovery 40x VS 2014 Tiffin Phaeton 36GH Deucenut Class A Motorhome Discussions 24 02-25-2015 08:28 AM
Fleetwood Discovery vs Winnie Journey? Milehghcty Fleetwood Owner's Forum 41 06-06-2014 05:22 PM
Ideas for Installing small Safe in Fleetwood Discovery Statgeek Fleetwood Owner's Forum 5 02-11-2014 07:19 PM
Round amber light on dash of 2000 discovery davidf1 Fleetwood Owner's Forum 9 09-18-2013 08:01 PM
2000 Fleetwood Discovery dash vents not working JMA1181 Fleetwood Owner's Forum 26 07-24-2013 01:01 PM


All times are GMT -6. The time now is 12:37 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.