RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-22-2017, 07:36 AM   #1
Junior Member
 
Join Date: Oct 2017
Posts: 11
Fog lites not working

Good morning , I have a 1999 Fleetwood Southwind with non working fog lites. The dash switch works and the sealed beams have ben replaced. The only other thing I see is a relay that has as "Fog Lite" listed on it. Is this relay replaceable? It seems to be hard soldered to the circuit board in the panel. Thank you...Snuffy2
Snuffy2 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-22-2017, 07:49 AM   #2
Senior Member
 
Join Date: Aug 2010
Posts: 1,261
Have you tried the fog lites with the engine running?
I thought our coach fog lites didn't work either until I was told to try them with the engine running. They worked!!
NITEHAWK is offline   Reply With Quote
Old 10-22-2017, 11:39 AM   #3
Junior Member
 
Join Date: Oct 2017
Posts: 11
Thumbs up Non functioning fog lights

Thanks for the suggestion, That was the issue. Works well now.
Snuffy2 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
In a fog over my fog lamps. thesoundguy Monaco Owner's Forum 6 05-04-2016 07:46 PM
Tradewinds LTC fog lites bigdog National RV Owner's Forum 7 08-19-2013 12:41 PM
Ceiling lites wiring Old Marine Fleetwood Owner's Forum 12 01-16-2009 08:22 PM
HWH Jacks working, not working and working again? Bob&Pat Winnebago Industries Owner's Forum 6 06-08-2006 05:22 AM
Wiring Diagrams, Dash lites & Cruise Cutout? ronboc Workhorse and Chevrolet Chassis Motorhome Forum 3 07-03-2005 07:53 AM


All times are GMT -6. The time now is 01:59 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.