Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-14-2015, 07:22 PM   #1
Junior Member
 
Join Date: Aug 2014
Posts: 1
Blog Entries: 1
Furnace problem

Hi,
I have a Fleetwood Bounder 1999 in great shape and a bizzard problem with the furnace.
In cold temperature ex: 14C Inside and 2C outside it works perfect. But if I have 14 or 17C Inside and 8C outside the furnace give me only cool air, like the heating would not kick on
any body could help me.
By the way Danielle and I are looking for a Fleetwood Providence 39L year around 04 to 06 with a cumming engine if possible.
Thanks in advance,
Guy & Danielle
golfcargo is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-17-2015, 12:54 PM   #2
Senior Member
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Mcdonough, Ga.
Posts: 5,509
It is possible you have a loose connection in the furnace plug. As you know things shrink when cold expand when warmer. I would start with opening the furnace and cleaning the connector.
__________________
1998 Pace Arrow 35 ft. F53 Ford V10 2014 Honda CRV toad
32 years mechanic at Delta Air Lines 15 year motorhome service manager. 3 popups....2 travel trailers....5 motorhomes....loved them all.
ga traveler is offline   Reply With Quote
Old 04-17-2015, 02:37 PM   #3
Senior Member
 
mchero's Avatar
 
Join Date: Mar 2006
Location: Full Time USA
Posts: 2,193
Quote:
Originally Posted by golfcargo View Post
Hi,
I have a Fleetwood Bounder 1999 in great shape and a bizzard problem with the furnace.
In cold temperature ex: 14C Inside and 2C outside it works perfect. But if I have 14 or 17C Inside and 8C outside the furnace give me only cool air, like the heating would not kick on
any body could help me.
By the way Danielle and I are looking for a Fleetwood Providence 39L year around 04 to 06 with a cumming engine if possible.
Thanks in advance,
Guy & Danielle
Welcome to the forum Guy!

Every spring I pull the ignitor boards and clean then down with a contact cleaner. I'd then use an eraser and clean the contacts on the ignitor boards. Brush out the flue/heat exchanger & I'm good to go.


Check all connections & make sure your voltage to the furnaces are AOK. Also, that ignitor, sometimes the insulator will get a hairline crack & not ignite.
__________________
Robert & Deb
07 Discovery 39v FWS Full Timers, Henniker NH
1K solar - 05 Jeep Grand Cherokee
mchero is offline   Reply With Quote
Reply

Tags
furnace, ace



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suburban Furnace Shuts Off Oilburner53 RV Systems & Appliances 13 10-09-2014 11:19 AM
Furnace Issues Chiefbvfd Winnebago Industries Owner's Forum 9 05-20-2014 07:17 AM
Bad furnace control board? DarqMan Forest River Owners Forum 4 03-21-2014 03:30 PM
Furnace Ignition Issues 2012 Thor Daybreak 34KD gitarwmn Class A Motorhome Discussions 2 02-07-2014 09:36 AM
Duotherm furnace problem butchlanoue Class C Motorhome Discussions 4 11-22-2013 08:07 PM


All times are GMT -6. The time now is 06:31 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.