Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-16-2014, 08:57 AM   #1
Senior Member
 
Join Date: Jan 2012
Location: Taft, TN 38488
Posts: 584
Help electrical problem

Ok my GFI in the bathroom will not reset

Almost all of my wall electrical plugs will not work on DC or Generator

I checked the fuses, all seem ok

I checked the breakers , none tripped

Am I missing some secret?

Tom


Sent from my iPad using iRV2 - RV Forum


2007 Fleetwood Providence 40X
OurBigRVAdventure.com
Tom222 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-16-2014, 08:58 AM   #2
Senior Member
 
DegoRed's Avatar
 
Fleetwood Owners Club
Join Date: Jun 2012
Location: Austin, TX
Posts: 879
Bad GFI plug, those things break all the time. Go down to HD/Lowes and pick up a new one.
DegoRed is offline   Reply With Quote
Old 05-16-2014, 09:06 AM   #3
Senior Member
 
Join Date: Apr 2012
Posts: 1,526
I don't think a GFI plug will reset without power on it. Check powers source to GFI circuit to isolate problem.
Libero is offline   Reply With Quote
Old 05-16-2014, 09:14 AM   #4
Registered User
 
mel s's Avatar
 
Join Date: Mar 2010
Posts: 8,777
Quote:
Originally Posted by DegoRed View Post
Bad GFI plug, those things break all the time. Go down to HD/Lowes and pick up a new one.
Quote:
Originally Posted by Libero View Post
I don't think a GFI plug will reset without power on it.
Tom222
I agree
IMO, either you have a bad GFCI receptacle, or no power to that GFCI receptacle.
Mel
'96 Safari
mel s is offline   Reply With Quote
Old 05-16-2014, 09:14 AM   #5
Senior Member
 
Join Date: Jan 2012
Location: Taft, TN 38488
Posts: 584
Tried it on DC and Genny



Sent from my iPad using iRV2 - RV Forum


2007 Fleetwood Providence 40X
OurBigRVAdventure.com
Tom222 is offline   Reply With Quote
Old 05-16-2014, 09:16 AM   #6
Senior Member
 
Join Date: Jan 2012
Location: Taft, TN 38488
Posts: 584
Can I use a regular house GFI?
Not one made for RV?

Tom




Sent from my iPad using iRV2 - RV Forum


2007 Fleetwood Providence 40X
OurBigRVAdventure.com
Tom222 is offline   Reply With Quote
Old 05-16-2014, 09:23 AM   #7
Senior Member
 
DegoRed's Avatar
 
Fleetwood Owners Club
Join Date: Jun 2012
Location: Austin, TX
Posts: 879
Quote:
Originally Posted by Tom222 View Post
Can I use a regular house GFI?
Not one made for RV?
They are one in the same. Once again, go down to HD/Lowes, buy a new one and swap it out. IF that does not fix your problem, you have to do some digging, but why go to all the trouble of digging around before eliminating the simpleste solution first?
DegoRed is offline   Reply With Quote
Old 05-16-2014, 09:24 AM   #8
bnb1313@aol.com
 
BigSkyBob's Avatar


 
Monaco Owners Club
Join Date: Feb 2008
Location: Western Montana on the Divide
Posts: 1,561
You can use a regular GFI receptacle. Replaced mine twice so far.
__________________
Bob Retired Army Traveling alone now, had to put Charlie the Beagle down :(.
2008 Camelot 40 PDQ 4 slides ISL400 towing a 2020 1500 GMC Sierra Denali 4x4 Crewcab
Western MT in summer, AZ, NV in winter
BigSkyBob is offline   Reply With Quote
Old 05-16-2014, 09:25 AM   #9
Senior Member
 
Join Date: Jan 2012
Location: Taft, TN 38488
Posts: 584
Quote:
Originally Posted by DegoRed View Post
They are one in the same. Once again, go down to HD/Lowes, buy a new one and swap it out. IF that does not fix your problem, you have to do some digging, but why go to all the trouble of digging around before eliminating the simpleste solution first?

Headed to store now, will let you all know in few minutes.

Tom


Sent from my iPad using iRV2 - RV Forum


2007 Fleetwood Providence 40X
OurBigRVAdventure.com
Tom222 is offline   Reply With Quote
Old 05-16-2014, 10:29 AM   #10
Registered User
 
mel s's Avatar
 
Join Date: Mar 2010
Posts: 8,777
Quote:
Originally Posted by Tom222 View Post
Tried it on DC and Genny
Tom222
DC has "0" to do with GFCI receptacles.

BTW, all GFCI receptacles are not "created equal".....(as with most things, an expensive GFCI receptacle will outlive a cheap one).

Mel
'96 Safari
mel s is offline   Reply With Quote
Old 05-16-2014, 11:10 AM   #11
Senior Member
 
vsheetz's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Jun 2012
Location: SoCal
Posts: 15,747
Quote:
Originally Posted by mel s View Post
Tom222
DC has "0" to do with GFCI receptacles.

BTW, all GFCI receptacles are not "created equal".....(as with most things, an expensive GFCI receptacle will outlive a cheap one).

Mel
'96 Safari
And some don't like MSW inverters...
__________________
Vince and Susan
2011 Tiffin Phaeton 40QTH (Cummins ISC/Freightliner)
Flat towing a modified 2005 Jeep (Rubicon Wrangler)
Previously a 2002 Fleetwood Pace Arrow 37A and a 1995 Safari Trek 2830.
vsheetz is offline   Reply With Quote
Old 05-16-2014, 11:19 AM   #12
Senior Member
 
Join Date: Jan 2012
Location: Taft, TN 38488
Posts: 584
Quote:
Originally Posted by Tom222 View Post
Headed to store now, will let you all know in few minutes.

Tom


Sent from my iPad using iRV2 - RV Forum


2007 Fleetwood Providence 40X
OurBigRVAdventure.com

Ok, replaced the GFI and this one is not working either, so the problem is at that plug, right? Now what is there a location that controls that plug?
Also I went ahead and replaced all the fuses that control the inside area.

Help...


Tom




Sent from my iPad using iRV2 - RV Forum


2007 Fleetwood Providence 40X
OurBigRVAdventure.com
Tom222 is offline   Reply With Quote
Old 05-16-2014, 11:20 AM   #13
Senior Member
 
Join Date: Jan 2012
Location: Taft, TN 38488
Posts: 584
Quote:
Originally Posted by vsheetz View Post
And some don't like MSW inverters...

I replaced the GFI with the exactly the same model, you can't tell them apart.

Tom


Sent from my iPad using iRV2 - RV Forum


2007 Fleetwood Providence 40X
OurBigRVAdventure.com
Tom222 is offline   Reply With Quote
Old 05-16-2014, 11:21 AM   #14
Senior Member
 
terry735001's Avatar
 
Join Date: Sep 2012
Posts: 1,177
Blog Entries: 11
Quote:
Originally Posted by vsheetz View Post
And some don't like MSW inverters...
is right



all so your GFI can cut power to plugs down the line so you may have power to it and it be bad

but some one else was all so right if no power is making it to it .. it well not reset .. its needs power
terry735001 is offline   Reply With Quote
Reply

Tags
electrical



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical problem and slide hesitation in Bounder outofdodge Class A Motorhome Discussions 1 04-22-2014 10:02 AM
2004 Windsor electrical problem Jmyates Monaco Owner's Forum 4 04-18-2014 02:46 PM
Norcold frosting problem Navy Flier RV Systems & Appliances 3 02-22-2014 09:10 AM
Unusual Hydro Hot problem, and the fix Medico RV Systems & Appliances 0 02-14-2014 07:18 AM
Dash Gauge Problem RangerRick Newmar Owner's Forum 3 02-02-2014 12:53 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 07:16 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.