RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 02-14-2017, 11:53 AM   #1
Junior Member
 
Join Date: Oct 2013
Posts: 5
ICC Running Lights not working

The ICC running lights on my 2002 Fleetwood Discovery quite working. Fuses are good. ICC rocker switch on left side of dash okay. Any suggestions? Thanks.
Ken S.
captken1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-14-2017, 11:58 AM   #2
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 20,812
If your coach is on a Freightliner chassis , the wiring probably goes through a " Marker Light Relay " that will have to be tested too.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 02-22-2017, 03:00 PM   #3
Junior Member
 
Join Date: Oct 2013
Posts: 5
Skip426...Have checked all fuses that concern marker lights, clearance lights and icc lights for continuity and 12 volt power to each fuse. Aslo, ck the flasher switch for the marker light and is working properly. Also, the Marker Lamp Relay is good. Any suggestions? Thanks.

captken1
captken1 is offline   Reply With Quote
Old 02-22-2017, 06:57 PM   #4
Senior Member
 
chuckftboy's Avatar
 
Winnebago Owners Club
Fleetwood Owners Club
Holiday Rambler Owners Club
Join Date: Dec 2011
Location: North East Florida
Posts: 1,213
If all the 12 volt circuits are good, you might start look for fault with the ground to those lights.
__________________
2019 Horizon 42Q
Cummins L-9 450 HP
Maxim Chassis / IFS with Tag
chuckftboy is offline   Reply With Quote
Old 02-23-2017, 06:44 AM   #5
Senior Member
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Mcdonough, Ga.
Posts: 5,291
There is one ground for the front and one ground for the rear. If the front or rear is out, it is probably the ground. If both are out, It is probably a power problem.
__________________
1998 Pace Arrow 35 ft. F53 Ford V10 2012 Honda Civic toad
32 years mechanic at Delta Air Lines 15 year motorhome service manager. 3 popups....2 travel trailers....5 motorhomes....loved them all.
ga traveler is offline   Reply With Quote
Old 02-23-2017, 09:44 AM   #6
Senior Member
 
Excursion04's Avatar
 
Winnebago Owners Club
Join Date: May 2013
Location: Naples, Fl
Posts: 319
I had similar problem with our 2004 excursion. Had almost complete outage, headlights hi & low, fog lights all except turn signals. Like you check all the fuses and connections they all were fine. I traced the wires from headlight to what it looked like maybe a 3x6 distribution board (this is best I can discribe it) on driver side on it I notices couple of white buttons, I pressed them both lights on problem solved. All by accident I discovered the reset buttons, no one at RV service center had any idea about the reset buttons. I am sure this saved me a few dollars. BTW excursion is deisel push front access to headlights wiring. Hope this help, good luck
Excursion04 is offline   Reply With Quote
Old 03-24-2017, 12:14 PM   #7
Junior Member
 
Join Date: Oct 2013
Posts: 5
The running light issue was resolved by replacing a "relay" which was not shown on any Fleetwood or Freightliner electrical schematic. It was in a bundel on the driver's side floorboard. captken1
captken1 is offline   Reply With Quote
Old 03-24-2017, 10:57 PM   #8
Senior Member
 
mchero's Avatar
 
Join Date: Mar 2006
Location: Full Time USA
Posts: 2,163
Quote:
Originally Posted by Excursion04 View Post
I had similar problem with our 2004 excursion. Had almost complete outage, headlights hi & low, fog lights all except turn signals. Like you check all the fuses and connections they all were fine. I traced the wires from headlight to what it looked like maybe a 3x6 distribution board (this is best I can discribe it) on driver side on it I notices couple of white buttons, I pressed them both lights on problem solved. All by accident I discovered the reset buttons, no one at RV service center had any idea about the reset buttons. I am sure this saved me a few dollars. BTW excursion is deisel push front access to headlights wiring. Hope this help, good luck
Sounds like you found a couple resettable circuit breakers to me.
__________________
Robert & Deb
07 Discovery 39v FWS Full Timers, Henniker NH
1K solar - 05 Jeep Grand Cherokee
mchero is offline   Reply With Quote
Old 03-25-2017, 08:57 PM   #9
Senior Member
 
KF5UMC's Avatar
 
Join Date: Sep 2015
Posts: 678
Quote:
Originally Posted by captken1 View Post
The running light issue was resolved by replacing a "relay" which was not shown on any Fleetwood or Freightliner electrical schematic. It was in a bundel on the driver's side floorboard. captken1
Good job tracking down your problem!

John
__________________
John & Debbie
2008 Fleetwood Discovery 40X Full Timers Since Oct 2015
KF5UMC is offline   Reply With Quote
Old 09-23-2020, 05:28 PM   #10
Junior Member
 
Join Date: Sep 2020
Posts: 3
captken1,

I am having the same issue with my running lts. Can you point me in the direction of the infamous relay? I can find anything.
racecrew12 is offline   Reply With Quote
Old 09-23-2020, 06:02 PM   #11
Senior Member
 
mchero's Avatar
 
Join Date: Mar 2006
Location: Full Time USA
Posts: 2,163
Quote:
Originally Posted by racecrew12 View Post
captken1,

I am having the same issue with my running lts. Can you point me in the direction of the infamous relay? I can find anything.
Can you please let us know make/model of your rig.
__________________
Robert & Deb
07 Discovery 39v FWS Full Timers, Henniker NH
1K solar - 05 Jeep Grand Cherokee
mchero is offline   Reply With Quote
Old 09-23-2020, 08:32 PM   #12
Junior Member
 
Join Date: Sep 2020
Posts: 3
Sorry, It is a 2002 Discovery 39D
racecrew12 is offline   Reply With Quote
Old 09-24-2020, 02:00 PM   #13
Junior Member
 
Join Date: Oct 2013
Posts: 5
Running Lights

The running light issue was resolved by replacing a "relay" which was not shown on any Fleetwood or Freightliner electrical schematic. It was in a bundel on the driver's side floorboard. captken1


It is a 2002 Fleetwood Discovery 38D.
captken1 is offline   Reply With Quote
Old 09-25-2020, 07:17 AM   #14
Junior Member
 
Join Date: Sep 2020
Posts: 7
Quote:
Originally Posted by captken1 View Post
The running light issue was resolved by replacing a "relay" which was not shown on any Fleetwood or Freightliner electrical schematic. It was in a bundel on the driver's side floorboard. captken1


It is a 2002 Fleetwood Discovery 38D.
Do you a part number for that relay? I am having the same issue and would like to take a relay to the storage lot with me. Thanks.
Joe1978 is offline   Reply With Quote
Reply

Tags
light, lights



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ICC / running lights racecrew12 Fleetwood Owner's Forum 1 09-22-2020 02:22 PM
ICC Light Flash Switch Not Working Craig N Deb Fleetwood Owner's Forum 23 03-03-2016 05:09 PM
turn signals, running lights, tow lights side clearance lights not working gowhiz Tiffin Owner's Forum 3 02-26-2014 07:02 AM
ICC switch not working recaffey Monaco Owner's Forum 7 11-23-2013 09:40 AM
ICC flash and courtesy light switch's not working jaminjer1 National RV Owner's Forum 0 07-06-2009 04:53 PM


All times are GMT -6. The time now is 01:40 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.