Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-11-2021, 02:27 PM   #1
Junior Member
 
Join Date: Oct 2021
Posts: 5
Angry Jacks control system

I have a 2003 Bounder 35E and I'm not getting power to my Jacks control board. Power gear sent me a PDF showing the unit but I've contacted Fleetwood Co. to ask where it is located and they have no contact information, just referring me to a dealer in Davenport, IA. I called them and they gave me the runaround, saying "Bring it in and we'll look at it." The service manual Power Gear sent me shows the control board getting it's power from the Leveling Control circuit box but I have no idea where it is located. Any help appreciated.
Gerry Seely is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-11-2021, 03:07 PM   #2
Junior Member
 
Join Date: Sep 2021
Posts: 22
Check the driver side of the firewall
billy_RV is offline   Reply With Quote
Old 10-11-2021, 05:00 PM   #3
Junior Member
 
Join Date: Oct 2021
Posts: 5
Been there

I've removed the driver's seat for the 2nd time to look for it there, I see nothing that looks like the picture Power Gear sent me.
Gerry Seely is offline   Reply With Quote
Old 10-11-2021, 05:02 PM   #4
Junior Member
 
Join Date: Sep 2021
Posts: 22
The firewall underneath the dash or on the outside under the hood
billy_RV is offline   Reply With Quote
Old 10-12-2021, 12:16 AM   #5
Junior Member
 
Join Date: Oct 2021
Posts: 5
Jacks

I've looked in both places, can't find anything even remotely similar.
Gerry Seely is offline   Reply With Quote
Old 10-12-2021, 08:31 AM   #6
Senior Member
 
AlanTerry's Avatar
 
Fleetwood Owners Club
Join Date: Dec 2010
Location: Cincinnati, Ohio
Posts: 424
Could the “Leveling Control circuit box” be near the Hydraulic reservoir? Have you checked there?
__________________
Alan & Terry 2016 Bounder 34T
Blue Ox Alpha Tow Bar, RVi brake 2system
2015 Jeep Trail Hawk (Toad),WeBoost.
AlanTerry is offline   Reply With Quote
Old 10-12-2021, 09:09 AM   #7
Junior Member
 
Join Date: Sep 2021
Posts: 22
Well it should be in that area, or near chassis fuses.
Attached Files
File Type: pdf Hydraulic_Levelers_Ford.pdf (385.4 KB, 16 views)
billy_RV is offline   Reply With Quote
Old 10-12-2021, 12:51 PM   #8
Junior Member
 
Join Date: Oct 2021
Posts: 5
Jacks

Thanks for the help, mine is a Workhorse Chassis...but it looks very similar. I crawled under it looking for the control box but still can't find it. I pulled off a rubber skirt across the top of the engine compartment thinking it might be there but no luck. I called another Dealer up by Chicago and was transferred 3 times and connected to a guy who wasn't in his office. They also told me "Bring it in and we'll check it out." I told her I wasn't about to have them replace the $1000 leveling system for what is apparently a broken (or mouse chewed) wire. Beside the fact that it's 200 miles away. Called the factory in Indiana (they did give me THAT information), but an automated system kept giving me options that had nothing to do with locating my problem.
Gerry Seely is offline   Reply With Quote
Old 10-12-2021, 12:55 PM   #9
Junior Member
 
Join Date: Oct 2021
Posts: 5
NO DEALER wants to give you the information to fix it yourself, they want their "Qualified" technicians to fix it so they can charge you an arm & a leg. Pisses me off. I am a Journeyman Electrician and I KNOW how to fix it, just need a location.

SUCCESS! I found it mounted on a plate screwed to the underside of the dash. COMPLETELY hidden from view. Thanks to everyone for their help.
Gerry Seely is offline   Reply With Quote
Old 10-12-2021, 01:56 PM   #10
Junior Member
 
Join Date: Sep 2021
Posts: 22
Glad to see you found the problem. I forgot to attach both files but they are pretty much the same. Here it is if it can help you out in the future.
Attached Files
File Type: pdf Chassis_Electrical_Workhorse.pdf (487.9 KB, 18 views)
billy_RV is offline   Reply With Quote
Old 10-19-2021, 04:30 PM   #11
Member
 
Bobog's Avatar
 
Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Oct 2011
Location: Alberta
Posts: 50
For any others following this thread, I found mine mounted to the underside of the shelf in the front curb side storage / propane compartment.
__________________
Greg & Tess Harrison, Maltese X named Camper
'04 Bounder 35E on W22, '10 Honda CR-V toad
Near Edmonton, Alberta
Bobog is offline   Reply With Quote
Old 10-19-2021, 05:27 PM   #12
Junior Member
 
PaulVK's Avatar
 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Apr 2021
Posts: 12
Good to know
__________________
Paul V..K....
PaulVK is offline   Reply With Quote
Old 10-19-2021, 06:46 PM   #13
Senior Member
 
Jim.B1's Avatar
 
Join Date: Nov 2017
Posts: 812
Gerry,
I have a 2014 Southwind that had the same problem a couple of years ago.
There is a 25 amp in-line fuse up high in the dash behind to speedometer. The fuse controls both the Power Gear level system and the chassis blower motor! Strange, but that is how it is hooked up.
If you have an access panel on the top of the dash, go in through there. Good Luck.
__________________
Jim.B
Southern Ontario
2014 Fleetwood Southwind 32VS 🇨🇦
Jim.B1 is offline   Reply With Quote
Old 10-20-2021, 06:43 AM   #14
Member
 
Ford Super Duty Owner
Join Date: Mar 2018
Posts: 88
Gerry I hate to say this, but did you first check your emergency brake was on. Many systems interface with this before they function.
__________________
Capt Retired R.C.A.F. Fleetwood Bounder,
CaptronNZ is offline   Reply With Quote
Reply

Tags
jacks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HWH 325 System Control Board, Jacks Won't Move LPD218 RV Systems & Appliances 8 05-06-2016 12:08 PM
jacks or no jacks hit the road Class A Motorhome Discussions 6 06-20-2012 12:38 PM
Jacks down alarm when Jacks are all up Help Janet&Sid Alpine Coach Owner's Forum 10 09-01-2011 12:30 PM
Cruise Control/Wiper Control/Bright Light Control cnjcampione Winnebago Industries Owner's Forum 2 05-21-2011 08:38 PM
Replace Electric Jacks with Hydraulic Jacks? sidewinder2 5th Wheel Discussion 10 01-04-2011 09:25 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 07:19 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.