Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-15-2014, 04:12 PM   #1
Senior Member
 
Join Date: Jan 2012
Location: Boaz, Alabama
Posts: 568
Jacks problem

I used the jacks with no problems earlier in the day. I went to put jacks down and they froze halfway down, the front and left jack lights blink and continue blinking along with the auto and man lights. Any thoughts?
tom


Sent from my iPad using iRV2 - RV Forum


2007 Fleetwood Providence 40X
OurBigRVAdventure.com
Tom222 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-15-2014, 04:16 PM   #2
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 23,336
Leveling system brand name ? HWH ? Usually on the control pad.


EDIT: OK not HWH; My brand ;, and I see Cliff has picked up, on your post, so I'll let him give you info.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 05-15-2014, 04:20 PM   #3
Senior Member
 
Join Date: Jan 2012
Location: Boaz, Alabama
Posts: 568
Nothing on the control panel, where would I look?


Sent from my iPad using iRV2 - RV Forum


2007 Fleetwood Providence 40X
OurBigRVAdventure.com
Tom222 is offline   Reply With Quote
Old 05-15-2014, 04:25 PM   #4
Community Administrator
 
CLIFFTALL's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Aug 2009
Posts: 44,757
You most likely have Power Gear Electric. They're in error Mode. I'll find a tech sheet and post it shortly.
__________________


Cliff,Tallulah and Buddy ( 1999-2012 )
CLIFFTALL is offline   Reply With Quote
Old 05-15-2014, 04:28 PM   #5
Senior Member
 
Join Date: Jan 2012
Location: Boaz, Alabama
Posts: 568
Quote:
Originally Posted by Clifftall View Post
You most likely have Power Gear Electric. They're in error Mode. I'll find a tech sheet and post it shortly.

Thanks, I can not locate what brand they army are from underneath



Sent from my iPad using iRV2 - RV Forum


2007 Fleetwood Providence 40X
OurBigRVAdventure.com
Tom222 is offline   Reply With Quote
Old 05-15-2014, 04:32 PM   #6
Community Administrator
 
CLIFFTALL's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Aug 2009
Posts: 44,757
Hers a tech doc that may assist.

http://support.powergearus.com/techdocs/3010002127.pdf

Here's your manual.

http://support.powergearus.com/techdocs/82-L0368.pdf

If you need to communicate with Power Gear. , they're available via email and respond during bus hours very quickly. Info@powergearus.com
Please update us when you can.
__________________


Cliff,Tallulah and Buddy ( 1999-2012 )
CLIFFTALL is offline   Reply With Quote
Old 05-15-2014, 04:37 PM   #7
Senior Member
 
Join Date: Jan 2012
Location: Boaz, Alabama
Posts: 568
Thanks, I am not very mechanical minded.

Tom


Sent from my iPad using iRV2 - RV Forum


2007 Fleetwood Providence 40X
OurBigRVAdventure.com
Tom222 is offline   Reply With Quote
Old 05-15-2014, 05:47 PM   #8
Senior Member
 
Join Date: Jan 2012
Location: Boaz, Alabama
Posts: 568
Quote:
Originally Posted by Clifftall View Post
Hers a tech doc that may assist.

http://support.powergearus.com/techdocs/3010002127.pdf

Here's your manual.

http://support.powergearus.com/techdocs/82-L0368.pdf

If you need to communicate with Power Gear. , they're available via email and respond during bus hours very quickly. Info@powergearus.com
Please update us when you can.

Thanks for sending me that, I followed the instructions and at least got the jacks up. They will not go down without going into error mode, but at least I can get the RV to a repair shop now.

Tom


Sent from my iPad using iRV2 - RV Forum


2007 Fleetwood Providence 40X
OurBigRVAdventure.com
Tom222 is offline   Reply With Quote
Old 05-15-2014, 05:50 PM   #9
Community Administrator
 
CLIFFTALL's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Aug 2009
Posts: 44,757
Great. The techs at Power Gear may be able to walk you through this. Email them now and you will have a response early tomorrow. They will call you if need be and assist. Good luck and once again update us when you can.
__________________


Cliff,Tallulah and Buddy ( 1999-2012 )
CLIFFTALL is offline   Reply With Quote
Old 05-15-2014, 05:56 PM   #10
Community Administrator
 
CLIFFTALL's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Aug 2009
Posts: 44,757
Hers a thread that will keep you up all night but will teach you everything you wanted to know about your jacks. There was an issue with water intrusion into the brake on the jack motor. You'll see in this thread that we found a fix for this.

http://www.irv2.com/forums/f107/powe...lem-53137.html
__________________


Cliff,Tallulah and Buddy ( 1999-2012 )
CLIFFTALL is offline   Reply With Quote
Old 05-16-2014, 07:42 AM   #11
Senior Member
 
Join Date: Jan 2012
Location: Boaz, Alabama
Posts: 568
Ok followed the directions and got it back working thanks!

But now at the same time all of the electrical plugs in the living area and bedroom, and bathroom are out. I checked the breakers and fuses and I can't find a problem. Any ideas?

Tom


Sent from my iPad using iRV2 - RV Forum


2007 Fleetwood Providence 40X
OurBigRVAdventure.com
Tom222 is offline   Reply With Quote
Reply

Tags
jacks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Gear Leveling Neutral Safety Switch Problem jpbill National RV Owner's Forum 5 07-21-2014 05:07 PM
Norcold frosting problem Navy Flier RV Systems & Appliances 3 02-22-2014 08:10 AM
Unusual Hydro Hot problem, and the fix Medico RV Systems & Appliances 0 02-14-2014 06:18 AM
Redneck 1993 Allegro Bay Diesel Pusher with electrical problem jcruce13 Class A Motorhome Discussions 7 10-09-2013 11:27 AM
New Member from Pennsylvania BaileythePug Monaco Owner's Forum 11 08-10-2013 09:18 AM


All times are GMT -6. The time now is 08:49 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.