Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-07-2011, 06:14 PM   #1
Registered User
 
dukenrock's Avatar
 
Join Date: Jan 2010
Posts: 431
Left turn signal issue 2002 American Eagle

I noticed today when checking my trailer lights that I have no left turn signal at the trailer. I checked the connection at the plug on the MH and I get a dim flash (Dim on my probe compared to the right turn signal) I traced the wire loom from the plug on the back of the motorhome to a connector inside the engine compartment (Rear) and the light flashes dim there too. All of my lights, including turn signals, work fine on the MH, it's just not making the left turn signal through to the trailer, even with a dim signal at the plug. It's dark out right now so I'll check the voltage at the plug tomorrow AM. Not sure what the issue is??...
__________________
2017 RAM DRW
2018 DRV Full House JX450
dukenrock is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-07-2011, 06:45 PM   #2
Member
 
bosshawg's Avatar
 
Country Coach Owners Club
Fleetwood Owners Club
Freightliner Owners Club
Join Date: Jun 2011
Posts: 52
The trailer plug has it own fuses. Mine were in a compartment by the engine ecu. It was on the passenger side next to last compartment. My left turn signal was not working. It had its own fuse. I have a freightliner chassis.
__________________
2003 Country Coach Intrigue 40'
2011 Buick Enclave
bosshawg is offline   Reply With Quote
Old 11-07-2011, 06:56 PM   #3
Registered User
 
dukenrock's Avatar
 
Join Date: Jan 2010
Posts: 431
I have a Spartan Chassis..Never recall running across a fuse panel for that but I'll check. Thanks.
__________________
2017 RAM DRW
2018 DRV Full House JX450
dukenrock is offline   Reply With Quote
Old 11-07-2011, 08:04 PM   #4
Senior Member
 
Winnebago Owners Club
Join Date: May 2009
Location: AZ Mountains
Posts: 394
Off-the-wall suggestion: bein' as the rear lights likely go thru the emergency flasher, operate the emergency flasher a few times. Just MIGHT clean the contacts! (and it's free and easy!)
nbounder is offline   Reply With Quote
Old 11-07-2011, 08:16 PM   #5
Registered User
 
dukenrock's Avatar
 
Join Date: Jan 2010
Posts: 431
i'll give that a try! thanks...
__________________
2017 RAM DRW
2018 DRV Full House JX450
dukenrock is offline   Reply With Quote
Old 11-07-2011, 08:43 PM   #6
Registered User
 
dukenrock's Avatar
 
Join Date: Jan 2010
Posts: 431
NADA.....pulled the flasher out and put back in too.

Tomorrow I'll see if I have some fuses in the back by the power jack and battery "stuff". I'll call Fleetwood after that if I don't find anything.
__________________
2017 RAM DRW
2018 DRV Full House JX450
dukenrock is offline   Reply With Quote
Old 11-07-2011, 08:59 PM   #7
Senior Member
 
Belgian's Avatar
 
National RV Owners Club
Join Date: Jun 2006
Location: Manhattan Beach, CA
Posts: 695
Sounds like a bad ground at the light.
Belgian is offline   Reply With Quote
Old 11-07-2011, 08:59 PM   #8
Senior Member
 
quadnkev's Avatar
 
Fleetwood Owners Club
Join Date: Aug 2011
Location: Tualatin Oregon
Posts: 163
Check your ground circuits, if you have a dim bulb that is the likely cause.
quadnkev is offline   Reply With Quote
Old 11-07-2011, 09:18 PM   #9
Registered User
 
dukenrock's Avatar
 
Join Date: Jan 2010
Posts: 431
The light that is dim is my tester when I test the left signal output at the trailer plug on the MH. It's not dim on the right turn signal output at the trailer plug so my ground I'm using on my tester should be good. I followed a wiring loom from the plug that I plug the trailer lights into. This loom goes to a connector that I pulled apart to make sure nothing was corroded. The connections looked good and I still got a dim light on my tester on the left signal output. Everything else on the trailer lights work good except for the left turn signal. (I'm not sure about the left brake light but that one may not work either-I'll have my DW check it with me tomorrow) Hopefully it will be a simple fuse as Bosshawg pointed out!!
__________________
2017 RAM DRW
2018 DRV Full House JX450
dukenrock is offline   Reply With Quote
Old 11-08-2011, 09:39 AM   #10
Senior Member
 
quadnkev's Avatar
 
Fleetwood Owners Club
Join Date: Aug 2011
Location: Tualatin Oregon
Posts: 163
I was meaning the turn signal ground at the lamp assembly primarily.
quadnkev is offline   Reply With Quote
Old 11-14-2011, 02:15 PM   #11
Senior Member
 
NHRA225's Avatar


 
American Coach Owners Club
Join Date: Jan 2011
Posts: 2,663
Smile

After confirming all the grounds are good, then go to the 4 dedicated Bosch relays that are dedicated to the 4 corner turn signals, mine are located in front of the pass - rear wheel up in the rear harness- in plain view. I had a similar issues and found that the left rear relay was going bad. Replaced the relay and the turn signal was ok.
__________________
Chuck
Brownsburg Indiana
1992 American Eagle-8.3C-450hp
NHRA225 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
W-22 turn signal chime storefixtureman Workhorse and Chevrolet Chassis Motorhome Forum 12 02-22-2011 05:55 PM
Freightliner Turn Signal Flasher Franknsandy National RV Owner's Forum 4 08-10-2010 12:36 PM
turn signal malfunction mtaire5093 Newmar Owner's Forum 2 05-30-2010 06:07 PM
Left Brake Light/Turn Signal Not Working On Towed Jeanne M. Winnebago Industries Owner's Forum 4 02-11-2008 07:43 AM
E450 Trailer Lights, Stop Lights - no Turn Signal? Scrib Ford Motorhome Chassis Forum 2 06-04-2007 12:38 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 01:51 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.