RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-23-2014, 10:30 PM   #1
Junior Member
 
Join Date: Jul 2014
Location: Bloomington Il
Posts: 9
Lost running lights and dash lights

Hello friends

I was out and parked all day at an event which was about40 miles away.

When I wen t to leave I started my 32 ft Fleetwood Southwind and had no running lights or dash lights and the speedometer did not work.

I had a friend help me out an we could not find the fuse for these ??? or the relay if any ??

We bought a new light switch and that did not do it - we also pulled the harness down and used a wire to "jump and to make all the running lights, dash lights and odometer work

Any ideas ???? please message me as I am baffled

Patrick

Soupy219 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-24-2014, 07:03 AM   #2
Senior Member
 
Tha_Rooster's Avatar
 
Join Date: Aug 2008
Location: Georgia
Posts: 6,466
If you jumped the wires from the switch and it worked it seems if it would be the switch. Did you use a meter to make sure the switch jump the same as you did with the wire?
__________________
2007 Fleetwood Revolution LE 40V
Tha_Rooster is offline   Reply With Quote
Old 08-24-2014, 07:48 AM   #3
Junior Member
 
Join Date: Jul 2014
Location: Bloomington Il
Posts: 9
thanks Rooster -
we did it with a wire after metering everything - I am at the point now where I think it is a harness issue as I bought a new light switch and that did not solve it
Soupy219 is offline   Reply With Quote
Old 08-24-2014, 08:12 AM   #4
Senior Member
 
Stano's Avatar
 
Join Date: Apr 2012
Location: Michigan
Posts: 680
I assume you mean running lights= headlights too?

Stano
__________________
Winter Home- Arcadia, Florida
USN Vietnam Veteran 1967-1971
DAV Lifetime Member
Stano is offline   Reply With Quote
Old 08-24-2014, 08:16 AM   #5
Junior Member
 
Join Date: Jul 2014
Location: Bloomington Il
Posts: 9
head lights, break lights, turn signals and flashers all work

Also lost power to the dash lighting - which also came on when we jumped the wires

this is why when he jumped it and it worked - I keep thinking it is the harness receptacle for the head light switch ???? -
Soupy219 is offline   Reply With Quote
Old 08-26-2014, 11:13 AM   #6
Junior Member
 
Join Date: Jul 2014
Location: Bloomington Il
Posts: 9
there is a fuse box under the whole dash after you lift up the dash - RV dealer found it in 3 minutes - thanks everyone - all good here
Soupy219 is offline   Reply With Quote
Reply

Tags
dash, lights



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No dash or running lights 2002 P22 Workhorse otter80546 Workhorse and Chevrolet Chassis Motorhome Forum 1 08-16-2014 05:31 PM
Dash warning lights not working AlpineRivers Alpine Coach Owner's Forum 8 05-01-2014 05:55 PM
Dash lights Gorlininc Monaco Owner's Forum 2 04-01-2014 02:54 AM
No dash, running and clearance lights. '97 Endeavor ARCA Dave Class A Motorhome Discussions 12 02-18-2014 06:14 AM
DIY troubles: taillight sockets and dash lights! monacle Monaco Owner's Forum 16 02-04-2014 07:44 AM


All times are GMT -6. The time now is 02:57 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.