RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-16-2020, 01:44 PM   #1
Junior Member
 
Join Date: Sep 2020
Posts: 17
No Rear Heat

11' FW Discovery 40G. I have a single thermostat in the front overhead bin. When I put in heat mode, Zone 1 shows gas and heat comes on and gets hot. However when I go to Zone 2 or 3, it displays "Off". Their is a second heater under the lavy sink, and doesn't turn on. Could the thermostat have lost its programming and no longer knows there is gas heat on the second zone? Where to begin troubleshooting this?
__________________
2011 Fleetwood Discovery 40G
SC182 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-16-2020, 03:48 PM   #2
Senior Member
 
KF5UMC's Avatar
 
Join Date: Sep 2015
Posts: 711
On our discovery the single thermostat can handle up to 3 units. The 3 heaters/air conditioners are assigned a number address via jumpers on the Load Shedding" circuit board located near the Transfer Relays and main power circuit breaker panel. In our case only 2 jumpers are used thus only two units are controlled.


I had a problem similar to you. The thermostat got confused and thought there was 3 units and did not find them...I pulled off the cover of the thermostat, pulled the power cable off the thermostat circuit board, waited a few seconds then plugged in the connector. This fixed my problem.


If not already you should contact REV and get all the drawings they have on you coach. Provide you serial number make, model.
REV contact info: fleetwoodmhservice@revrvgroup.com
Good luck!
John





Click image for larger version

Name:	Thermostat.png
Views:	13
Size:	51.8 KB
ID:	308269
__________________
John & Debbie
2008 Fleetwood Discovery 40X Full Timers Since Oct 2015
KF5UMC is offline   Reply With Quote
Old 12-01-2020, 08:39 AM   #3
Junior Member
 
Join Date: Sep 2020
Posts: 17
Got the rear heat working!!!!! Wife is very happy now.

Thank-you for you help which led me to the fix. I have the Rvcomfort.zc thermostat (AS7825) and pulled the fuse from it and reinserted after a few minutes. Still did not see second zone as gas heat. So I found the link on another forum on how to reprogram thermostat and tell it zone 1 and 2 both have gas heat.

https://www.irv2.com/forums/attachme...1&d=1448982783

Not sure why it would have lost this setting, unless previous owner had disabled it for a reason. But it got nice and toasty real quick in the coach.
__________________
2011 Fleetwood Discovery 40G
SC182 is offline   Reply With Quote
Old 12-02-2020, 03:27 AM   #4
Senior Member
 
KF5UMC's Avatar
 
Join Date: Sep 2015
Posts: 711
Glad you have heat/zones! And thanks for the link I will file this procedure for future reference.
__________________
John & Debbie
2008 Fleetwood Discovery 40X Full Timers Since Oct 2015
KF5UMC is offline   Reply With Quote
Reply

Tags
heat, rear



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
To heat pump or not heat pump Bruce and Jenna Excel Owner's Forum 17 04-15-2009 11:20 PM
Heat pump heat down to what temp? Bruce and Jenna RV Systems & Appliances 2 11-28-2008 04:39 AM
Heat: Gas & Heat Pump together? SCVJeff Winnebago Industries Owner's Forum 9 05-23-2007 07:11 PM
Max heat with HydroHot AND heat pumps? footdoc Newmar Owner's Forum 12 11-02-2006 06:58 PM
Heat Pump - No Heat - 2002 Journey PULLEY MH-General Discussions & Problems 5 09-12-2006 05:07 PM


All times are GMT -6. The time now is 06:07 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.