Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-30-2017, 01:41 PM   #1
Member
 
Join Date: May 2012
Posts: 91
Onan 5.5 HGJAB Generator Problem

Tested my generator Friday morning for 15 minutes, everything fine. Went to start it today, starts fine, but cuts off after 10-15 seconds. Fault code 37. Any ideas what to look for?
__________________
Mike Stoneham
2012 Fleetwood Bounder 35K
2012 Honda CRV
mst0neham123 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-01-2017, 11:19 AM   #2
Senior Member
 
Medic57's Avatar
 
Join Date: Oct 2015
Location: Highlands, TX
Posts: 145
Everything I've read points to fuel. Could be filter, pump, or carb. If it had been sitting for a length of time, maybe some trash broke loose after the 15 minute run and got in the carb. Good luck.
__________________
2020 Thor Quantum WS31
2020 Jeep Wrangler Sahara
Medic57 is offline   Reply With Quote
Old 10-01-2017, 01:55 PM   #3
Senior Member
 
Rocky Larson's Avatar
 
Workhorse Chassis Owner
Join Date: Aug 2007
Posts: 837
This may be a shot in the dark, try turning off as many loads as possible, especially converter and heaters. See if the gen will keep running then add loads as it warms up. good luck.
__________________
Jan and Rocky
Volunteers USFWS. 8500 hrs each, 28 refuges. 04 Allegro 30DA, WH 8.1, Banks, 2012 Jeep Liberty , Brake Buddy Adv Select, 300watts Solar, "Philippians 4:11-13 KJV"
Rocky Larson is offline   Reply With Quote
Old 10-01-2017, 02:05 PM   #4
Senior Member
 
Join Date: Jul 2014
Posts: 27,936
Make sure you have 1/4 tank or more of fuel.

They run out before the main engine so you can get to a station.
twinboat is online now   Reply With Quote
Old 10-02-2017, 09:45 PM   #5
Member
 
Join Date: Apr 2017
Posts: 66
My Southwind generator cuts out after gas is down to 1/2 tank. Fill the tank first. If it works the same, consider the fact that the Onan fuel pumps fail often. If you bother to do that, change the filter while in there. Amazon has both. Note that if you do this yourself, remember to have something ready to stop the fuel flow till you can connect the new stuff. There's a lot more fuel ready to run out than when you work on the mower.
ClassyClassA is offline   Reply With Quote
Old 10-03-2017, 08:29 AM   #6
Member
 
Join Date: May 2012
Posts: 91
Appreciate the advice from everyone. Fuel tank is full.

I made certain everything was off inside RV. I opened the gen breakers and it started right up. Stopped the unit and closed one breaker. Started right up. Stopped the unit and closed the second breaker. Started right up. Put load on the unit and ran for 20 minutes.

Everything seems good now.
__________________
Mike Stoneham
2012 Fleetwood Bounder 35K
2012 Honda CRV
mst0neham123 is offline   Reply With Quote
Old 10-03-2017, 01:52 PM   #7
Senior Member
 
Medic57's Avatar
 
Join Date: Oct 2015
Location: Highlands, TX
Posts: 145
So, was it a miraculous healing, or were you low on fuel? Share your resolution so we can all learn. Even if it was something you feel is silly, we've all been there.

Sent from my HP Pro Slate 8 using iRV2 - RV Forum mobile app
__________________
2020 Thor Quantum WS31
2020 Jeep Wrangler Sahara
Medic57 is offline   Reply With Quote
Old 10-05-2017, 07:33 AM   #8
Member
 
Join Date: May 2012
Posts: 91
Fuel tank was full when all this started.
__________________
Mike Stoneham
2012 Fleetwood Bounder 35K
2012 Honda CRV
mst0neham123 is offline   Reply With Quote
Old 10-05-2017, 08:50 AM   #9
Senior Member
 
Medic57's Avatar
 
Join Date: Oct 2015
Location: Highlands, TX
Posts: 145
So you didn't find a reason for the problem you were having?

Sent from my HP Pro Slate 8 using iRV2 - RV Forum mobile app
__________________
2020 Thor Quantum WS31
2020 Jeep Wrangler Sahara
Medic57 is offline   Reply With Quote
Old 10-06-2017, 03:29 AM   #10
Senior Member
 
KF5UMC's Avatar
 
Join Date: Sep 2015
Posts: 789
What did the fault code represent? On our Onan 8KW genset, it will shut off with 15 seconds or less when high or low oil pressure is detected.
__________________
John & Debbie
2008 Fleetwood Discovery 40X Full Timers Since Oct 2015
KF5UMC is offline   Reply With Quote
Old 10-06-2017, 07:26 AM   #11
Member
 
Join Date: May 2012
Posts: 91
I got a fault code 37, which basically means take it to a service center.

Before taking it to a service center, I rode over in my car and talked to the shop foreman. He gave me the sequence I followed. The oil level in the generator was fine.
__________________
Mike Stoneham
2012 Fleetwood Bounder 35K
2012 Honda CRV
mst0neham123 is offline   Reply With Quote
Old 10-07-2017, 11:11 PM   #12
Senior Member
 
Swan-Bull's Avatar
 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: May 2016
Location: Full-Time, USA
Posts: 111
This happened to me recently. We were traveling from SLC to north west of Boise in the extreme heat, (about 110) and decent elevation (around 3000) and the generator was cutting out while we were driving. We had it cranking all through the drive. My research showed that the code meant the generator had shut down unexpectedly. I let her rest for a bit, topped off the oil, and gave the air filter a good cleaning as we weren't near anywhere we could get a fresh one. I also adjusted the altitude setting. Once we got to our destination where we were dry camping for the week, it ran fine. We ran it on and off each day for about 8 hours or so with no issues. It was also a bit cooler there. Hasn't given me any issues since.

I guess the moral of the story is that with a code like this it could be anything. I've read other places that cleaning the carb or replacing fuel filter can resolve this issue. Make sure your generator is getting what it needs - air, fuel, and lubrication.
__________________
www.MixtapeDrifters.com
2016 Fleetwood Bounder 33C
2004 Jeep Wrangler TJ; ReadyBrute Elite with ReadyBreak
Swan-Bull is offline   Reply With Quote
Old 10-14-2017, 04:06 AM   #13
Senior Member
 
mojoracing's Avatar
 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Oct 2013
Location: northern IL
Posts: 2,557
I find that priming it a bit longer can avoid this problem. Prime it for as much as 20 to 25 seconds. I believe air gaps can form and can cause the gen to stop after a few seconds. Again, I sould like a broken record but I always carry an extra fuel pump for the gen. I went through the original plus 2 more before finally getting the last one that has now lasted a few years. Hopefully onan has worked through their bad batch of pumps or has changed suppliers.
__________________
2014 Fleetwood Bounder 35k
mojoracing is offline   Reply With Quote
Old 10-16-2017, 04:32 PM   #14
Senior Member
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Mcdonough, Ga.
Posts: 5,572
Quote:
Originally Posted by mojoracing View Post
I find that priming it a bit longer can avoid this problem. Prime it for as much as 20 to 25 seconds. I believe air gaps can form and can cause the gen to stop after a few seconds. Again, I sould like a broken record but I always carry an extra fuel pump for the gen. I went through the original plus 2 more before finally getting the last one that has now lasted a few years. Hopefully onan has worked through their bad batch of pumps or has changed suppliers.
I have posted this before but here it is again for those who missed it. I was changing far to many fuel pumps on Onan generators. I finally decided to research the problem. I started to tear down all the pumps and test them. I found almost every one was contaminated with rust. Not slabs of metal like you think of rust, but tiny grains of rust that looked like tiny sand particles. I checked with a magnet and all the particles were attracted to the magnet.
I went back to the Onan installation manual and it called for a filter BEFORE the pump. I started looking at all the onan installs and there was no filter before the pump. I started installing a filter before the pump and the pump failures stopped.
__________________
1998 Pace Arrow 35 ft. F53 Ford V10 2014 Honda CRV toad
32 years mechanic at Delta Air Lines 15 year motorhome service manager. 3 popups....2 travel trailers....5 motorhomes....loved them all.
ga traveler is online now   Reply With Quote
Reply

Tags
generator, onan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan 5.5 HGJAB generator: remove fan shroud BBDogHouse RV Systems & Appliances 1 05-17-2017 07:33 PM
Onan 5.5 HGJAB Electrical problem todintexas RV Systems & Appliances 7 06-20-2016 05:55 PM
Onan 5500 Marquis HGJAB-901A problem Golfr61 RV Systems & Appliances 31 05-08-2016 09:37 PM
Cummins / Onan HGJAB generator starts priming by itself SandyEggo Fleetwood Owner's Forum 6 02-20-2016 09:43 AM
Onan Genset 5500 gas HGJAB model not starting always udbe2 RV Systems & Appliances 9 05-19-2009 06:55 PM


All times are GMT -6. The time now is 10:18 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.