RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-19-2021, 10:45 PM   #1
Member
 
dbdreamers's Avatar
 
American Coach Owners Club
Spartan Chassis
Join Date: May 2015
Location: Mt.VernonMO,PellaIA,RioGrandValleyTX
Posts: 82
Onan generator (anomaly?)

Greetings - We have a 2007 Revolution with a Onanģ 7.5 kW Quiet
Diesel Generator. After 5 years of no problem the generator has suddenly started to "click" (like the preheat/prestartup sound) at the SAME TIME every night. It is accompanied by the red light on the inside startup button (and on the generator itself in the front bay). When I push it, the clicking stops and the red light turns off. The generator DOES NOT start when this happens... only the clicking. The unit itself functions with no problem during normal starting. There's been a couple of times when the clicking has evidently gone on for several hours while we were away from the coach.

I have looked online and in the books and can find no mention of the problem. It is almost like there is a timer to start it... but, it never starts - just clicks. I have to hold down the red button light to start it. Any thoughts? Thanks in advance.

Dave Cook Wintering the beautiful RGV (Rio Grand Valley) TX.
__________________
Dave & Becky Cook - Retired 2016
2006 Revolution E40LE
2014 Honda CRV
dbdreamers is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-19-2021, 11:06 PM   #2
Senior Member
 
Mile Marker 42's Avatar
 
Join Date: May 2013
Location: S. California
Posts: 689
Quote:
Originally Posted by dbdreamers View Post
Greetings - We have a 2007 Revolution with a Onanģ 7.5 kW Quiet
Diesel Generator. After 5 years of no problem the generator has suddenly started to "click" (like the preheat/prestartup sound) at the SAME TIME every night. It is accompanied by the red light on the inside startup button (and on the generator itself in the front bay). When I push it, the clicking stops and the red light turns off. The generator DOES NOT start when this happens... only the clicking. The unit itself functions with no problem during normal starting. There's been a couple of times when the clicking has evidently gone on for several hours while we were away from the coach.

I have looked online and in the books and can find no mention of the problem. It is almost like there is a timer to start it... but, it never starts - just clicks. I have to hold down the red button light to start it. Any thoughts? Thanks in advance.

Dave Cook Wintering the beautiful RGV (Rio Grand Valley) TX.

Do you have an auto-start feature?
__________________
2003 Monaco Knight 36ft- 315 ISC
2007 Jeep Grand Cherokee 3.0 Diesel 4x4
2- 2013 Yamaha VXR's 70MPH+ on aluminum trailer
Mile Marker 42 is offline   Reply With Quote
Old 01-20-2021, 05:21 AM   #3
Senior Member
 
Tha_Rooster's Avatar
 
Join Date: Aug 2008
Location: Georgia
Posts: 6,510
It happens no real idea why some say itís the wiring harness I guess itís rain running down windshield dripping on switch on the genny. You can either cut the salesman switch off or look at your inside control panel for genny and make sure it says manual start.
__________________
2007 Fleetwood Revolution LE 40V
Tha_Rooster is offline   Reply With Quote
Old 01-22-2021, 08:15 AM   #4
Junior Member
 
Join Date: Mar 2018
Location: Harrison Twp., MI
Posts: 26
Quote:
Originally Posted by Tha_Rooster View Post
It happens no real idea why some say itís the wiring harness I guess itís rain running down windshield dripping on switch on the genny. You can either cut the salesman switch off or look at your inside control panel for genny and make sure it says manual start.
Same here too! I also do what you did with the Salesman switch to stop it
__________________
2007 Revolution LE 40E
surelink is offline   Reply With Quote
Old 01-22-2021, 12:58 PM   #5
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 23,862
The remote switch wiring harness on the Onan7500/8000 is known to suffer from moisture build-up, causing some of the wires to short. Yours apparently shorts the pre-start warm-up (normally done by pushing the Off side of the button) circuit to ON, causing the clicking sound that signals the warming cycle. I'm guessing that it cools off in the evening and condensation forms in the wiring to trigger it.


I've heard that people have fixed it by thoroughly drying out the wiring with a hair dryer, but don't know how easy/hard that is or if its a reliable fix.
__________________
Gary Brinck
Former owner of 2004 American Tradition and several other RVs
Home is in the Ocala Nat'l Forest near Ocala, FL
Summers in Black Mountain, NC
Gary RVRoamer is online now   Reply With Quote
Old 01-22-2021, 01:05 PM   #6
Junior Member
 
outdoorplay's Avatar
 
Join Date: Jan 2019
Posts: 29
Blog Entries: 1
same here put it in the shop and yep new wire harness and had a complete tuneup
__________________
Not going to die saying I wish I did that...
outdoorplay is offline   Reply With Quote
Reply

Tags
generator, onan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Generator anomaly? Roscott Newmar Owner's Forum 22 06-20-2016 04:45 PM
Strange 12V anomaly... gjw Entegra Owner's Forum 7 07-11-2015 10:04 AM
An anomaly from nowhere! Sidewinder4 Newmar Owner's Forum 10 02-18-2015 07:10 AM
HWH 200 series, anomaly ihbond Winnebago Industries Owner's Forum 18 05-03-2011 08:24 PM
Time anomaly Darrel Forum 101 | Announcements | Member Forum Concerns 1 12-04-2010 12:38 AM


All times are GMT -6. The time now is 03:50 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.