Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-23-2016, 07:57 PM   #1
Junior Member
 
snoopy-8847's Avatar
 
Winnebago Owners Club
Fleetwood Owners Club
Join Date: Aug 2013
Posts: 6
Power awning not working

I have a 2008 Fleetwood Bounder, it has a Dometic WeatherPro Awning. The awning is closed and doesn't want to open. When we push the toggle switch, there is a clicking in the control panel. We pulled the face off the control panel (Mounted in a closet over the chair next to the door) there is no fuse in it. Any ideas how to open it and is there a lock on it that would keep it closed if we tired to pull the arms open by hand? Or can it even be opened by hand?
snoopy-8847 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-23-2016, 08:04 PM   #2
Senior Member
 
Kazoo Tom's Avatar
 
Join Date: Feb 2006
Location: Kalamazoo, Michigan
Posts: 1,188
make sure that your ignition switch is off. I have the same awning and it will not deploy if the ignition switch is on, or the engine is running. Mine also has a small 6 amp circuit breaker (resettable) in with the other 12 volt breakers. You might also check the top of the arm, there is a plug the connecting the power feed with the motor that may have jarred loose.
__________________
Tom and Barb
'07 Winnebago Voyage 35L
Workhorse W22 chassis FMCA 219315
Kazoo Tom is offline   Reply With Quote
Old 08-23-2016, 08:22 PM   #3
Senior Member
 
Join Date: Jan 2015
Location: Prescott, Arizona
Posts: 3,565
Blog Entries: 6
Getting ready to covert my manual to a 12v electric awning. A dealer told me today that Dometic has the motor in the awning tube and is subject to failure because of heat.
__________________
'04 Newmar MADP, 1100w of solar, Rubicon toad
ByeTheWay is offline   Reply With Quote
Old 08-23-2016, 08:55 PM   #4
Senior Member
 
KF5UMC's Avatar
 
Join Date: Sep 2015
Posts: 821
Is the LEDs flashing on control box? Do you have the remote (FOB) box to control the awning? Have you pulled the power cable to the control box to reset the box? In my situation, the large power awning would not come out due to an error with the wind sensor...LEDS Flashing indicating an Error "unable to communicate with wind sensor" the only way to RESET the controller is with the little FOB remote. I had to buy a replacement as the original was lost. Once I got the FOB I was able to reset the awning controller, and now both awnings door and patio work great and I never use the toggle switches anymore, just the remote.
__________________
John & Debbie
2008 Fleetwood Discovery 40X
KF5UMC is offline   Reply With Quote
Reply

Tags
awning, power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slide not working / motor is working chrisc8869 5th Wheel Discussion 5 08-15-2015 06:24 PM
Weather Pro Power Awning Not Working needlenoses Class A Motorhome Discussions 5 01-07-2015 08:38 AM
06 Monaco Executive Door Awning Not Working AUExec Monaco Owner's Forum 5 03-05-2011 02:42 PM
Electric Door Awning not working Hugginator Winnebago Industries Owner's Forum 4 12-28-2010 07:23 PM
HWH Jacks working, not working and working again? Bob&Pat Winnebago Industries Owner's Forum 6 06-08-2006 04:22 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 07:56 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.