Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-11-2021, 09:38 AM   #1
Junior Member
 
Join Date: Aug 2017
Posts: 10
Powergear reset switch

I have a 2000 Fleetwood Southwind 32V. I recently put in a new battery, main chassis, and since then the hydraulic leveling system stop working. I was told by Lippert that there is a reset switch for the leveling system, but they didn't know where it was located on my unit. I called Fleetwood, no help there. I've had one rv repairman out and he couldn't fine it and we changed out some fuses etc. Any help is greatly appreciated. By the way, the control does light up, but the functions don't work.
renorich is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-11-2021, 03:53 PM   #2
Senior Member
 
Hittntheroad's Avatar
 
Join Date: Mar 2016
Location: Morehead City NC
Posts: 417
There is a reset procedure by holding down several buttons at once. Will see if I can find which ones.
__________________
2016 Jayco Precept 31 UL
Hittntheroad is offline   Reply With Quote
Old 11-11-2021, 08:21 PM   #3
Senior Member
 
Join Date: Jul 2018
Location: Oklahoma
Posts: 180
Hopefully this works, it was passed off to me by a member of this group, payin forward.

https://lci-support-doc.s3.amazonaws...370-rev.-2.pdf
__________________
Questios, questions, questions. Yeah, Iím that guy. But, Iím learnin!
2009 American Tradition 42P. ISL Cummins 425hp, Spartan chassis w/ tag, Allison trans,
Jandcinok is offline   Reply With Quote
Old 11-11-2021, 08:24 PM   #4
Senior Member
 
Join Date: Jul 2018
Location: Oklahoma
Posts: 180
https://support.lci1.com/power-gear-...eveling-system


And this one, hope it helps.
Jandcinok is offline   Reply With Quote
Old 11-11-2021, 11:13 PM   #5
Junior Member
 
Join Date: Aug 2017
Posts: 10
Thank you

Unfortunately I don't have the auto leveling system. The control panel is different then the one shown. Mine is an older manual system.
renorich is offline   Reply With Quote
Old 11-14-2021, 08:46 AM   #6
Senior Member
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Mcdonough, Ga.
Posts: 5,701
At our dealership we had this happen a couple of times. Both times it happened after a battery change Both times it was caused by the jack lead being left off. Go to the jack solenoid. Follow the heavy lead back to the battery. I bet you will find the lead is not attached to the battery. Let us know what you find.
__________________
1998 Pace Arrow 35 ft. F53 Ford V10 2014 Honda CRV toad
32 years mechanic at Delta Air Lines 15 year motorhome service manager. 3 popups....2 travel trailers....5 motorhomes....loved them all.
ga traveler is offline   Reply With Quote
Old 11-15-2021, 03:29 PM   #7
Junior Member
 
Join Date: Aug 2017
Posts: 10
Jack reset

Thank you for your response, but it seems everything is connected. The on light on the control panel lights up and when I push the "retract Jacks" button it lights up until it realizes they are already up.
renorich is offline   Reply With Quote
Old 11-16-2021, 08:24 AM   #8
Senior Member
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Mcdonough, Ga.
Posts: 5,701
Quote:
Originally Posted by renorich View Post
Thank you for your response, but it seems everything is connected. The on light on the control panel lights up and when I push the "retract Jacks" button it lights up until it realizes they are already up.
The panel gets it power through a 12 volt wire inside the motorhome. If the main pump power wire was left off, you would still have panel power.
It still sounds like you left the wire off or a fuse or breaker tripped.
I say again, go to the solenoid on the jack pump. Follow the large power wire back to the battery. I think you will find a breaker, fuse or the wire not connected.
I don’t think this is a componite failure because it started when you changed the battery.
__________________
1998 Pace Arrow 35 ft. F53 Ford V10 2014 Honda CRV toad
32 years mechanic at Delta Air Lines 15 year motorhome service manager. 3 popups....2 travel trailers....5 motorhomes....loved them all.
ga traveler is offline   Reply With Quote
Old 11-17-2021, 11:57 AM   #9
Junior Member
 
Join Date: Aug 2017
Posts: 10
Reset

I went under the RV and traced the cable as far as I could. ( I'm 76 yrs old, not easy for me anymore lol ) and couldn't fine a loose wire or switch. I'm going to take the battery out and see if I let a wire drop when I did it originally. Thank you so much for your replies. I'll probably fine the line and then kick myself.
renorich is offline   Reply With Quote
Old 11-17-2021, 02:02 PM   #10
Senior Member
 
Hittntheroad's Avatar
 
Join Date: Mar 2016
Location: Morehead City NC
Posts: 417
Quote:
Originally Posted by renorich View Post
I went under the RV and traced the cable as far as I could. ( I'm 76 yrs old, not easy for me anymore lol ) and couldn't fine a loose wire or switch. I'm going to take the battery out and see if I let a wire drop when I did it originally. Thank you so much for your replies. I'll probably fine the line and then kick myself.

I get calls all the time from boat owners that replace their own batteries. Lots of times I remove the batteries to find a wire has fallen down somewhere. Battery compartments are cramped most of the time and itís easy to miss a wire. I take a picture and sometimes wire tie each set of wires together. Hoping thatís what you find.
__________________
2016 Jayco Precept 31 UL
Hittntheroad is offline   Reply With Quote
Old 11-23-2021, 03:02 PM   #11
Junior Member
 
Join Date: Jul 2016
Posts: 4
Quote:
Originally Posted by renorich View Post
I have a 2000 Fleetwood Southwind 32V. I recently put in a new battery, main chassis, and since then the hydraulic leveling system stop working. I was told by Lippert that there is a reset switch for the leveling system, but they didn't know where it was located on my unit. I called Fleetwood, no help there. I've had one rv repairman out and he couldn't fine it and we changed out some fuses etc. Any help is greatly appreciated. By the way, the control does light up, but the functions don't work.

When putting battery back in, hook up positive lead first then ground lead. Worked for us in one of our cars.
ppars1948 is offline   Reply With Quote
Old 11-23-2021, 03:05 PM   #12
Junior Member
 
Join Date: Jul 2016
Posts: 4
Hook up positive lead first then ground lead. We had a car that acted very similar, no levelers but something else, hubby disconnected battery, hooked positive lead first and then ground lead and all was well. Hope it works.
ppars1948 is offline   Reply With Quote
Old 11-23-2021, 04:35 PM   #13
Senior Member
 
gt350ed's Avatar
 
Join Date: Nov 2012
Posts: 116
Not sure if this will help. Ours is a 2000 Pace Arrow Vision. So I would assume the Power Gear leveling system is the same. My symptoms were the same except I was not changing batteries. Same lights on, but system stopped operating. After trying several different things, we found that the ground wire for the pump was no longer making a solid enough contact with the chassis. Rust and or corrosion. This particular ground is in the compartment with the pump, motor and hydraulic tank. Once we unbolted the ground wire, cleaned everything to make a better contact and retightened it, everything worked. This after a year of fretting and wondering if I needed the upgraded version of the now obsolete control panel.
__________________
Ed
2000 Pace Arrow Vision 36B
gt350ed is offline   Reply With Quote
Old 11-24-2021, 06:32 AM   #14
Senior Member
 
Tha_Rooster's Avatar
 
Join Date: Aug 2008
Location: Georgia
Posts: 7,249
Quote:
Originally Posted by renorich View Post
I have a 2000 Fleetwood Southwind 32V. I recently put in a new battery, main chassis, and since then the hydraulic leveling system stop working. I was told by Lippert that there is a reset switch for the leveling system, but they didn't know where it was located on my unit. I called Fleetwood, no help there. I've had one rv repairman out and he couldn't fine it and we changed out some fuses etc. Any help is greatly appreciated. By the way, the control does light up, but the functions don't work.


Since it stopped working after changing batteries check wiring.
__________________
2007 Fleetwood Revolution LE 40V
Tha_Rooster is offline   Reply With Quote
Reply

Tags
power, switch



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to reset GFCI outlet with no reset button??? anthonynalli 5th Wheel Discussion 55 04-24-2018 12:39 AM
Atwood Water heater reset switch? emiddleb RV Systems & Appliances 8 07-19-2015 09:12 PM
2002 Monaco Diplomat ABS / ATC light - reset switch location? FLNavyVet Monaco Owner's Forum 8 01-07-2015 11:40 PM
Locating gfi reset switch John WW RV Systems & Appliances 4 04-22-2013 04:08 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 03:55 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.