Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-30-2021, 05:00 PM   #1
Junior Member
 
Join Date: Mar 2021
Posts: 3
Starting batteries dead

2002 Fleetwood Discovery with diesel engine.
My starting batteries are dead. They were new in April after being replaced then. They are apparently not getting charged when setting parked for several months.
Fred S. is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-30-2021, 05:58 PM   #2
Senior Member
 
Join Date: Jul 2014
Posts: 28,381
If they charged in the past, check the float voltage of the house batteries. They need to be over 13.4 volts to start charging the chassis battery.
Could be a bad battery temp sensor, part of the inverter/charger.

Or, if you have a Lambert L415 charger next to your isolator, see if the green light is on.Click image for larger version

Name:	Capture%2B_2021-07-30-19-56-47.jpg
Views:	12
Size:	49.9 KB
ID:	337847
twinboat is offline   Reply With Quote
Old 08-03-2021, 12:40 PM   #3
Junior Member
 
Join Date: Mar 2021
Posts: 3
I have a freedom combi, it's lights are normal. I am persuing replacing the house batteries. Then if I still Have a charging problem I will have the inverter repaired.
Fred S. is offline   Reply With Quote
Reply

Tags
batteries



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dead dead dead batteries...help! RebelSouls Newmar Owner's Forum 56 04-14-2021 11:46 AM
Starting batteries almost dead, jimbo2013 RV Systems & Appliances 4 06-26-2014 04:01 PM
Dead Starting Batteries smaaj Tiffin Owner's Forum 1 03-10-2013 03:18 PM
Starting generator with dead batteries AvoJim National RV Owner's Forum 12 06-27-2012 10:14 PM
Dead Starting Batteries bdpreece Monaco Owner's Forum 41 08-28-2011 08:00 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 09:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.