RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-22-2020, 05:37 PM   #1
Junior Member
 
Scuba00's Avatar
 
Join Date: Nov 2018
Posts: 10
Question Surge Guard

Surge guard (41260) installed in one of the bays, has two red lights that are both lit. Next to it says service required. By service required does that mean replace or that it can be reset by a technician? I use a pedestal surge protector that checks to make sure it is safe prior to plugging in so not sure what could have caused this - any ideas?

Thanks
Steve
__________________
Steve & Tisha Sutton
2019 Fleetwood Discovery 38N
Living the Dream
Scuba00 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-22-2020, 06:59 PM   #2
Senior Member
 
R.Wold's Avatar


 
Newmar Owners Club
Ford Super Duty Owner
Freightliner Owners Club
Retired Fire Service RVer's
Join Date: Jan 2019
Location: Rosemary Farm, Northern Ca
Posts: 2,648
It could mean there was a surge and it blew its fuse and needs a new one installed. Are you still getting power trough it?
__________________
2016 Ventana 3427
R.Wold is online now   Reply With Quote
Old 09-22-2020, 07:14 PM   #3
Senior Member
 
dkoldman's Avatar
 
Winnebago Owners Club
Ford Super Duty Owner
Join Date: Oct 2019
Location: Dallas, Texas
Posts: 508
Quote:
Originally Posted by Scuba00 View Post
Surge guard (41260) installed in one of the bays, has two red lights that are both lit. Next to it says service required.

Thanks
Steve
Pictures? Are you looking inside the Switch or do you see something next to the Switch. I think you have the Surge Guard brand of Transfer Switch. There may be something in front or behind it that is blown? Pictures to be clear...
__________________
2019 Sunstar 29VE
Safe T Plus; EC-30 AGS Nighthawk X4 AC2200 WiFi EX7300; H/W Heater & Chassis Disconnect Switches; Surge Guard 44270
dkoldman is offline   Reply With Quote
Old 09-22-2020, 08:08 PM   #4
Senior Member
 
Join Date: Feb 2018
Posts: 187
Quote:
Originally Posted by Scuba00 View Post
Surge guard (41260) installed in one of the bays, has two red lights that are both lit. Next to it says service required. By service required does that mean replace or that it can be reset by a technician? I use a pedestal surge protector that checks to make sure it is safe prior to plugging in so not sure what could have caused this - any ideas?

Thanks
Steve
With the model number you should be able to download the answer with a short internet search. Nice unit.
__________________
Pete
2019 Newmar Bay Star Sport 3008
2004 Jeep Wrangler LJ with Blue Ox and Stay In Play brakes
PetesMH is offline   Reply With Quote
Old 09-22-2020, 08:47 PM   #5
Senior Member
 
dkoldman's Avatar
 
Winnebago Owners Club
Ford Super Duty Owner
Join Date: Oct 2019
Location: Dallas, Texas
Posts: 508
I saw this from a Southwire FAQ, I don't have your model but I do have Southwire ATS. I have true Southwire Surge Guard Protector in front of my ATS that has series of lights to tell me the condition of power. You may need your ATS replaced. If so; I would suggest a better surge protector in front of ATS.

What does the RED "protected" indicator LED on my surge guard tell me?
If the “SURGE” indicator light is on, it means that the built-in surge protection has absorbed its capacity or been sacrificed to protect your equipment and is
no longer functioning properly. The surge guard is recommended to be replaced. Any questions can be answered by Technical Support
__________________
2019 Sunstar 29VE
Safe T Plus; EC-30 AGS Nighthawk X4 AC2200 WiFi EX7300; H/W Heater & Chassis Disconnect Switches; Surge Guard 44270
dkoldman is offline   Reply With Quote
Old 09-23-2020, 09:04 AM   #6
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 23,034
The 41260 Troubleshooting Guide isn't much help (link below). However, "Service required" means something beyond what the owner might be expected to do, i.e. requires opening the case to do something inside. I doubt if there is any simple "reset button" inside, but a tech might be able to replace a component. You could send it back to Southwire (Surgeguard), but my guess is that they will just say to replace it anyway. The most likely explanation is that the surge guard self-sacrificed to prevent a damaging surge from reaching your coach systems.



The 41260 is a combo surge protect and ATS. My choice would be to install a separate ATS and add a hardwired surge/power protection unit. That way you don't have to buy a new ATS every time the surge unit sacrifices itself to protect you.



https://rvpower.southwire.com/wp-con...1260-DSG-3.pdf
__________________
Gary Brinck
Former owner of 2004 American Tradition and several other RVs
Home is in the Ocala Nat'l Forest near Ocala, FL
Summers in Black Mountain, NC
Gary RVRoamer is offline   Reply With Quote
Old 09-26-2020, 07:05 PM   #7
Junior Member
 
Scuba00's Avatar
 
Join Date: Nov 2018
Posts: 10
Apologizes - Wrong Model #

I incorrectly stated that my surge guard was one model when in reality it is a Surge Guard 40350RVC, and appears to be functioning normally. The mystery to my issue remains - posted in Frustrating Day in the Discovery forum.

Steve
Scuba00 is offline   Reply With Quote
Reply

Tags
surge guard



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Surge protector or surge guard? Klibber Travel Trailer Discussion 8 06-11-2018 06:58 AM
Autoformer with Surge Protection AND/OR Surge Guard specmga1 Newmar Owner's Forum 22 11-23-2016 01:30 PM
Surge Guard portable surge protector Bymorris Class A Motorhome Discussions 15 11-30-2013 07:39 AM
Rock guard, tow guard mud flap ctpres Class A Motorhome Discussions 3 04-30-2012 04:42 PM
Surge Guard or Progressive Industries Surge Protector ? VACMAN Newmar Owner's Forum 41 08-20-2009 10:22 AM


All times are GMT -6. The time now is 10:20 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.