Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-26-2022, 12:21 PM   #1
Junior Member
 
Join Date: Oct 2015
Posts: 22
Surge Guard

I have a surgeguard 40250-RVC that operates properly except that the red lights on the unit do not light up & I think they used to. I am plugged into a 30Amp at my house, do they only light up on 50 Amp service? Or does it mean the surge protection is not working? I emailed surgeguard a week ago and have not heard back. 2014 Bounder 35K. I have added a Multiplus 2 so power comes out of this unit, to the Multiplus & then back to the breaker box.
__________________
2014 Bounder 35K
dsintrepid is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-26-2022, 04:02 PM   #2
Senior Member
 
Old-Biscuit's Avatar
 
Join Date: Nov 2015
Posts: 23,077
Red Lights should be ON

30A adapter jumpers the 1 HOT to Both L1 & L2 of the 50A

Do you have the Remote Display?
*What is it showing....voltage, amps etc
__________________
I took my Medication today. HAVE YOU?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is online now   Reply With Quote
Old 09-26-2022, 04:47 PM   #3
Junior Member
 
Join Date: Oct 2015
Posts: 22
With everything off or in standby mode
122V 0A
122V 0A

With 2 Air conditioners on
118V 15A
118V 0A

I am pretty sure this is how it has always reacted on 30A here at my house.
__________________
2014 Bounder 35K
dsintrepid is offline   Reply With Quote
Old 10-01-2022, 11:06 AM   #4
Junior Member
 
Join Date: Oct 2022
Posts: 1
I was told by Newmar Service the red lights confirm communication is active to the board for Surge Guard 40350 RVC
EasyCamper2 is offline   Reply With Quote
Old 10-01-2022, 11:16 AM   #5
Senior Member
 
ArtJoyce's Avatar
 
Monaco Owners Club
Freightliner Owners Club
Holiday Rambler Owners Club
Join Date: Sep 2019
Location: Thornville, Ohio
Posts: 2,695
My 50 amp surge protector lights up with two good lines on 30 amps. It does not know I'm on 30 amps service because how the 30/50 adapter is wired.
__________________
Art & Joyce
Thornville, OH
Kia Soul pushing a 36' DP Endeavor
ArtJoyce is offline   Reply With Quote
Old 10-01-2022, 11:51 AM   #6
Senior Member
 
Old-Biscuit's Avatar
 
Join Date: Nov 2015
Posts: 23,077
Quote:
Originally Posted by dsintrepid View Post
With everything off or in standby mode
122V 0A
122V 0A

With 2 Air conditioners on
118V 15A
118V 0A

I am pretty sure this is how it has always reacted on 30A here at my house.
Quote:
Originally Posted by EasyCamper2 View Post
I was told by Newmar Service the red lights confirm communication is active to the board for Surge Guard 40350 RVC
Quote:
Originally Posted by ArtJoyce View Post
My 50 amp surge protector lights up with two good lines on 30 amps. It does not know I'm on 30 amps service because how the 30/50 adapter is wired.
Red lights should be ON

Surge Guard looks for Voltage not amperage

Remote Monitor measures volts/amps on each leg
2 A/Cs running, 15A on one Leg but 0A on other leg???
__________________
I took my Medication today. HAVE YOU?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is online now   Reply With Quote
Old 10-07-2022, 09:30 AM   #7
Senior Member
 
AlanTerry's Avatar
 
Fleetwood Owners Club
Join Date: Dec 2010
Location: Cincinnati, Ohio
Posts: 578
Did you go to “ask question “page?

Quote:
Originally Posted by dsintrepid View Post
I have a surgeguard 40250-RVC that operates properly except that the red lights on the unit do not light up & I think they used to. I am plugged into a 30Amp at my house, do they only light up on 50 Amp service? Or does it mean the surge protection is not working? I emailed surgeguard a week ago and have not heard back. 2014 Bounder 35K. I have added a Multiplus 2 so power comes out of this unit, to the Multiplus & then back to the breaker box.
Here is the link for ask a question page:

https://www.southwire.com/recreational-power

They called right away.

Red blinking slowly equals LOW VOLTAGE
red blinking fast equals HIGH VOLTAGE
Red lights should be on anytime connected to electricity.
__________________
Alan & Terry 2016 Bounder 34T
Blue Ox Alpha Tow Bar, RVi brake 2system
2015 Jeep Trail Hawk (Toad),WeBoost,Tire Minder TPMS. 1000 watts of Solar
AlanTerry is offline   Reply With Quote
Old 10-08-2022, 12:20 AM   #8
Junior Member
 
Join Date: Oct 2015
Posts: 22
Quote:
Originally Posted by Old-Biscuit View Post
Red lights should be ON



Surge Guard looks for Voltage not amperage



Remote Monitor measures volts/amps on each leg

2 A/Cs running, 15A on one Leg but 0A on other leg???
Yes about the 2 acs and 15amps on one line
__________________
2014 Bounder 35K
dsintrepid is offline   Reply With Quote
Old 10-08-2022, 12:21 AM   #9
Junior Member
 
Join Date: Oct 2015
Posts: 22
I am hooked up to 50 amps now and everything is operating fine except no red lights. I think I need a new unit and will reach out to the manufacturer again. Like old-biscuit said red lights should be on.
__________________
2014 Bounder 35K
dsintrepid is offline   Reply With Quote
Reply

Tags
surge guard



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SURGE GUARD PROTECTION - on Tiffin Progressive vs Surge Guard? JimLuk Tiffin Owner's Forum 17 12-24-2020 10:36 PM
Surge protector or surge guard? Klibber Travel Trailer Discussion 8 06-11-2018 07:58 AM
Autoformer with Surge Protection AND/OR Surge Guard specmga1 Newmar Owner's Forum 22 11-23-2016 02:30 PM
Surge Guard portable surge protector Bymorris Class A Motorhome Discussions 15 11-30-2013 08:39 AM
Surge Guard or Progressive Industries Surge Protector ? VACMAN Newmar Owner's Forum 41 08-20-2009 11:22 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 05:35 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.