Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Gulf Stream Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-14-2010, 10:31 PM   #1
Registered User
 
Gulf Streamers Club
Join Date: Jun 2010
Location: Trois-Rivieres, QC, Canada
Posts: 414
Send a message via Skype™ to normandlegra
LCI automatic leveling

Just got last wednesday my new GS Yellowstone 8367; went out camping over the week end and NO PROBLEM.
Back home, parked the RV and today wanted to go out, the hydraulic jacks won't retract !
I've "reset" by holding all 4 arrows, but no issue...

Anyone knows what could be the problem ?
normandlegra is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-15-2010, 03:43 AM   #2
Moderator Emeritus
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,060
Have you checked to be sure you have 12 volt power at the pump solenoid? If not you may have a tripped circuit breaker near the battery bank. If you do have power does the pump run when you press the retract button? Is your battery voltage up and the banks turned on?
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 06-15-2010, 05:55 AM   #3
Senior Member
 
Shellback1's Avatar
 
Damon Owners Club
Ford Super Duty Owner
Join Date: Jul 2008
Location: Nashua, NH
Posts: 721
Send a message via AIM to Shellback1
Quote:
Originally Posted by normandlegra View Post
Just got last wednesday my new GS Yellowstone 8367; went out camping over the week end and NO PROBLEM.
Back home, parked the RV and today wanted to go out, the hydraulic jacks won't retract !
I've "reset" by holding all 4 arrows, but no issue...

Anyone knows what could be the problem ?

Last time mine failed it was the circuit breaker, that opens to an "L" shape. It is usually no more han 18" from the + side of the battery. Mine is mounted on the frame.

__________________
2006 Damon Daybreak 3274 35' Ford F53 V-10
2006 Ion Retired Navy, FAA and PASS Union VP
[SIGPIC][/SIGPIC]
Shellback1 is offline   Reply With Quote
Old 06-15-2010, 06:22 AM   #4
Registered User
 
Gulf Streamers Club
Join Date: Jun 2010
Location: Trois-Rivieres, QC, Canada
Posts: 414
Send a message via Skype™ to normandlegra
Thanks, I'll check both points and will get back to you.
normandlegra is offline   Reply With Quote
Old 06-15-2010, 03:24 PM   #5
Senior Member
 
bullydogs1's Avatar
 
Join Date: Apr 2007
Posts: 470
I couldn't help but see this post as the LCI component jack/slide system has had its share of woes...I'd run engine...make sure parking brake is set...push on button, then push retract all jacks...You can also call LCI and their website is lci1.com....they will help you.
__________________
Stuart and Stella Denning
2016 Entegra Aspire 42RBQ
3 Bullies and a Diesel Pusher
bullydogs1 is offline   Reply With Quote
Old 06-15-2010, 04:44 PM   #6
Registered User
 
Gulf Streamers Club
Join Date: Jun 2010
Location: Trois-Rivieres, QC, Canada
Posts: 414
Send a message via Skype™ to normandlegra
Finally, this morning I called my dealer and with the help of one of their technicians, we found that one breaker supplying 12 VOLTS to the hydraulic pump had to be reset; minutes later all came back to normal.
p.s. with this problem, I've learned how the hydraulic pump controls my 4 jacks and 2 of my slide-outs, since the 3rd one works only on electricity.
Thanks to everyone.
normandlegra is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Manual to Automatic Leveling smokey5209 Fleetwood Owner's Forum 7 05-29-2010 01:21 PM
Problem with HWH automatic leveling jacks on my 97 Newmar Mountainaire genegunnels Newmar Owner's Forum 21 10-17-2009 02:49 AM
Winnebago 07 - Automatic leveling jacks... Dive-n-diva Winnebago Industries Owner's Forum 6 05-28-2009 09:15 PM
LCI Auto Leveling ??? Cayman Dave Damon 6 07-25-2008 10:50 AM
Bounder: Leveling manually an Automatic system travel Fleetwood Owner's Forum 1 06-04-2006 05:37 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 01:09 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.