RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Country Coach Owners Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-18-2020, 09:25 PM   #1
Member
 
Join Date: Mar 2017
Posts: 49
Flashers not working

We have a 2002 Affinity 42' and tow a Ford Edge. After a few months the turn signals started working erratically, then quit. I replaced the standard auto flasher with an identical one and it lasted about a week. Found a heavy duty unit at Auto Zone but the old one slipped when I tried to remove it it slipped and now I'm not sure of the installiation orientation. The receptacle has plugs at the 9, 6 and 3 oclock positions but the flasher has only two pins so it will fit either the 9/6 or 6/3 positions. Tried the new flasher in both orientations, got 1 flash and then nothing. No voltage at the recepticle with the key on. Fuse? Nothing looks blown on the driver's side panel. If so, where is it? Thanks for any and all help! Rich McCune
holyrollers is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Four Way Flashers not working IBullock Winnebago Industries Owner's Forum 15 09-26-2019 07:25 AM
Flashers and Blinkers (Rear) not working SX_RVing Newmar Owner's Forum 23 05-23-2018 06:33 PM
Turn signals and emergency flashers not working deewhite0612 Spartan Motorhome Chassis Forum 4 11-01-2015 05:49 AM
Flashers not working Carolina Fun Workhorse and Chevrolet Chassis Motorhome Forum 19 05-03-2012 06:46 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 10:46 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×