Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Country Coach Owners Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-23-2021, 02:40 PM   #15
Senior Member
 
Ljwt330's Avatar
 
Join Date: Jan 2018
Location: Capistrano Beach, California
Posts: 4,465
Quote:
Originally Posted by mike brez View Post
Turns like normal and fires up in one second.
To me, consistent excessive resistance at starter motor, including grounds. Have you checked the heavy ground straps bolted to the transmission and/or engine? Binding starter drive shaft or motor bearings also still in play.
__________________
Larry, Eileen, and Finley
2004 Alpine 36FDDS
Third motor home, first Alpine, no need for another.
Ljwt330 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-25-2021, 08:13 AM   #16
Registered User
 
Join Date: May 2005
Location: Milford,CT.
Posts: 2,237
Ok thanks everybody found it. 3/8 eyelet wire connector was broke inside loom.
Crimped on new connector with heat shrink re connected and fired right up.
mike brez is offline   Reply With Quote
Old 10-25-2021, 05:33 PM   #17
Senior Member
 
Smitty77's Avatar
 
Join Date: Aug 2010
Location: Over the next hill, around the next curve...
Posts: 5,346
Quote:
Originally Posted by mike brez View Post
Ok thanks everybody found it. 3/8 eyelet wire connector was broke inside loom.
Crimped on new connector with heat shrink re connected and fired right up.
THANK YOU! For posting the Root Cause!

I can not tell you how many times I've found a thread like this, that has helped me when Bird Dawging down a problem. It's these obscure ones, that take the time to figure out!

Smooth starting, and travels,
Smitty
__________________
07 Country Coach Magna Rembrandt 45' ISX600
Roo II was our 04 Country Coach Allure 40'
OnDRoad for The JRNY! Enjoy life...
Smitty77 is online now   Reply With Quote
Old 10-25-2021, 08:18 PM   #18
Senior Member
 
dons2346's Avatar
 
Country Coach Owners Club
Join Date: Dec 2010
Posts: 6,934
Mike, where was the culprit located?
__________________
Don
2002 Country Coach Intrigue
dons2346 is offline   Reply With Quote
Reply

Tags
batteries, no start



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine and Generator won't start with new batteries--did I fry something? Doug Simpson Monaco Owner's Forum 28 01-29-2020 07:57 AM
Batteries, batteries, batteries Farkey Class A Motorhome Discussions 24 04-26-2019 01:44 PM
Batteries, Batteries, Batteries... JasonDean Newmar Owner's Forum 46 07-09-2016 08:58 AM
Auxiliary Batteries vs. Main Batteries - which is which? Batteries dying.......😞 Napabeth Fleetwood Owner's Forum 16 08-05-2015 01:54 PM
New house batteries and the Generator still won't start Gary G. RV Systems & Appliances 8 08-31-2013 07:41 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 03:08 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.