Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Country Coach Owners Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-24-2022, 04:05 AM   #1
Member
 
Join Date: May 2019
Location: O'Brien FL
Posts: 64
smart wheel

well here we go folks another issue, just all of a sudden the controls on my steering wheel for my 03 magna stopped. I do have power and ground and the pulse thru the wires the the circuit board in the wheel itself. Has anyone else have experience and a fix.
firedan is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-24-2022, 08:46 AM   #2
Senior Member
 
gnvrvin's Avatar


 
Join Date: Aug 2017
Location: Burien, Wa
Posts: 932
FireDan

I have not experience this but do recall others have and it was a frayed wire in the wheel usually at the pivot point where it rubbed the wire

Greg
__________________
Greg and Vicki R.
2004 Country Coach Intrigue "Sweet Serenade"
40' Tag Axle Quad slide CCI #11811
16 Jeep Wrangler, Airforce One
gnvrvin is offline   Reply With Quote
Old 06-24-2022, 08:57 AM   #3
Member
 
Join Date: May 2019
Location: O'Brien FL
Posts: 64
thanks i will check that again, im hoping its that simple
firedan is offline   Reply With Quote
Old 06-28-2022, 01:55 PM   #4
Member
 
Join Date: May 2019
Location: O'Brien FL
Posts: 64
has to be loose wire it worked no it dont anyone know the 4 wires at the wheel what ground and what is 12 volt thanks anyone
firedan is offline   Reply With Quote
Old 06-28-2022, 04:50 PM   #5
Senior Member
 
BrianGlenn's Avatar
 
Country Coach Owners Club
Join Date: Apr 2015
Location: Alberta
Posts: 1,546
Quote:
Originally Posted by firedan View Post
has to be loose wire it worked no it dont anyone know the 4 wires at the wheel what ground and what is 12 volt thanks anyone
The smartwheel era for your coach should be the SM209 master controller.

The 4 wires are 12V for backlight and backlight ground. The other 2 are MPX (network) positive and ground.

Simplest is to troubleshoot as per VIP (now Immi) documents for that smartwheel era. I've attached it - From Here.....Immi.

Wiring diagram is near the end of the document, troubleshooting starts about page 5.

Hope this helps,
Brian
Attached Files
File Type: pdf VIP SM209 TROUBLESHOOT.pdf (331.0 KB, 6 views)
__________________
Towr: 2007 Country Coach Allure 470 - 37 Sunset Bay Cummins 400 ISL, Coach #31563
Toad: 2016 F150 King Ranch - 3.5L EcoBoost 4x4 Supercrew (curb weight 4,775 lbs)
Toad: SOLD 2007 Jeep Grand Cherokee (yes, it has a Hemi) (curb weight 4,720 lbs)
BrianGlenn is offline   Reply With Quote
Old 06-28-2022, 05:47 PM   #6
Member
 
Join Date: May 2019
Location: O'Brien FL
Posts: 64
great info thank you now i need to locate the controller
firedan is offline   Reply With Quote
Old 06-28-2022, 06:40 PM   #7
Member
 
Join Date: May 2019
Location: O'Brien FL
Posts: 64
ruled out the clock spring and the ground is fine, not getting power to the 2 wires, now where can i look for the control box. I didnt see anything under the driver comp.
firedan is offline   Reply With Quote
Old 06-29-2022, 09:40 AM   #8
Member
 
Join Date: May 2019
Location: O'Brien FL
Posts: 64
found the module tucked up behind bunch wires on the passenger side on to hopefully figure the problem
firedan is offline   Reply With Quote
Old 06-29-2022, 11:59 AM   #9
Member
 
Join Date: May 2019
Location: O'Brien FL
Posts: 64
problem solved the harness to the clock spring was bad, thank s Brian for the link huge help
firedan is offline   Reply With Quote
Old 06-30-2022, 12:47 PM   #10
Senior Member
 
gnvrvin's Avatar


 
Join Date: Aug 2017
Location: Burien, Wa
Posts: 932
Great to hear firedan
Where was the harness bad at?

Greg
__________________
Greg and Vicki R.
2004 Country Coach Intrigue "Sweet Serenade"
40' Tag Axle Quad slide CCI #11811
16 Jeep Wrangler, Airforce One
gnvrvin is offline   Reply With Quote
Old 06-30-2022, 05:24 PM   #11
Senior Member
 
Smitty77's Avatar
 
Join Date: Aug 2010
Location: Over the next hill, around the next curve...
Posts: 5,285
I'm also interested in where the harness was at fault...

We replaced a clock spring on a new to us 07 Magna when we bought her... But really not sure that was our problem, as we've had intermittent 'Well that's strange!' behavior at times since then. When our's starts being a bit different, I'll move the Tilt and or the Telescope a bit, and that usually gets everything working properly again...

And yeah, I should take the time to tear down and inspect, but admit, since it always seems to work with a bit of adjustment by two buttons - well, I spend my energy and time elsewhere in the coach!

Glad you found the root cause... And appreciate you closing the loop back, as it could help others while searching problems in the future!
Smitty
__________________
07 Country Coach Magna Rembrandt 45' ISX600
Roo II was our 04 Country Coach Allure 40'
OnDRoad for The JRNY! Enjoy life...
Smitty77 is offline   Reply With Quote
Old 06-30-2022, 05:33 PM   #12
Member
 
Join Date: May 2019
Location: O'Brien FL
Posts: 64
i came across what looks like a plug on bottom of clock spring with the 4 wires and held the plug on top of the clock spring and all started to work. I kinda ruled out the clock spring as i had continuity be the main harness and the wires into the circuit board where the switches are. Have not tore down yet as i want a clock spring 1st so anyone knows where to get one would be great
firedan is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Smart car for Toad? Who has a Smart toad? seb1899 Toads and Motorhome Related Towing 3 11-03-2018 08:23 AM
Smart TV or no Smart TV? tmw188 Technology: Internet, TV, Satellite, Cell Phones, etc. 8 08-16-2016 08:41 PM
Smart TV or Smart RV or Roku lbaldwin Technology: Internet, TV, Satellite, Cell Phones, etc. 10 08-10-2015 04:05 PM
Smart wheel control on 02 Windsor, is now a dumb wheel KCSAILS Monaco Owner's Forum 3 07-01-2014 02:55 PM
smart visor vs power smart visor tncruiser Class A Motorhome Discussions 3 11-05-2010 11:28 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 02:16 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.