Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-21-2019, 10:47 AM   #15
Senior Member
 
Join Date: Jul 2014
Posts: 28,967
Quote:
Originally Posted by RamiDav View Post
When a diesel spins but doesn't start you can usually find a fuel problem .


IMHO the easiest place to start is fuel filters .



Have you done anything recently to the fuel system , filters etc ?


I would replace both fuel filters , do them one at a time .
Pull the filter , look for any evidence of black goo ( algae ) or any other
trash that shouldn't be in the fuel system , it may be right on top , easy to see.

In your case I suggest you get a gal of clean diesel to 1st fill the new filters .


As stated you should hear the lift pump run when you turn the key to on .
You may need to go to the back of the coach or at least open the door
to hear the pump running .
My pump is loud enough so I can hear it while in the drivers seat .
This is all with the key on before starting the engine .


Good luck hope you get it running soon .
Let us know the outcome .


Ray
In many, many years of working on them, I've never run into a diesel that didn't start, after shutting it down, due to fuel filters, unless they were jelled.

In this no start situation, opening up the fuel system, to change filters, has the potential to add another no start issue.
twinboat is online now   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-21-2019, 01:43 PM   #16
Junior Member
 
Join Date: Apr 2017
Posts: 5
****UPDATE****

Both ECM fuses are good and there wss no power on either end of the fuse holders. The fuse block is located in the aft most compartment on the curb side, and has 3 large red wires approximately 6 gauge with 12 volts and an equal sized white wire that is ground on the left side; however, the ECM fuses are powered from 2 small red wires that come in via harness connectors on the right side. I made a jury rig bypass using an inline fuse holder and a switch to supply power to the ECM (image attached), and after cycling the key numerous times to top off and prime the 2 filters I replaced, she fired up.
Needed to get my wife to Florida for DR's appointments so drove it 726 miles over 2 days. Never missed a beat... now to try and track down where the ECM power originates to fix it right..
Trying to get schematics from REV now, the 2006 Endeavor schematics I have show ECM fuses are connected directly to the batteries.
Thanks for the support and suggestions, when I find the root cause and solution I will update this thread, if you have schematics for an o8 Diplomat or know a source please let me know.
Attached Thumbnails
Click image for larger version

Name:	20191119_114902.jpg
Views:	12
Size:	620.8 KB
ID:	267548  
danbrinson is offline   Reply With Quote
Old 11-22-2019, 07:09 PM   #17
YC1
Senior Member
 
YC1's Avatar


 
Join Date: Jun 2011
Location: FL
Posts: 9,675
In post 4 I attached a PDF. Is it of any use?

Endeavor is the sister to the Diplomat.

Here is the rear fuse panel with ECM fuses shown. Maybe this will help.
Attached Files
File Type: pdf Fuse Rear Distribution Panel Harness.1.pdf (78.4 KB, 17 views)
__________________
Myron & Deborah
08 HR Endeavor 40 SKQ
400 Isl, 400 HP/// Now 450 HP
2016 Ford F150 Limited V6 with Ready Brake
YC1 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
07 Diplomat Generator won't start from dash taz4028 Monaco Owner's Forum 1 11-27-2018 11:34 AM
98 Diplomat won't start rtr6646 Monaco Owner's Forum 13 09-20-2018 07:35 PM
'04 Diplomat - Inflating Airbags to Tow if Engine Won't Start tkcas01 Monaco Owner's Forum 15 11-02-2017 06:38 PM
99 Monaco Diplomat won't start snowsurfer56 Monaco Owner's Forum 29 12-18-2015 09:51 PM
2005 Monaco Diplomat won't start timeforus Class A Motorhome Discussions 14 03-04-2015 08:10 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 07:09 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.