Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-18-2021, 06:27 PM   #1
Senior Member
 
Join Date: Apr 2020
Location: Parris Island, SC
Posts: 298
10000K Quiet Diesel problems.

2000 Executive. Gets hot then shuts off. Recommendations please.

Thank Y'all,
__________________
Fast E.

2000 Monaco Executive. 350 Cummins.
Fast E is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-18-2021, 06:48 PM   #2
Senior Member
 
96 Wideglide's Avatar
 
Holiday Rambler Owners Club
Join Date: Aug 2010
Posts: 7,882
Belt still on and turning the fan?
__________________
Ben & Sharon
2008 43' Holiday Rambler Scepter PDQ
96 Wideglide is offline   Reply With Quote
Old 07-18-2021, 08:11 PM   #3
Senior Member
 
Traps90's Avatar
 
Monaco Owners Club
Join Date: Sep 2010
Location: Alberta
Posts: 1,419
Had a similar problem and ended up being a fuel filter
__________________
Trap, Jan and the Pup
2013 Monaco Diplomat 43dft
2010 Black Jeep Liberty
Traps90 is offline   Reply With Quote
Old 07-18-2021, 09:34 PM   #4
Member
 
2Yoopers's Avatar
 
Monaco Owners Club
Join Date: Aug 2020
Posts: 68
Quote:
Originally Posted by Traps90 View Post
Had a similar problem and ended up being a fuel filter
Mine started cutting out this spring intermediately. Changed the fuel filter on it and it fixed the problem too.
First thing to check is are you getting air from the fan like Ben said though. Someone posted recently that their radiator was clogged and needed cleaned, might check that out too.
__________________
Doug & Shannan
2007 Beaver Contessa
2Yoopers is offline   Reply With Quote
Old 07-19-2021, 06:12 AM   #5
Senior Member
 
RobRoy's Avatar
 
Join Date: Nov 2014
Posts: 1,525
Quote:
Originally Posted by Fast E View Post
2000 Executive. Gets hot then shuts off. Recommendations please.

Thank Y'all,

What fault codes do you have, if any?

Without that information you will be on a wild goose chase ...not that you wont find your issue ...it's just how much time it will take you to get there.



Happy Trails
__________________
2004 HR Navagator 500 ISM
RobRoy is offline   Reply With Quote
Old 07-20-2021, 01:22 PM   #6
Senior Member
 
Monaco Owners Club
Join Date: Jan 2017
Location: Utopia, TX
Posts: 390
Quote:
Originally Posted by RobRoy View Post
What fault codes do you have, if any?

Without that information you will be on a wild goose chase ...not that you wont find your issue ...it's just how much time it will take you to get there.

Happy Trails
Yep. That's the place to start.
There's also a troubleshooting guide in the Onan Mobile Genset Service Manual.
Cheers,
Walter
__________________
2003 Monaco Dynasty 42 Regal.
wamcneil is offline   Reply With Quote
Old 07-30-2021, 04:48 PM   #7
Senior Member
 
Join Date: Apr 2020
Location: Parris Island, SC
Posts: 298
I fixed it. Removed the panels to gain access to water pump. Fan belt loose as a goose. Tightened the belt. While in there decided to look for chaffed, cut wires. Did find one wire with male/female connections disconnected. Connected and put everything back together, (with the million bolts). Started right up and KEPT RUNNING while traveling. So, it was either the fan belt or the disconnected wires. Lord only knows because I am not taking that thing apart again. 2 hours tops.
__________________
Fast E.

2000 Monaco Executive. 350 Cummins.
Fast E is offline   Reply With Quote
Reply

Tags
diesel, ems, problem, problems, quiet



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan 7500 quiet generator too quiet!! won't start ?? ToddnRhonda Class A Motorhome Discussions 22 01-15-2020 10:55 AM
Onan 7.5 QD (Quiet Diesel) Generator GStream40 RV Systems & Appliances 11 06-15-2008 07:10 PM
Onan Hybrid Quiet Diesel HighwayRanger MH-General Discussions & Problems 13 02-29-2008 03:07 PM
Quiet Diesel 7500 Fuel leak Moder2 MH-General Discussions & Problems 6 02-21-2008 03:58 AM
High dollar ONAN Quiet Diesel not worth it! Dale Tomlinson Winnebago Industries Owner's Forum 2 05-17-2005 06:24 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 11:07 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.