RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-08-2012, 12:52 PM   #1
Member
 
Fleetwood Owners Club
Join Date: Jun 2012
Posts: 62
1999 Monaco Diplomat Power issue

I have a 1999 Monaco Diplomat When I run the Gen all my power works but when I plug it in only half of the electricity works. Only one AC runs and there are several lights in the back not working
Does anyone know what this could be?

Thanks for all your help

Danny
Translators7 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-09-2012, 07:39 AM   #2
Senior Member
 
Join Date: Feb 2010
Posts: 199
Dan, Get a VOM and test the the black wire to the white, and the red wire to the white wire to make sure you have 120 volts on each leg of the shore power going to the transfer switch. If you have a Todd transfer switch you may have a bad contactor/relay in it. Be careful and unplug from shore power and make sure your generator does not have an auto-start function. I would turn both battery bank switches off before pulling the cover off the transfer switch. George R. 2001 Diplomat PBD
__________________
George, 2001 40' Diplomat PBD
86 Cavalcade is offline   Reply With Quote
Old 07-21-2012, 11:08 AM   #3
Member
 
Fleetwood Owners Club
Join Date: Jun 2012
Posts: 62
Thank you for all your info
It appeared to be an issue with the AC units. After I replaced them with new units, everything worked fine

Danny
Translators7 is offline   Reply With Quote
Reply

Tags
monaco, power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:25 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.