Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-08-2022, 05:32 PM   #1
Senior Member
 
Ted DuPuis's Avatar
 
Join Date: Sep 2020
Posts: 224
2000 HR Endeavor Turn Signal Issue

Iíve been working on an electrical (lighting) issue on my 2000 Holiday Rambler Endeavor. I had multiple issues going on as it turns out and had a bad trailer harness adapter (removing that fixed most of my problems). However I am now trying to figure out whatís going on with my right turn signal.

With headlights off, right turn signal works correctly and as intended. The right side marker light (side of the bus, just ahead of the rear wheel) blinks opposite the front/rear turn signal as itís supposed to, same as the left.

With headlights on, the right turn signal indicator is always on on the instrument cluster. The right side marker light is NOT on (left side is). When I turn on the right turn signal the indicator blinks correctly, as do the front/rear turn signals. The marker light does NOT blink.

I have wiring diagrams but I was not able to figure out where this interconnect existed that might tie the marker light and turn signal together but only on the right side, nor am I sure how that is triggered. I had thought it might be a 3-wire marker light that handled that internally, but I removed it and confirmed that itís 2-wire.

Any suggestions appreciated!
Ted DuPuis is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-08-2022, 06:02 PM   #2
Senior Member
 
153stars's Avatar
 
Join Date: Mar 2019
Location: Braidwood Il.
Posts: 5,912
Sounds like a missing or poor ground. It's seeking a different ground path. Spent way too much time fixing trailer lights and darn chassis only grounds a lights. Two ground wires in one end of butt connector cause issues look in looms for taped up butt connectors un-tape examine butt connectors. Also broken bulb elements can cross , dirty rusty dual element bulb sockets can cause similar issue. Check shorted trailer plug wires sockets lastly trailer/toad module also.
__________________
95 Monaco Crown Royale
M11 400hp, 4060 trans.
Aquahot, Generac Guardian7.5k
153stars is offline   Reply With Quote
Reply

Tags
endeavor



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do you turn off speed limit warning and voice turn by turn strasinger RV LIFE Trip Wizard - Trip Planner Topics 2 03-29-2022 08:28 AM
98 HR Endeavor turn signal issues Ontuy1 Monaco Owner's Forum 6 04-25-2021 12:49 PM
03 HR Endeavor turn signal relay shoalsgary Monaco Owner's Forum 9 03-09-2020 01:17 PM
2007 Endeavor R front turn signal bulb sinterior Monaco Owner's Forum 1 04-04-2019 07:15 AM
Endeavor turn signal problem dmull Monaco Owner's Forum 11 07-14-2014 07:50 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 05:47 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.