Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-01-2022, 01:41 PM   #1
Member
 
Holiday Rambler Owners Club
Join Date: Jul 2018
Posts: 57
2001 Holiday Rambler (Cummins ISC330)- No Start Issue

Looking for some help here,

So I went to start my 2001 Holiday Rambler Endeavor with the ISC 330 diesel this past weekend, and it started right up, but after about 45 seconds, the engine shut down and it would not restart. It will crank, but not run.

The fuel filters were changed about 6,000 ago, so I don't think its clogged filters. Fuel tank is reading over 1/2 full. I thought maybe air in the system so I cracked the bleeder nut on fuel line on top of the high pressure fuel pump (down stream of the lift pump) and had my wife crank the engine. NOT a drop of fuel was making it to the HPFP. I then checked for 12v at the Lift Pump.
When holding a volt meter to both the +/- power leads to the Lift Pump coming from the wiring harness, "0" voltage is observed when my wife cranked the engine.

Could a failed Transient Suppressor be the issue? I don't have an engine scanner for the RV, and I am not sure what type scanner to buy/rent; so I cannot see if any codes are present.

BTW, in 2018 I had the Lift Pump replaced at Cummins ($$), and in 2021 the High Pressure Fuel Pump was replaced as that failed ($$$$), so I cannot believe they would have failed this soon.

I'm open to offers for help?
Iceking69 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-01-2022, 03:09 PM   #2
Senior Member
 
jacwjames's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Posts: 12,347
First thing I would do is confirm how much fuel is in the tank. I do not rely on my fuel gauge, it is not accurate at all.

Does your generator run???
The lift pump is suppose to run for only ~30-45 seconds and you should be able to hear it when you turn the key and walk back to the passenger side engine area.



Although filter being clogged is unlikely it's not out of the realm of possibilities. When was the last time you filled up? Do you use any type of fuel additive like Biobor? How long was the rig sitting? When I know my rig will be parked for a little while I always make sure the tank is full and I use both Biobor and Startron.



Do you have a primary filter with the clear bowl on the bottom, can you see anything in it. Probably the first thing to try is changing the primary filter. When you pull it off look at it and see if you can see any algae. Put on a new one and cycle the key 5 times without starting listening for the lift pump. Can you see fuel going to the filter if you have a clear bowl.
__________________
Jim J
2002 Monaco Windsor 38 PKD Cummins ISC 350 8.3L
2005 Jeep Grand Cherokee w/5.7 Hemi
jacwjames is offline   Reply With Quote
Reply

Tags
cummins, holiday rambler, no start



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cummins isc330 2001 no boost gorlininc1 Cummins Engines 14 01-20-2022 08:56 PM
Adding a Carter Lift Pump 2001 Monaco ISC330 Dave727 Cummins Engines 2 10-30-2019 01:35 AM
Cummins caps pump ISC330 DougW Newmar Owner's Forum 4 12-13-2013 11:33 AM
After Market Cummins ISC330 Muffler Logthumper Cummins Engines 35 09-21-2010 02:28 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 01:46 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.