RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-07-2020, 10:20 PM   #1
Senior Member
 
VegasFoodGuy's Avatar
 
Join Date: Nov 2012
Posts: 237
2006 Diplomat Water pump sporadic

We are presently on the road, Columbia Missouri. My water pump switch would not activate the water pump.Two days later turned pump on and it worked.
Now quit working again, when i hit one of the three switches, the light comes on and goes out when I release switch.

Please help.

Terry
__________________
Reno, Nv
2006 Monaco Diplomat PAQ
Jeep Grand Cherokee & Wrangler Toads
VegasFoodGuy is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-07-2020, 11:17 PM   #2
Senior Member
 
Join Date: Jul 2016
Posts: 608
We have the same problem. I've replaced the pump, all switches and the intellitec latching relay. The system can work fine for a long time and then all of a sudden the switches go out and the pump stops.

From researching on here, it's a fairly common problem with a multiple switching system. It's apparently a grounding issue. I have yet to be able to fix the issue. I simply just bypass the switches by taking the load and ground leads off the latching relay and connect them together with a 10 amp blade fuse.
__________________
Irishguy
2003 Monaco Windsor PST
Toad: 2008 Jeep Wrangler
irishguy is offline   Reply With Quote
Old 10-12-2020, 02:20 PM   #3
Senior Member
 
VegasFoodGuy's Avatar
 
Join Date: Nov 2012
Posts: 237
Quote:
Originally Posted by irishguy View Post
We have the same problem. I've replaced the pump, all switches and the intellitec latching relay. The system can work fine for a long time and then all of a sudden the switches go out and the pump stops.

From researching on here, it's a fairly common problem with a multiple switching system. It's apparently a grounding issue. I have yet to be able to fix the issue. I simply just bypass the switches by taking the load and ground leads off the latching relay and connect them together with a 10 amp blade fuse.
Thanks for your help, I didn't have wifi until today. I will use your fix when I get home, for now i spliced a pigtail into the waterpump ground. I ran to the door attachment for ground, installed a 12 volt switch and it worked. When activated the lights come on for all 3 switches. A quick fix if you are on the road. I thought this may help others.

Terry.
__________________
Reno, Nv
2006 Monaco Diplomat PAQ
Jeep Grand Cherokee & Wrangler Toads
VegasFoodGuy is offline   Reply With Quote
Old 10-12-2020, 06:51 PM   #4
Senior Member
 
Join Date: Jul 2016
Posts: 608
Your pigtail temp fix is basically the same thing, perhaps better as you have a quick on and off switch.

If you find a permanent fix for the problem, please let me know.

An RV tech told me that running new wiring from the pump with a single switch mounted to a convenient spot in the coach is the easiest way to fix the problem. The downside is then we would only have one switch as opposed to the current 5 switches. He said somewhere in the multi-switch system it's grounding out and turning off the switches.
__________________
Irishguy
2003 Monaco Windsor PST
Toad: 2008 Jeep Wrangler
irishguy is offline   Reply With Quote
Reply

Tags
diplomat, water, water pump



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
98 Diplomat with sporadic heater problem Racer_C Monaco Owner's Forum 3 09-06-2020 07:28 PM
Another (sporadic)Coleman Mach Basement Heat Pump Problem Petesflhtk Winnebago Industries Owner's Forum 7 03-13-2017 06:49 PM
Sporadic fuel pump Manftar New Member Check-In 7 05-02-2014 11:04 AM
Battery disconnect sporadic operation kokpelli National RV Owner's Forum 3 08-08-2012 10:21 AM
Generator cycling on and off (sporadic electricity) or maybe a ATS question? jumper bob RV Systems & Appliances 6 05-17-2010 10:38 PM


All times are GMT -6. The time now is 11:40 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.