RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-15-2012, 10:06 AM   #1
Junior Member
 
Join Date: May 2012
Posts: 4
air system problem 2008 Ambassador

I have a 2008 Holiday Rambler Ambassador, 39', 360 Cummins. I am having a problem with the air system (for air ride). The "rear air" system takes ofrever to come up to a pressure that will release the alarm for low pressure. It never does go as high as it did before (or up to par with the front) and seems to hover just over minimum and alarms and shows low air pressure intermittently.
PReviously both front and rear ran somewhere around 100+lbs, adjusting of course for different conditions, but generally in that area. Now the rear barely makes 75, front works as always.
Service company here says that the air is actually working fine with no leaks, but that the gauge/sensor is not.. They say it needs a new panel cluster, the whole gauge panel assembly. But they are having great difficulty finding one.
Any ideas or anyone seen this problem before. Or any ideas where one might find an assembly? The "new Monaco" not much help.
Any input would be great
Thanks,
__________________

longhornjoe is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-15-2012, 10:21 AM   #2
Senior Member
 
Monaco Owners Club
Join Date: Feb 2011
Location: Signal Hill, California
Posts: 3,317
longhornjoe have you checked other "threads" on this subject? I believe I've seen others with similar issues. Sorry I can't recall the fix. deSanford
__________________

__________________
Sanford, Linda & R cats: Molly, Levi, Cody
2011 Monaco by Navistar RV
Good Sam Life Member Good Sam Hams Chapter
deSanford is offline   Reply With Quote
Old 05-15-2012, 06:20 PM   #3
Senior Member
 
Join Date: Jul 2000
Posts: 3,023
The dash gauges are very inacurate. Mine sometimes show about 80 lbs. but when I use the Alladin the pressure is 125! BUT I have never had the alarm come on. This is serious and you need to find the problem asap as that rear tank could be connected to your air brakes via a relay valve.
__________________
Moisheh
2008 Dynasty 42' Diamond IV
1988 Bluebird PT38
2009 Silverado Toad
moisheh is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 11:00 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×