RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-06-2014, 04:20 PM   #1
Junior Member
 
Join Date: Mar 2013
Posts: 23
Aladdin

My screen will not light up does anyone have the same 2005 year

thanks
__________________

ecurbing is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-06-2014, 05:09 PM   #2
Senior Member
 
Pusherpilot's Avatar
 
Monaco Owners Club
Join Date: Jul 2001
Location: SD
Posts: 1,022
ecurbing, what model motorhome do you have and what screen are you referring to?
Ron
__________________

__________________
2004 HR Imperial
Pusherpilot is offline   Reply With Quote
Old 10-06-2014, 05:15 PM   #3
Senior Member
 
Twomed's Avatar
 
Monaco Owners Club
Join Date: Oct 2009
Location: On the road
Posts: 1,734
Check for reset switch. Usually in cabinet on outside wall above driver seat, sometimes on dash. Usually marked Aladdin, sometimes VM spec.
__________________
Happy Trails,
06 Dynasty Countess III ISL//3060
07 Hummer H3
Twomed is offline   Reply With Quote
Old 10-06-2014, 05:31 PM   #4
Junior Member
 
Join Date: Mar 2013
Posts: 23
Quote:
Originally Posted by Pusherpilot View Post
ecurbing, what model motorhome do you have and what screen are you referring to?
Ron
I have a 2005 Monaco ex the alladden up front does not light up
ecurbing is offline   Reply With Quote
Old 10-06-2014, 05:34 PM   #5
Junior Member
 
Join Date: Mar 2013
Posts: 23
Quote:
Originally Posted by Twomed View Post
Check for reset switch. Usually in cabinet on outside wall above driver seat, sometimes on dash. Usually marked Aladdin, sometimes VM spec.
I have did the switch I can get the radio to work by trial and error but the screen does not come on ,its a touch screen
ecurbing is offline   Reply With Quote
Old 10-06-2014, 08:49 PM   #6
Senior Member
 
DtBt's Avatar
 
Monaco Owners Club
Join Date: Apr 2010
Location: Saint Leonard,MD
Posts: 747
Do you have a rear bedroom monitor? Does that work? That will help to isolate the problem in the monitor or the Aladdin system itself. When you operate the joystick the front monitor should come alive. Monaco used several different configurations. My Panther uses the Sony backup monitor for the Aladdin while other coaches used the input on the Navigation display.
The Aladdin system has been abandoned by Monaco. There is an Aladdin Troubleshooting manual. If you can't find it let me know and I will provide it
__________________
2005 Safari Panther Diamond IV Cat C13
2013 Avalanche Toad
DtBt is offline   Reply With Quote
Old 10-06-2014, 10:45 PM   #7
Senior Member
 
Bob&AnnaMari's Avatar
 
Join Date: Mar 2009
Posts: 949
Ah, the radio in our rig is on the chassis battery and the Aladdin system is on the house battery. Do you have your power switch on? I missed this one when we first got our coach and the screen would not light.
Bob
__________________
2003 Beaver Patriot
2014 Honda CRV Toad
Bob&AnnaMari is offline   Reply With Quote
Old 10-18-2014, 07:44 AM   #8
Junior Member
 
Join Date: Mar 2013
Posts: 23
sorry Ihave been away tried that
ecurbing is offline   Reply With Quote
Old 10-19-2014, 09:26 PM   #9
Member
 
Join Date: Apr 2013
Posts: 87
Who made the display monitor, the name on the frame? also does the backup camera work?, have you checked all the possible fuses?
RonD1 is offline   Reply With Quote
Old 12-12-2014, 09:51 AM   #10
Senior Member
 
vettehead's Avatar
 
Monaco Owners Club
Join Date: Feb 2012
Location: Mississsippi
Posts: 181
I also have the same problem as you. Front screen would not light up. My front unit is Kenwood. Rear screen worked fine. After contacting Monaco tech. I narrowed it to the front monitor. Only one wire feeds the screen from the Aladdin control box. I hooked that one wire to a TV to verify system is operational and front screen to be bad.
Now waiting on local audio store to supply a monitor that I can plug into the original hole in the dash. Monaco technical and Silverleaf were very helpful.
Hope this give some help in repairing yours.
__________________
Phil & Carolyn (Retired)
2006 Monaco Executive
ISX Cummins 525 hp
vettehead is offline   Reply With Quote
Old 12-13-2014, 08:09 AM   #11
Junior Member
 
Join Date: Mar 2013
Posts: 23
thanks Rick when you get yours could you e mail me as im in mexico and will get one as soon as I leave here in Feb Thanks All the best this season |Bruce
ecurbing is offline   Reply With Quote
Old 12-15-2014, 07:19 AM   #12
Senior Member
 
vettehead's Avatar
 
Monaco Owners Club
Join Date: Feb 2012
Location: Mississsippi
Posts: 181
Be glad to Bruce. I installed a new 7" screen last Sat. morning and all works fine now.
You an I probably have the same system. Only troubleshooting will tell if the problem is the same. Will help if if you need me. Phil
__________________
Phil & Carolyn (Retired)
2006 Monaco Executive
ISX Cummins 525 hp
vettehead is offline   Reply With Quote
Old 01-02-2015, 09:14 AM   #13
Junior Member
 
Join Date: Mar 2013
Posts: 23
Best greetings to you and yours im interested in the name and brand of your new monitor or screen , as im in mexico will get one in feb 2015 My e mail is ( brucealain@hotmail.com)
ecurbing is offline   Reply With Quote
Old 01-03-2015, 11:58 AM   #14
Senior Member
 
vettehead's Avatar
 
Monaco Owners Club
Join Date: Feb 2012
Location: Mississsippi
Posts: 181
The unit I replaced my defective Kenwood with is an Fahrenheit, Model# TID 893.
It is AM/FM radio capable, that I did not hook up. All I wanted was the Monitor. Easy hook up as one battery wire, ground, and Video feed.
Haven't discovered any problems yet.
__________________

__________________
Phil & Carolyn (Retired)
2006 Monaco Executive
ISX Cummins 525 hp
vettehead is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 11:48 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×