Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-04-2022, 11:40 AM   #1
Member
 
HartsRving's Avatar
 
Monaco Owners Club
Join Date: Jun 2010
Location: Ridgecrest, CA
Posts: 95
All sensors reading 3/4 full when empty on 1999 Monaco Windsor

Has anyone had a problem with all their sensors all of a sudden read 3/4 full when empty? Is the controller possibly bad or what?
__________________
Gene & Sharon Hart
1999 Monaco Windsor 34 No Slides
HartsRving is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-04-2022, 12:52 PM   #2
Senior Member
 
jacwjames's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Posts: 11,693
I looked at my wiring diagram and it shows one 15 amp fuse that powers all the sensors. Not sure where the fuse is but it might be in the main 12 volt fuse panel, which in my case is in the bedroom.

There is also a common ground for all the level gauges. I'd check the ground connection, which may be behind the face of the panel. Each sensor has a ground at it's location but if all are showing the wrong reading I'd think it might be the common ground.
__________________
Jim J
2002 Monaco Windsor 38 PKD Cummins ISC 350 8.3L
2005 Jeep Grand Cherokee w/5.7 Hemi
jacwjames is online now   Reply With Quote
Old 05-04-2022, 04:23 PM   #3
Member
 
HartsRving's Avatar
 
Monaco Owners Club
Join Date: Jun 2010
Location: Ridgecrest, CA
Posts: 95
Quote:
Originally Posted by jacwjames View Post
I looked at my wiring diagram and it shows one 15 amp fuse that powers all the sensors. Not sure where the fuse is but it might be in the main 12 volt fuse panel, which in my case is in the bedroom.

There is also a common ground for all the level gauges. I'd check the ground connection, which may be behind the face of the panel. Each sensor has a ground at it's location but if all are showing the wrong reading I'd think it might be the common ground.


Thank you we’ll check that out. Just strange with all the sensors (LP, Black & Gray tanks as well as the fresh water) happened at the same time.
__________________
Gene & Sharon Hart
1999 Monaco Windsor 34 No Slides
HartsRving is offline   Reply With Quote
Old 05-04-2022, 08:07 PM   #4
Senior Member
 
jacwjames's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Posts: 11,693
That's why I think it may be a common ground at the level display.
__________________
Jim J
2002 Monaco Windsor 38 PKD Cummins ISC 350 8.3L
2005 Jeep Grand Cherokee w/5.7 Hemi
jacwjames is online now   Reply With Quote
Old 06-18-2022, 08:39 PM   #5
Member
 
HartsRving's Avatar
 
Monaco Owners Club
Join Date: Jun 2010
Location: Ridgecrest, CA
Posts: 95
All sensors reading 3/4 full when empty on 1999 Monaco Windsor

Jacwjames sorry we didn’t get back to you sooner. We did take the RV into the shop but no luck they want to put in a new monitor. Today we found the main fuse box you stated could have a bad fuse. No luck finding a bad fuse. All ground wires are intact. Any other suggestions before buying a new tank monitor? If needing to buy new tank monitor which one would be suggested? We have the large old style with Windsor name on it. Thank you for your help.
__________________
Gene & Sharon Hart
1999 Monaco Windsor 34 No Slides
HartsRving is offline   Reply With Quote
Old 06-19-2022, 08:03 AM   #6
Senior Member
 
Join Date: Apr 2018
Posts: 2,006
Buy a Sea level 2 system, Bluetooth one is so nice to use. Tank sensors just stick onto the outside of the tanks. You can easily install it yourself.
shootist is online now   Reply With Quote
Old 06-22-2022, 12:03 AM   #7
Senior Member
 
Join Date: Mar 2019
Posts: 125
Yes - get the Garnet sea Level2 monitor.
I re-used the wires (didn’t use about half of them). Also installed a second monitor in my wet bay - so I can see how full my water is as I am filling.

Having accurate numbers in 3% increments is totally great! I did it all myself.

Good Luck
__________________
Michael Loosle
2000 Monaco Dynasty 36’
2018 Jeep JKU
Rocketman3 is offline   Reply With Quote
Old 07-01-2022, 01:55 AM   #8
Member
 
Join Date: Sep 2021
Location: California
Posts: 72
Also, check the sensor foil. Mine has fall off the tank itself, thus, it cant be accurate at all. I stick it back, and it works again. But, as people also says, they are not that great anyways. I used SeeLevel II on 2 RVs now, they are one of the best upgrades.
Sinyyl is offline   Reply With Quote
Old 07-01-2022, 05:06 AM   #9
Senior Member
 
153stars's Avatar
 
Join Date: Mar 2019
Location: Braidwood Il.
Posts: 5,908
Another system to consider . Originally Larson installed on my 95 Monaco Signature. still works fine .Mine feeds VDO analog gauge along with LP tank. Now Tech-Edge. Some sellers descriptions kind of suck main system comes with 3tank sensors kits. Goes about $220-250.
https://tankedge.com/
__________________
95 Monaco Crown Royale
M11 400hp, 4060 trans.
Aquahot, Generac Guardian7.5k
153stars is offline   Reply With Quote
Reply

Tags
1999, monaco, wind, windsor



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Potable tank empty, reading 1/3 full Kiss4aFrog RV Systems & Appliances 3 10-22-2019 11:11 AM
Monaco Windsor :: 2005 Monaco Windsor Frankintx iRV2 Owners Registry 0 06-06-2019 04:01 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 07:58 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.