Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-18-2021, 04:10 PM   #1
Senior Member
 
Join Date: Jul 2011
Location: Acra, NY
Posts: 108
Alt alarm on dash

Went to start rv and after started got alt alarm/light. Gauge shows alt charging above 13v. I check batteries while running and showed 13.6v on house & chassis. All connections on batteries are tight and clean. Alt wires are good also. What else should I check??
MSgtNobody is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-18-2021, 04:17 PM   #2
Senior Member
 
Join Date: Oct 2014
Posts: 3,937
Was this at start-up or after the engine had warmed up a little??


The INTAKE MANIFOLD HEATER draws a LOT of current when the engine is cold.
__________________
Brett Wolfe
Ex: 2003 Alpine 38FDDS. Ex: 1997 Safari Sahara. Ex: 1993 Foretravel U240
wolfe10 is offline   Reply With Quote
Old 10-18-2021, 04:47 PM   #3
Senior Member
 
Join Date: Jul 2011
Location: Acra, NY
Posts: 108
I let the engine warm up for about 20 minutes then shut off. Went back about 5 min. and when I started engine got the alarm.
MSgtNobody is offline   Reply With Quote
Old 10-18-2021, 04:55 PM   #4
Senior Member
 
Join Date: Jul 2014
Posts: 29,049
Is it on shore power while running ?

Both charging systems running can fool the Alt light system.
twinboat is online now   Reply With Quote
Old 10-18-2021, 05:41 PM   #5
Senior Member
 
fastcat's Avatar
 
Monaco Owners Club
Join Date: Dec 2011
Location: Oregon
Posts: 476
What twinboat said. If I start the engine while the motorhome is plugged in to shore power, inverter/charger working, my alternator light will come on.
__________________
Dick & Theresa
2007 HR Endeavor 36 PDQ
400 ISL
fastcat is offline   Reply With Quote
Old 10-18-2021, 07:34 PM   #6
Senior Member
 
Join Date: Jul 2011
Location: Acra, NY
Posts: 108
It was'nt plugged in.
MSgtNobody is offline   Reply With Quote
Old 10-19-2021, 06:34 AM   #7
Member
 
Join Date: Jul 2019
Location: Cary, NC
Posts: 87
Depending on alternator, may have an in-line fuse for the alarm circuit. Have you checked it?
__________________
2005 Monaco Diplomat 40 DST
DanEllis is offline   Reply With Quote
Old 10-19-2021, 07:51 AM   #8
Senior Member
 
Join Date: Jul 2011
Location: Acra, NY
Posts: 108
No I have not. I have mechanic that installed new alternator in spring coming to check it out.
MSgtNobody is offline   Reply With Quote
Old 10-20-2021, 06:40 AM   #9
Member
 
Join Date: Jul 2019
Location: Cary, NC
Posts: 87
What year/model is your coach?
Odds are your alternator cannot communicate with the alarm system. I recently bought a 2005 Diplomat. The ALT light is lit constantly and the beep alarm is disconnected but the alternator works correctly as evidenced by gauge and VMSpc. Previous owner replaced the alternator twice without solving the problem. This problem has been mentioned in several posts on this forum. Many people recommend rebuilding the OLD alternator since new alternators lack the proper wire for communicating with the alarm circuit relay. Not an option for me but everything works so no worries.
__________________
2005 Monaco Diplomat 40 DST
DanEllis is offline   Reply With Quote
Old 10-20-2021, 02:50 PM   #10
Senior Member
 
jacwjames's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Posts: 10,023
On my coach there is an in-line fuse back at the alternator. In the wiring diagram there is a Alt Fail relay that is what send the signal to the dash. Not sure where the relay is, I think it may just be loose in my front run bay. It is a Hamsar 6 volt relay.
__________________
Jim J
2002 Monaco Windsor 38 PKD Cummins ISC 350 8.3L
2005 Jeep Grand Cherokee w/5.7 Hemi
jacwjames is online now   Reply With Quote
Old 10-20-2021, 03:14 PM   #11
Senior Member
 
Join Date: Jul 2011
Location: Acra, NY
Posts: 108
I have a 2008 Monaco Lapalma XL
MSgtNobody is offline   Reply With Quote
Old 10-20-2021, 03:57 PM   #12
Senior Member
 
jacwjames's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Posts: 10,023
Do you have a wiring diagram?
__________________
Jim J
2002 Monaco Windsor 38 PKD Cummins ISC 350 8.3L
2005 Jeep Grand Cherokee w/5.7 Hemi
jacwjames is online now   Reply With Quote
Old 10-20-2021, 06:35 PM   #13
Senior Member
 
Join Date: Jul 2011
Location: Acra, NY
Posts: 108
No I dont
MSgtNobody is offline   Reply With Quote
Old 11-02-2021, 02:21 PM   #14
Member
 
Join Date: Nov 2018
Location: Clermont, FL
Posts: 52
All you need to monitor alternator performance is a volt meter gauge in your dash cluster. If you have 14.2 volts while driving, your alternator is working fine. Not sure why they would put an electronic alternator monitor in a motorhome.
DougJames65 is offline   Reply With Quote
Reply

Tags
dash



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dashboard says "Alt Charge" with an audible alarm Cyanne RV Systems & Appliances 7 10-14-2018 08:09 PM
Alt light and alarm only when climbing pass Banshee Ben Monaco Owner's Forum 4 06-28-2017 12:49 PM
Alt Charge Alarm xydial Monaco Owner's Forum 4 03-26-2017 03:40 PM
Alt Charge lite and alarm obwahn Monaco Owner's Forum 11 04-17-2016 01:48 PM
alt charge alarm ? cummins isb thmdamit Cummins Engines 5 01-28-2011 08:59 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 07:53 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.