Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-05-2014, 06:41 AM   #1
Senior Member
 
jeepsrule's Avatar
 
Monaco Owners Club
Join Date: Nov 2009
Posts: 377
Atwood hot water tank problem

I'm having an intermittent problem with my hot water tank. At times it does not come on and heat water. At other times it works fine but then does not reheat after a shower. This happens on both electric and propane. If I go out and wiggle the controller electronic board on the tank it will light up and kick on. I've cleaned all the electrical connections but to no avail. Any thoughts? Do I have a controller going bad?


Randy
2005 Monaco Diplomat 40ft PDQ
Towing a Jeep Liberty
Full Timers
__________________
2005 Diplomat 40PDQ, Jeep Cherokee Toad
Randy, Pam & Rascal (150lb Rottweiler in a Jack Russell Terrier body)
jeepsrule is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-05-2014, 05:14 PM   #2
Junior Member
 
Join Date: Apr 2014
Posts: 17
I just went through this with the thermostat, mine would not shut off so the water overheated and the pressure relief valve opened. I checked the thermostat using a combination of the following:

Lawn mower battery
Standard 12v test probe with light
Electric hot plate
Some additional wires with alligator clips attached


After connecting the electric leads I placed the thermostat on the hot plate and turned the power on to low. I held the thermostat down on the heating element with my finger and you could tell right away if the thermostat is working as it should, mine was not so I replaced it with another Atwood adjustable thermostat that I ordered from Amazon, $34. Everything works good now, an easy fix.


Good luck!


Bill
Black Smoke is offline   Reply With Quote
Old 05-06-2014, 08:14 AM   #3
Senior Member
 
Gorlininc's Avatar
 
Monaco Owners Club
Join Date: Jun 2012
Location: Merritt Island, FL
Posts: 1,742
I'm pretty sure the 120v and LP circuits are totally separate. I had a problem with my LP board. I bought one on eBay. The LP heater gets the water hotter than the 120v heating element.
Gorlininc is offline   Reply With Quote
Reply

Tags
atwood, tank, water



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
American Coach: Water Tank Bypass Drain troyrice76 Fleetwood Owner's Forum 8 03-18-2014 08:33 PM
Hot water tank cleaning Pilot135pd RV Systems & Appliances 7 01-20-2014 08:40 AM
Hot water heater not sparking smittythebea RV Systems & Appliances 6 07-26-2013 08:57 AM
Axle hits water tank 2010 Surveyor Tom3205 Forest River Owners Forum 11 04-29-2013 01:19 PM
Atwood & Suburban water heaters & Furnace "007" RV Systems & Appliances 1 08-07-2010 09:37 PM


All times are GMT -6. The time now is 02:09 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.