Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-26-2021, 11:03 AM   #1
GCS
Member
 
Join Date: Oct 2013
Posts: 35
Brake lights not working

Here’s the scene: 2008 Holiday Rambler 40SFT. The problem: both rear break lights quit working, the middle third light works fine. I checked the bulbs, they’re good. With the third light working, pretty much ruled out the switch. Turn signals, running lights and back-up light work OK. Next, was to check the fuse. I opened the forward door drivers side to check for a fuse in the panel. Looked for it on the panel listing to no avail. Also checked the bedroom closet circuit panel, just in case it might be there. It’s not. My question that I need help with is: WHERE IS THE BREAK LIGHT FUSE?? Any help would be greatly appreciated!
__________________
Guy & Cindy with our Shelties Toni and Teddy
2008 HR Endeavor 40SFT 400 Cummins 2020 Jeep Wrangler Sahara
GCS is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-26-2021, 07:24 PM   #2
Senior Member
 
Join Date: Apr 2010
Location: schaghticoke, new york
Posts: 424
look in battery compartment lot of fuses in there if it is similar to 2008 Knight
doublechevy is offline   Reply With Quote
Old 09-26-2021, 07:28 PM   #3
Senior Member
 
Join Date: Apr 2010
Location: schaghticoke, new york
Posts: 424
your signature does not match coach you are inquiring about


rambler or endeavor ?
doublechevy is offline   Reply With Quote
Old 09-26-2021, 11:11 PM   #4
Member
 
scott 61's Avatar
 
Holiday Rambler Owners Club
Join Date: Feb 2017
Location: Oregon
Posts: 82
I have an 08 Holiday Rambler Endeavor I think the fuses are on the passenger side last compartment all the way towards the back
__________________
08 Holiday Rambler endeavor skq 400 Cummins
scott 61 is online now   Reply With Quote
Old 09-27-2021, 07:51 AM   #5
GCS
Member
 
Join Date: Oct 2013
Posts: 35
Thanks all for the suggestions. Still looking, once i find it, I’ll repost and let everyone know where it was found.
__________________
Guy & Cindy with our Shelties Toni and Teddy
2008 HR Endeavor 40SFT 400 Cummins 2020 Jeep Wrangler Sahara
GCS is offline   Reply With Quote
Old 09-28-2021, 05:09 PM   #6
Junior Member
 
Join Date: Sep 2021
Posts: 2
I have a 2006 Monaco Dynasty with same problem with brake lights and tow plug. I have 1 fuse in the front run box and another on circuit board 2 in ther rear run box. Both fuses are good and still no brake lights all though turn signals emergency flashers, tail lights and center cyclops brake light all work. Monaco's schematics show brake light signal wiring going to brake light assemblies making a 5th wire. Brake lights are Ford Van lights and are standard 4 wire automotive light assemblies. I am thinking there must be a 3 to 2 wire converter somewhere that must be bad. I don't know if you have the wiring diagrams, but mine show the rear run box in 2006 was used for the Navigator as well as my Dynasty. It is located on the rear passenger side just above the hydraulic reservoir. Board 2 is located onn the top left of the rear run box.
racerjar8 is offline   Reply With Quote
Old 09-30-2021, 03:14 PM   #7
Senior Member
 
RobRoy's Avatar
 
Join Date: Nov 2014
Posts: 1,531
My trailer lighting converter is mounted in the rt rear of the engine compartment and it was taped to and existing harness and I had to look around some time to find it the first time around.

In 7 years I have replaced 2 - 3 tail light converters ... So I installed weather pak connectors on the converter and the harness and a prepped a spare also .... so now it's a quick plug and play should it fail again.... cheap insurance IMO


Happy Trails
__________________
2004 HR Navagator 500 ISM
RobRoy is offline   Reply With Quote
Old 10-06-2021, 05:28 PM   #8
GCS
Member
 
Join Date: Oct 2013
Posts: 35
Thanks again to all who gave suggestions. The break light fuse is in the small panel inside the last compartment on the passenger side of my 2008 HR Endeavor 40 SFT. Thanks Scott 61 for your info!! Glad to get the help we got as to where to look. Greatly appreciated!!
__________________
Guy & Cindy with our Shelties Toni and Teddy
2008 HR Endeavor 40SFT 400 Cummins 2020 Jeep Wrangler Sahara
GCS is offline   Reply With Quote
Reply

Tags
light, lights



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear lights not working, brake lights/ turn signals(rear only) and all other lights o Kloussen Monaco Owner's Forum 3 03-24-2021 09:50 AM
Brake Lights not working, but 3rd brake light does? Jeff00NTW National RV Owner's Forum 5 05-13-2019 07:40 PM
Marker lights,clearance lights and brake lights Ahall Entegra Owner's Forum 1 04-18-2014 05:39 AM
turn signals, running lights, tow lights side clearance lights not working gowhiz Tiffin Owner's Forum 3 02-26-2014 07:02 AM
HWH Jacks working, not working and working again? Bob&Pat Winnebago Industries Owner's Forum 6 06-08-2006 04:22 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 09:04 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.