RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-20-2017, 10:17 PM   #1
Senior Member
 
Arby49's Avatar
 
Join Date: Jul 2016
Posts: 580
Dash A/C not cooling

I'm sure this topic has been discussed before, but did not turn up on my search. Just returned from a short trip and the dash a/c quit. Blows plenty of air, but doesn't cool. I have never attempted to work on the a/c unit, so not sure what to do. I do remember something about the Freon used in older units is probably no longer available.

2008 Monaco Dynasty
Roadmasterr Chasis
__________________
Russ & Lois Bell
2008 Monaco Dynasty Yorkshire IV
2013 Ford Flex
Arby49 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-20-2017, 10:23 PM   #2
Community Administrator
 
Spk64's Avatar


 
Newmar Owners Club
Join Date: Apr 2014
Location: Southern Indiana
Posts: 14,337
Dash A/C not cooling

Yours will have the latest freon R-134A like our 2002. First thing you need to do is get a set of gages on it. I had to replace the dryer after having system evacuated then vacuum down the system then do a full refill to the specs on the back of the Evans unit. Worked great but I still have a slow leak somewhere in the 40' of lines.
__________________
Steve
2002 Newmar Mountain Aire 4095

Wash your Hands, Wear a Mask, Social Distance
Spk64 is offline   Reply With Quote
Old 05-20-2017, 10:31 PM   #3
Senior Member
 
Arby49's Avatar
 
Join Date: Jul 2016
Posts: 580
Thanks Spk64. I have 3 weeks to get it done, so will start Monday morning.
__________________
Russ & Lois Bell
2008 Monaco Dynasty Yorkshire IV
2013 Ford Flex
Arby49 is offline   Reply With Quote
Old 05-20-2017, 10:53 PM   #4
Senior Member
 
10Boomer's Avatar


 
Join Date: May 2012
Posts: 2,893
Most issues for leaks stem from the fittings on the hoses. Check fittings on back of pump too. From sniffers help find slow leaks.
__________________
Perry & Julie: 2008 Monaco Camelot 40PDQ, 400ISL, Toad; 2015 Chevy Equinox.
10Boomer is offline   Reply With Quote
Old 05-21-2017, 07:19 AM   #5
Senior Member
 
onechaddude's Avatar
 
Join Date: Jul 2011
Posts: 1,881
I'm following closely here. I noticed Friday on a short run to get new tires installed on the coach my dash a/c wasn't cooling either. It's on my 07 Neptune and has always been cold until all of a sudden on this trip. It's not a huge deal as I usually run genny with overhead air on but i still want it fixed. I guess I'll have to find a shop to look at it. Please keep us posted on what you find. Thanks

Chad
onechaddude is offline   Reply With Quote
Old 05-21-2017, 07:22 AM   #6
Senior Member
 
palehorse89's Avatar
 
Newmar Owners Club
Join Date: Oct 2009
Posts: 8,938
With the engine running, turn it on, and go look to see if the AC compressor clutch has picked up and is turning.........if not, pull the small wire off the AC compressor and see if it has 12 VDC going to the compressor.
If there is 12VDC on the wire, and the clutch is not engaging, it might be low on Freon, and the low pressure switch is not able to pickup to engage the clutch.........the low pressure switch is a safety switch so you don't burn up the compressor. The low pressure switch could also be bad.
__________________
2012 Essex 4544 2011 Jeep JK, M&G Braking, 2014 MTI 27' Hog Hauler, Wireless brake control, 2006 Ultra & 1989 Springer
palehorse89 is offline   Reply With Quote
Old 05-21-2017, 07:28 AM   #7
Senior Member
 
Busskipper's Avatar
 
Join Date: Sep 2007
Location: Grasonville, MD -- Golden, CO
Posts: 5,304
Quote:
Originally Posted by Arby49 View Post
I'm sure this topic has been discussed before, but did not turn up on my search. Just returned from a short trip and the dash a/c quit. Blows plenty of air, but doesn't cool. I have never attempted to work on the a/c unit, so not sure what to do. I do remember something about the Freon used in older units is probably no longer available.

2008 Monaco Dynasty
Roadmasterr Chasis
Topic is never ending, Why? because in my History they never get fixed to work more than 1/2 of the next trip.

So solution for most of us after spending thousands $$ is to fire up the generator and turn on the A/C - works and the Coach is cool when we arrive.

Seems now every year i will put in a large bottle of freon, R-134A - just to leak out - helps in that the A/C is at least not HOT - Have had it repaired three times all lasted less than 500 miles so -

JMHO,

Best of Luck,
__________________
Busskipper
Location - Arnold, Maryland-Sold - Grasonville, Maryland - and/or - Superior, Colorado
2005 Travel Supreme 42DS04 - GX470 toad
Busskipper is offline   Reply With Quote
Old 05-21-2017, 08:08 AM   #8
Senior Member
 
Jeff753's Avatar
 
Monaco Owners Club
Coastal Campers
Join Date: Mar 2012
Posts: 2,088
I'm taking mine in next week. I noticed a bunch of oily fluid on top the generator. I think a line blew or something because then my dash Ac quit. Clutch doesn't engage now.
__________________
Jeff
2001 Monaco Dynasty tag axle
2006 Jeep Wrangler
Jeff753 is offline   Reply With Quote
Old 05-21-2017, 10:13 AM   #9
Senior Member
 
Captjake1's Avatar
 
Monaco Owners Club
Join Date: May 2015
Location: Where I happen to land
Posts: 2,528
I had mine charged last summer. Dead when I went to use it. Shop thought there may be a big leak somewhere. They are going to pure the system, charge with nitrogen, and then hunt for the leak, fix, purge and recharge with refrigerant.
__________________
John and Debi
2008 Beaver Contessa, 2005 Jeep Grand Cherokee,
28 years retired Fire Captain Tales of the Muttley Crew
Captjake1 is offline   Reply With Quote
Old 05-21-2017, 10:19 AM   #10
Senior Member
 
JohnBoyToo's Avatar
 
Monaco Owners Club
Join Date: May 2012
Location: DFW, Tex-US
Posts: 6,067
Mine too, it died on the way back from colorado last august and sorry, all 3 ac's at full tilt will only mitigate the heat coming through that front firewall - it's porous !!!

I waited until this March to get it fixed hoping it would last the summer
__________________
'11 Monaco Diplomat 43DFT RR10R pushed by a '14 Jeep Wrangler JKU. History.. 5'ers: 13 Redwood 38gk(junk!), 11 MVP Destiny, Open Range TT, Winn LeSharo, C's, popups, vans, tents...
JohnBoyToo is offline   Reply With Quote
Old 05-21-2017, 10:20 AM   #11
Senior Member
 
Captjake1's Avatar
 
Monaco Owners Club
Join Date: May 2015
Location: Where I happen to land
Posts: 2,528
Quote:
Originally Posted by JohnBoyToo View Post
Mine too, it died on the way back from colorado last august and sorry, all 3 ac's at full tilt will only mitigate the heat coming through that front firewall - it's porous !!!

I waited until this March to get it fixed hoping it would last the summer
Lol...I found the same thing a few weeks ago....
__________________
John and Debi
2008 Beaver Contessa, 2005 Jeep Grand Cherokee,
28 years retired Fire Captain Tales of the Muttley Crew
Captjake1 is offline   Reply With Quote
Old 05-21-2017, 12:14 PM   #12
Senior Member
 
Monaco Owners Club
Join Date: Jan 2013
Location: Buckeye AZ
Posts: 271
Some engines have the AC on a drive belt of it's own. It's possible you have lost that belt.
monacojim is offline   Reply With Quote
Old 05-21-2017, 04:41 PM   #13
Senior Member
 
onechaddude's Avatar
 
Join Date: Jul 2011
Posts: 1,881
Quote:
Originally Posted by monacojim View Post
Some engines have the AC on a drive belt of it's own. It's possible you have lost that belt.
Mine does have a separate belt. Not sure about the OP as to what his has.I looked up from underneath yesterday and belt looks great. I haven't had a chance yet to check and see if compressor starts or not. Will try this week if I have time to troubleshoot it. Thanks for suggestion.

Chad
onechaddude is offline   Reply With Quote
Old 05-21-2017, 04:54 PM   #14
Senior Member
 
Join Date: May 2010
Posts: 185
a/c warm

I was also blowing air but not even cool so I went to auto parts store and bought the Freon for my 2008 Monaco dynasty and after 2 months it still blows cold. All these coaches will lose Freon so just add the Freon yourself because if you go to a dealer they will make it cold for big bucks.
ken bauer is offline   Reply With Quote
Reply

Tags
cooling, dash



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dash A/C all new but not cooling - Help kustom Class A Motorhome Discussions 30 08-28-2015 08:37 PM
American Coach: A/C Cooling Fan / Radiator / Cooling GlennLever Fleetwood Owner's Forum 11 09-23-2014 04:37 PM
In Dash Air Conditioning not Cooling Buddy Jones Jayco Owner's Forum 3 06-14-2011 10:25 AM
Dash A/C problems poor Cooling ccfulp Country Coach Owners Forum 1 05-12-2011 03:31 PM
Dash A/C not cooling Eagle123 MH-General Discussions & Problems 3 09-04-2010 12:17 PM


All times are GMT -6. The time now is 01:49 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.