Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-20-2021, 10:06 PM   #1
Senior Member
 
Ronbstewart's Avatar
 
Monaco Owners Club
Join Date: Jan 2010
Location: Ohio
Posts: 174
Eng RPM hanging up

94 Monaco executive 8.3 300 Cummins Mechanical fuel system has been operating just fine, but on a recent trip from FL back home to OH I noticed the RPM starting to hang up a bit when getting of the throttle, it will finally drop down, but causes harder than normal braking to stop, throttle system is the original air system that came on it, any thoughts as what the problem could be? I replaced the return spring at fuel pump, problem is not there.
__________________
1994 Executive
Ronbstewart is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-21-2021, 11:43 AM   #2
Senior Member
 
Timaz's Avatar
 
Monaco Owners Club
Join Date: Aug 2017
Location: On the road
Posts: 1,654
Clean & lube pedal linkage and engine linkage? Just a swag.

Tim
__________________
Full Time 2000 Dynasty Regent FD, 8.3, Banks Turbo, 5" Diameter Exhaust, 475 HP 1425 Torque towing 05 Pilot 700 Watts solar 400ah lithium & E-Bike
Timaz is offline   Reply With Quote
Old 03-21-2021, 12:53 PM   #3
Senior Member
 
RamiDav's Avatar
 
Join Date: Jan 2016
Posts: 1,977
I have heard that the mechanical ( no ECM ) engines have a spring on
the engine somewhere that pulls the fuel supply back to idle.

I would get someone to work the throttle with the engine running and
see what moves and if there is a spring there. I said with the engine
running because I think that is when it will move but I may be wrong
about that so you could first try without the engine running.

Sounds like something that needs to be corrected for safety reasons
RamiDav is offline   Reply With Quote
Old 03-21-2021, 12:59 PM   #4
Senior Member
 
Outbound's Avatar
 
Join Date: Jun 2012
Location: NorCal
Posts: 2,971
I would WD-40 the linkage., a little lubricant does wonders.
__________________
Outbound
2002 Monaco Executive 500 ISM
2004 GMC 2500HD 4X4
Outbound is offline   Reply With Quote
Old 03-22-2021, 09:33 AM   #5
Senior Member
 
Ronbstewart's Avatar
 
Monaco Owners Club
Join Date: Jan 2010
Location: Ohio
Posts: 174
Thanks so much for your replies. Replacing Return Spring at engine fuel pump was first action I took, no problem there. had my wife work the foot throttle up front while I checked operation at the engine. Everything worked fine, going to have to take it on the road for 5 miles to get it up to normal temp and check then. got a feeling it has to do with air dump/exhaust valve part of foot throttle that releases air so throttle can retard.
__________________
1994 Executive
Ronbstewart is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Eng elect fans controls for eng a/c cryoman Workhorse and Chevrolet Chassis Motorhome Forum 7 08-06-2010 03:05 PM
Adv. 34D Eng. won't turnover CTC42 Winnebago Industries Owner's Forum 2 09-10-2007 02:53 AM
2005 F250 V-10 w/9,100 miles = MAJOR Eng. Failure Ned Trailer Towing and Tow Vehicles Discussion 11 03-19-2006 02:45 PM
Weight Question about '97 P chassis w/454 eng. Ned Toads and Motorhome Related Towing 2 06-10-2005 07:21 PM
eng door R V WEST Winnebago Industries Owner's Forum 5 01-12-2005 09:34 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 03:06 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.