Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-27-2018, 04:59 PM   #1
Junior Member
 
Join Date: Jan 2018
Posts: 10
Engine and generator will not start

My RV is a 2004 holiday rambler manaco. Neither the generator or the engine will start. I'm not getting a WTS light either. The grid heater circuit is good. Both the engine and generator crank but don't start. I'm thinking fuel since that seems to be all that is common. Any troubleshooting tips will be greatly appreciated!
Mbrown61 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-27-2018, 05:58 PM   #2
Senior Member
 
Pusherpilot's Avatar
 
Monaco Owners Club
Join Date: Jul 2001
Location: SD
Posts: 1,022
How much fuel is in the tank? The generator usually has a pickup in the tank that doesn't allow it to run the tank dry. I don't know if that applies to the pickup for the engine but it could be you're very low on fuel.
__________________
2004 HR Imperial
Pusherpilot is offline   Reply With Quote
Old 01-27-2018, 07:10 PM   #3
Senior Member
 
Monaco Owners Club
Join Date: Jul 2017
Posts: 166
If there is no white smoke while cranking means no fuel. Cranking and no fuel no smoke. This is on engine but think diesel gen should be the same. Don
DiplomatDon is offline   Reply With Quote
Old 01-27-2018, 07:40 PM   #4
Senior Member
 
RamiDav's Avatar
 
Join Date: Jan 2016
Posts: 1,776
How cold is it ?
Diesel will gel if you don't have winter blend .

Ray
RamiDav is offline   Reply With Quote
Old 01-27-2018, 11:34 PM   #5
Junior Member
 
Join Date: Jan 2018
Posts: 6
Sure your ground is good?
Uzumau is offline   Reply With Quote
Old 01-28-2018, 08:12 AM   #6
Junior Member
 
Join Date: Jan 2018
Posts: 10
First of all thanks for the replies! There is plenty of gas and it's not very cold, maybe in the 20s at night. No white smoke so no fuel, makes total sense, thanks. I can't confirm or deny the ground, I'd say it's good but I will definitely check it, thanks.
Mbrown61 is offline   Reply With Quote
Old 01-28-2018, 08:22 AM   #7
Senior Member
 
Join Date: Sep 2012
Posts: 8,055
Quote:
Originally Posted by Mbrown61 View Post
First of all thanks for the replies! There is plenty of gas and it's not very cold, maybe in the 20s at night. No white smoke so no fuel, makes total sense, thanks. I can't confirm or deny the ground, I'd say it's good but I will definitely check it, thanks.
Are you gas or diesel?
nothermark is offline   Reply With Quote
Old 01-28-2018, 08:43 AM   #8
Member
 
Ford Super Duty Owner
Join Date: Oct 2014
Location: Home for now
Posts: 77
I hope you got towed?
fbuckwalter is offline   Reply With Quote
Old 01-28-2018, 09:37 AM   #9
YC1
Senior Member
 
YC1's Avatar


 
Join Date: Jun 2011
Location: FL
Posts: 9,648
If things are cranking the batteries are good. It takes a lot of power to turn the engine over.

Can't do this on the engine since you have a grid heater but you could give the generator a puff of starting fluid. If it tries to run you know for sure it is fuel related.

You generator probably has a priming function???
__________________
Myron & Deborah
08 HR Endeavor 40 SKQ
400 Isl, 400 HP/// Now 450 HP
2016 Ford F150 Limited V6 with Ready Brake
YC1 is offline   Reply With Quote
Old 01-28-2018, 10:10 AM   #10
Junior Member
 
Join Date: Jan 2018
Posts: 10
Generator does have a priming switch in the cab, push switch down to prime up to start.
Mbrown61 is offline   Reply With Quote
Old 01-28-2018, 10:29 AM   #11
Senior Member
 
RustyTools's Avatar
 
Monaco Owners Club
Join Date: Feb 2008
Posts: 2,148
I'm always interested to learn from others and their experiences and outcomes. In this instance, I had a somewhat similar problem several years ago - turned out to be a very bad case of algae in the fuel tank. Hope the OP gets things going.

I'm not sure we're getting the full story here, he's also posting the same question - with additional information - in the 'Class A Motorhome' forum. Kinda confusing.
RustyTools is offline   Reply With Quote
Old 01-28-2018, 11:06 AM   #12
Senior Member
 
Join Date: May 2014
Posts: 831
You could have gotten some bad fuel. Have you change your fuel filters. Don't use starting
fluid if you have glow plugs and most if not all diesel generators have glow plugs.
__________________
Peter
36 ft 98 Dynasty
98 Suzuki Sidekick Sport 4 door
oldguy70 is offline   Reply With Quote
Old 01-28-2018, 02:19 PM   #13
Senior Member
 
RustyTools's Avatar
 
Monaco Owners Club
Join Date: Feb 2008
Posts: 2,148
More confusing by the moment. Seems the OP is spending a lot more time on the Class A forum explaining his predicament. And turns out it's 'his friends' coach now.

We still don't know what model, year, or anything else about it. Nor why he's "sure" it's not the grid heater circuit.

RustyTools is offline   Reply With Quote
Reply

Tags
engine, generator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine and generator will not start Mbrown61 Class A Motorhome Discussions 20 01-28-2018 09:53 AM
Will not start and Allison transmission key pad does not light on start Jeff753 Monaco Owner's Forum 28 12-03-2017 07:54 PM
Sprinter RV 2008 glow plug light will not come on and engine will not start. Dan_Johnston Class C Motorhome Discussions 3 07-04-2017 05:34 PM
1of 4 generator start switches will not start genny Jeff753 Monaco Owner's Forum 6 09-05-2013 08:07 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 04:52 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.