RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-28-2020, 10:42 PM   #1
Senior Member
 
Join Date: May 2016
Location: Prescott Az.
Posts: 199
Help Inverter

Hello everyone, 07 hr headed to the desert for an 11 day boondock. Stopped at my daughters for a night and plugged into her 20 amp power to run the charger and fridge

Well the charger was pulling too many amps, volt meter was at border line so I left the charger n inverter off. Went out for the The day and retuned to find the inverter/charger has no power. I checked the breaker and it was not tripped

Any ideas on the problem, is there another power source to check? Kinda lost here. Thank you,
__________________
Pat and Shelley C.
Prescott Az.
2007 H R Endeavor 40 PDQ, H2 Hummer
gweedo295 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-28-2020, 10:48 PM   #2
Senior Member
 
Join Date: May 2016
Location: Prescott Az.
Posts: 199
I should add The display shows no power.
__________________
Pat and Shelley C.
Prescott Az.
2007 H R Endeavor 40 PDQ, H2 Hummer
gweedo295 is offline   Reply With Quote
Old 10-28-2020, 11:09 PM   #3
Senior Member
 
vsheetz's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Jun 2012
Location: SoCal
Posts: 14,930
How about on generatir power?
__________________
Vince and Susan
2011 Tiffin Phaeton 40QTH (Cummins ISC/Freightliner)
Flat towing a modified 2005 Jeep (Rubicon Wrangler)
Previously a 2002 Fleetwood Pace Arrow 37A and a 1995 Safari Trek 2830.
vsheetz is offline   Reply With Quote
Old 10-28-2020, 11:10 PM   #4
Senior Member
 
vsheetz's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Jun 2012
Location: SoCal
Posts: 14,930
12v voktage ok? 12v switch at entry door on?

Breakers on inverter itself tripped? All other breakers ok?
__________________
Vince and Susan
2011 Tiffin Phaeton 40QTH (Cummins ISC/Freightliner)
Flat towing a modified 2005 Jeep (Rubicon Wrangler)
Previously a 2002 Fleetwood Pace Arrow 37A and a 1995 Safari Trek 2830.
vsheetz is offline   Reply With Quote
Old 10-29-2020, 08:08 AM   #5
Senior Member


 
Monaco Owners Club
Join Date: Mar 2018
Location: Blairsville, GA & WPB, FL
Posts: 3,574
Send a message via ICQ to Ivylog
“Has no power” 12V or 120V? Your batteries should have been charged when you arrived and a residential only draws 1 amp so you should be able to power your rig with 15 amps...something is not right. I can even run one AC on 15amps.
__________________
This post is my opinion, worth what you paid for it.
Our ĒNewĒ ride...08 HR Navigator 45í. A nice upgrade after 14 years with a 04 Dynasty 42í.
Ivylog is online now   Reply With Quote
Old 10-29-2020, 08:14 AM   #6
Senior Member
 
Join Date: May 2016
Location: Prescott Az.
Posts: 199
Good morning,
the breakers on the box not tripped,
I tried the generator, everything powered but still no display on board
Tried the kill switch at door nothing changed

I will add this info: I am plugged into a long power cord, the coach, and 15í 50 amp extender to a 25í 10 gage cord running off a 20 amp outlet. I know Iím loosing some Amps n volts through the long run, but I havenít had issues in the past, the only thing different is, I also have a Dometic fridge/freezer running below.

last night I added a transformer to boost the power going in, slight difference but still no display.

The unit is. Magnum Energy.

Everything has power plugged in, the fridge tv micro etc. Just no power on the magnum display. I am assuming I just canít invert the DC to AC, which is okay for now while boondocking. I have two 2200 Honda Generators I parallel, I can use those for power during the day and at night Iíll run the coach genny.

Iím hoping itís just the display board and not the inverter/charger that took a dump.

Thnx,
__________________
Pat and Shelley C.
Prescott Az.
2007 H R Endeavor 40 PDQ, H2 Hummer
gweedo295 is offline   Reply With Quote
Old 10-29-2020, 08:59 AM   #7
Senior Member
 
Join Date: May 2016
Location: Prescott Az.
Posts: 199
I may be confusing the inverter when I say the fuses were not tripped. On my coach in the last door there is a power box that has two fuses that pop out when the system is over loaded, I simply push them to reset.

Iím thinking this is not the inverter, Iím wonder if the inverter is on the inside near the fuse panel/ breakers. I watched a utube video Iíll look for the inverter unless one of you can tell me where it is. Itís very possible a fuse is bad since the display is dead.
__________________
Pat and Shelley C.
Prescott Az.
2007 H R Endeavor 40 PDQ, H2 Hummer
gweedo295 is offline   Reply With Quote
Old 10-29-2020, 09:25 AM   #8
Senior Member
 
Join Date: May 2016
Location: Prescott Az.
Posts: 199
So the box is the inverter/charger. There is a green light that flashes slowly on n off, I felt a button that u pushed but so far no difference. Hopefully one of the guys in the desert will know something.

Now my wall meter shows a strong 120 volts coming in, it was at 112

Iíll keep guess checking. Thnx again. Any ideas let me know.
__________________
Pat and Shelley C.
Prescott Az.
2007 H R Endeavor 40 PDQ, H2 Hummer
gweedo295 is offline   Reply With Quote
Old 10-29-2020, 03:21 PM   #9
Senior Member
 
153stars's Avatar
 
Join Date: Mar 2019
Location: Braidwood Il.
Posts: 2,001
When ever there is sudden issue on 120v incoming check ATS connections tighten all while in there all, power removed of course. Poor connection can show decent voltage until a load is put on. Someone had a recent issue with Magnum Inv. was able to reset by disconnecting all 120v and 12v important do positive cable not Neg .
__________________
95 Monaco Crown Royale
M11 400hp, 4060 trans.
Aquahot, Generac Guardian7.5k
153stars is online now   Reply With Quote
Old 10-29-2020, 05:34 PM   #10
Senior Member
 
Join Date: May 2016
Location: Prescott Az.
Posts: 199
So the box is the inverter/charger. There is a green light that flashes slowly on n off, I felt a button that u pushed but so far no difference. Hopefully one of the guys in the desert will know something.

Now my wall meter shows a strong 120 volts coming in, it was at 112

Iíll keep guess checking. Thnx again. Any ideas let me know.

Iím in the desert. One of my 2200 Hondaís runs everything. Still no display. Hopefully tomorrow I can troubleshoot.
__________________
Pat and Shelley C.
Prescott Az.
2007 H R Endeavor 40 PDQ, H2 Hummer
gweedo295 is offline   Reply With Quote
Old 10-30-2020, 05:35 AM   #11
Senior Member
 
Join Date: May 2016
Location: Prescott Az.
Posts: 199
I have a friend who is pretty familiar with electrical. We checked the connections, pressed the on off and by looking in from the outside everything is pointing to the remote locAted inside the coach.

All connections are tight (even though these washboard roads in the desert usually loosens something, lol) I looked on u tube a found a place in Arizona Bodour I think the name is, that works on these things. I sent them an email and go from there. Probably end up taking it to them.

For now all electrical works perfectly on shore or gen power.

Thanks for the responses, always comforting to know IRV2 is always there!!!!

Guido...
__________________
Pat and Shelley C.
Prescott Az.
2007 H R Endeavor 40 PDQ, H2 Hummer
gweedo295 is offline   Reply With Quote
Old 10-31-2020, 07:31 AM   #12
YC1
Senior Member
 
YC1's Avatar


 
Holiday Rambler Owners Club
Join Date: Jun 2011
Posts: 8,203
Have you exercised the phone type connectors used to connect the remote and inverter?

What model inverter? Here is all of the files I have on ours.

Did you do the reset suggested??? Turn off batteries, remove any 110 volt sources, disconnect any solar. This allows a good reset on the inverter.


https://1drv.ms/u/s!Aqrv2TUdbV6xjndp...4fC5P?e=PhafMs
__________________
Myron & Deborah
08 HR Endeavor 40 SKQ
2016 Ford F150 Limited V6 with Ready Brake
Aluminator tow bar, Demco base plate
YC1 is offline   Reply With Quote
Old 11-01-2020, 10:58 AM   #13
Senior Member
 
Join Date: May 2016
Location: Prescott Az.
Posts: 199
Thank you for the manual info, this will be helpful.
__________________
Pat and Shelley C.
Prescott Az.
2007 H R Endeavor 40 PDQ, H2 Hummer
gweedo295 is offline   Reply With Quote
Old 11-02-2020, 06:39 PM   #14
Senior Member
 
Join Date: May 2016
Location: Prescott Az.
Posts: 199
Hard reset

Thnx to YC1. I read the manual n I contacted a service shop, Monroe in Oregon. The gentleman there was very helpful.

So I did a soft reset n it began inverting but still no display. I did a hard reset (partially) just disconnected the hot n ground from battery, turned of battery selector switches n main breaker , I didnít disconnect ac although it calls for it on a hard reset.

Well it worked, connected power n ground back turned on breaker and it worked, display is functional.

Thank you again for all the responses n for the manual Save some big $$$$
gweedo295 is offline   Reply With Quote
Reply

Tags
inverter



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Please help?! Novice wiring and inverter help needed. johnplesh iRV2.com General Discussion 9 02-10-2018 11:06 AM
Help with Inverter Freedom 25 Inverter Charger MatthewChase Monaco Owner's Forum 6 08-17-2017 06:46 AM
Help, Help, Help, Oh Please Help. Possum RV Systems & Appliances 11 04-23-2012 11:35 PM
inverter/charger or just inverter bdawson11 RV Systems & Appliances 10 06-14-2009 10:48 AM
Simple Inverter Hook Up? Plug my 50 amp to the inverter? E Z Livin MH-General Discussions & Problems 7 12-19-2005 03:59 AM


All times are GMT -6. The time now is 09:42 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.