RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-22-2020, 06:04 AM   #1
Junior Member
 
Join Date: Jul 2016
Posts: 3
Holbrook, 08 Beaver 42 ft

10,000 Onan Gen. will not keep running. Have changed fuel filter and checked all fluid levels, nothing changed. Has anyone else had this problem and found a solution?
holbrook is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-22-2020, 06:40 AM   #2
Senior Member
 
CountryB's Avatar
 
Monaco Owners Club
Join Date: Aug 2017
Location: Orlando, Florida
Posts: 5,300
Check the settings in your gen controller to make sure it is not set to auto-shutoff when the batteries reach a certain state of charge. (on my Coach the settings are made through the Xantrex (Inverter/Charger) panel.

So, for example, if the programmed setup is to start generator automatically when battery voltage drops to 12.0 and then shutoff automatically when batteries reach 12.6V, it may be that batteries are already over 12.6 so once generator is manually started it reads battery voltage and then auto shuts off.
__________________
Mike --- 2005 Beaver Patriot Thunder CAT C13 525HP, Vicksburg 42ft, with HydraLift ---
*SMC-Bvr-Mnco History/Chassis Info https://1drv.ms/f/s!AtvAXw_lfqbToxXYREK9YdBP08Jn
*SMC-Bvr-Mnco Wiring Diagrams https://1drv.ms/f/s!AtvAXw_lfqbTm0WTuuNqpn9a8hCh
CountryB is offline   Reply With Quote
Old 06-22-2020, 06:42 AM   #3
Senior Member
 
jacwjames's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Posts: 7,671
Check your manual and find the procedure to recover the blink codes. I can recover my blink codes by pressing the STOP switch 3 times within 5 seconds. It will then go through a sequence of blink codes. Once you get the codes you can check what they mean. Without these there could be a number of causes.



How many hours on the generator???
__________________
Jim J
2002 Monaco Windsor 38 PKD Cummins ISC 350 8.3L
2005 Jeep Grand Cherokee w/5.7 Hemi
jacwjames is offline   Reply With Quote
Old 06-22-2020, 08:22 AM   #4
Senior Member
 
pduggs's Avatar
 
Monaco Owners Club
Join Date: Mar 2014
Location: Somewhere Nice
Posts: 936
My 10k Onan genset has recently started pulsating and quivering, then it would shut down. It will easily restart, but then do the same thing. You need to get the code.

https://www.irv2.com/forums/f54/1000...ng-476733.html
__________________
2008 Monaco Dynasty Squire
Paul & Luci
Fulltimers
pduggs is offline   Reply With Quote
Reply

Tags
beaver



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Beaver, Beaver, Beaver, can't get Her outta my Head !!! ---nota___ Monaco Owner's Forum 14 06-07-2017 01:53 PM
Silver City,NM to Holbrook,AZ ? Lester Navigation, Routes & Roads 3 09-13-2013 04:20 PM
77 State Rd. Holbrook Az. to Hwy. 60 Riverc Navigation, Routes & Roads 1 08-01-2013 02:14 AM
Tucson to Holbrook wil01 Navigation, Routes & Roads 1 04-29-2013 05:11 PM
Help stuck in holbrook, arizona garrydt Caterpillar Engine Forum 1 06-15-2012 10:21 AM


All times are GMT -6. The time now is 04:04 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.