RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-03-2017, 03:50 PM   #1
Member
 
Join Date: Mar 2017
Posts: 78
HWH Air Leveling Issue

I have a 2003 Monaco Windsor 40PST with the hwh air only leveling system. When the system goes into leveling mode and the system raises the front past a certain point it starts releasing air out of the ride height valve exhaust tube. The air bags don't deflate but will continue to release air until either the tank runs out of air or I manually lower the front below this point. What could be causing this issue? Could it be the travel solenoids as I am also have issues with the front returning to ride height? Thanks for your help.
__________________

Coreyph is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-03-2017, 03:56 PM   #2
Senior Member
 
Mr_D's Avatar
 
Country Coach Owners Club
Winnebago Owners Club
Solo Rvers Club
iRV2 No Limits Club
Join Date: May 2011
Location: Vancouver, WA
Posts: 36,660
I have the same leveling system but I've never heard of your problem.
__________________

__________________
2009 45' Magna 630 w/Cummins ISX 650 HP/1950 Lbs Ft
Charter Good Sam Lifetime Member, FMCA, SKP
RV'ing since 1957, NRA Benefactor Life, towing '14 Jeep JKU Dragon Edition
Mr_D is offline   Reply With Quote
Old 11-03-2017, 04:01 PM   #3
Senior Member
 
CountryB's Avatar
 
Monaco Owners Club
Join Date: Aug 2017
Location: Orlando, Florida
Posts: 4,565
I would start by checking the air/ride height adjustment on the front bags valve.
__________________
Mike ----- 2005 Beaver Patriot Thunder CAT C13 525HP, 42-ft Tag, with HydraLift
*SMC-Bvr-Mnco History/Chassis Info https://1drv.ms/f/s!AtvAXw_lfqbToxXYREK9YdBP08Jn
*SMC-Bvr-Mnco Wiring/Air Diagrams https://1drv.ms/f/s!AtvAXw_lfqbTm0WTuuNqpn9a8hCh
CountryB is offline   Reply With Quote
Old 11-03-2017, 04:57 PM   #4
Senior Member
 
Flyin4Fun's Avatar
 
Join Date: Dec 2015
Posts: 203
The ride height exhaust tube is dumping air until tank is empty, but the elevation of the front end does not lower at all? In other words while air is being discharged the level isn't changing up or down, correct?
Flyin4Fun is offline   Reply With Quote
Old 11-03-2017, 06:26 PM   #5
Senior Member
 
DtBt's Avatar
 
Monaco Owners Club
Join Date: Apr 2010
Location: Saint Leonard,MD
Posts: 746
My guess your travel valve is not disabling like it should when you go to manual or auto level mode. Check the coil resistance of that valve. Check out the service manual for your model. You might have a series 2000 system. Here is the service manual for that.
https://www.hwhcorp.com/ml31043.pdf
__________________
2005 Safari Panther Diamond IV Cat C13
2013 Avalanche Toad
DtBt is offline   Reply With Quote
Old 11-04-2017, 02:40 PM   #6
Senior Member
 
mydogmax's Avatar
 
Join Date: Jul 2017
Location: Cental Texas
Posts: 341
What brand air system do you have? I have air only and its firestone. Got a program from whoever owns Monaco now and reprogramed the system and it works great!
__________________
2005 Monaco Windsor, 40 ft single axle.
TRW GB, Watts front and watts x braces rear. 2013 GMC 2500HD toad.
mydogmax is offline   Reply With Quote
Old 11-06-2017, 07:54 PM   #7
Member
 
Join Date: May 2014
Location: Largo, Fl.
Posts: 90
It sounds like the Travel Solenoid Valve is leaking. When you go into the leveling mode this valve closes and shuts the air supply to the ride height valve, so if you have pressure there the valve must be bad. It's not a solenoid problem because the power is removed from the valve to put it in the closed position.
__________________

traveler999 is offline   Reply With Quote
Reply

Tags
air, hwh, leveling



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HWH air leveling issue ldfeat Country Coach Owners Forum 4 04-12-2016 01:36 PM
HWH air leveling issue ldfeat Class A Motorhome Discussions 0 04-07-2016 06:03 AM
HWH leveling System "Not leveling" TheToads Winnebago Industries Owner's Forum 5 12-04-2013 03:51 PM
HWH Leveling System Problems & No Air In Air Shocks K5EAG MH-General Discussions & Problems 19 09-24-2010 09:20 PM
HWH Leveling Issue waynehartwig MH-General Discussions & Problems 7 09-07-2010 10:22 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 03:33 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×